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Lab Prerequisites  

Following prerequisites and setup must be complete for successful completion of the exercise: 

• You must be connected to the internet. 

• Signup for Power BI: Go to http://aka.ms/pbidiadtraining and sign up for Power BI with a business 

email address. If you cannot sign up for Power BI, let the instructor know. 

• If you have an existing account, please go to http://app.powerbi.com and Sign in using your 

Power BI Account. 

• At minimum, a computer with 2-cores and 4GB RAM running one of the following version of 

Windows: Windows 10, Windows 7, Windows 8 (64-bit preferred), Windows 8.1, Windows Server 

2008 R2, Windows Server 2012, Windows Server 2012 R2. 

• Microsoft Power BI Desktop requires Internet Explorer 9 or greater.  

• Verify if you have 32-bit or 64-bit operating system to decide if you need to install the 32-bit or 64-

bit applications.  

o Search for computer on your PC, right click properties for your computer.  

o You will be able to identify if your operating system is 64 or 32 bit based on “system type” 

as shown below.  

 

• Download the Power BI Content: Create a folder called DIAD on the C drive of your local machine. 

Copy all contents from the folder called Dashboard in a Day Assets on the flash drive to the DIAD 

folder you just created (C:\DIAD).  

• Download and install Power BI Desktop using any one of the options listed below: 

o If you have Windows 10, use Microsoft App Store to download and install Power BI Desktop 

app.  

o Download and install Microsoft Power BI Desktop from http://www.microsoft.com/en-

us/download/details.aspx?id=45331. 

 

 

 

http://aka.ms/pbidiadtraining
http://app.powerbi.com/
http://www.microsoft.com/en-us/download/details.aspx?id=45331
http://www.microsoft.com/en-us/download/details.aspx?id=45331
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Document Structure  

   This document has two main sections: 

• Power BI Desktop: This section highlights the features available in Power BI Desktop and walks the 

user through the process of bringing in data from the data source, modeling and creating 

visualizations. 

• Power BI Service: This section highlights the features available in Power BI Service including the 

ability to publish the Power BI Desktop model to the web, creating and sharing dashboard and 

Power Q & A. 

The document flow is in a table format. On the left panel are steps the user needs to follow and in the 

right panel are screenshots to provide a visual aid for the users. In the screenshots, sections are 

highlighted with red boxes to highlight the action/area user needs to focus on. 

 

 

NOTE:  This lab is using real anonymized data and is provided by ObviEnce LLC. Visit their site to learn 

about their services: www.obvience.com .    
This data is property of ObviEnce LLC and has been shared for the purpose of demonstrating PowerBI 

functionality with industry sample data.   Any uses of this data must include this attribution to ObviEnce 

LLC.   

http://www.obvience.com/
http://www.obvience.com/


Version: 07.10.2018  Copyright 2018 Microsoft     5 | P a g e  
Maintained by:  Microsoft Corporation    

Overview    
Introduction  
Today you will be learning various key features of the Power BI service. This is an introductory course 

intended to learn how to author reports using Power BI Desktop, create operational dashboards and share 

content via the Power BI Service.   

Data Set   
The dataset you will you use today is a sales and market share analysis.  This type of analysis is very 

common for the office of a Chief Marketing Officer (CMO).  Unlike the office of the Chief Financial Officer 

(CFO), a CMO is focused not only on company’s performance internally (how well do our products sell) but 

also externally (how well do we do against the competing products).  

The company, VanArsdel, manufactures expensive retail products that could be used for fun as well as 

work and it sells them directly to consumers nationwide as well as several other countries.   

Workshop Outline  
1. Power BI Desktop   

2. Power BI Service 

3. Bring your own data to build a dashboard 

4. Q&A 
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Power BI Desktop   
Power BI Desktop - Accessing Data  
In this section, you will import VanArsdel and its competitors USA sales data. Then you import and merging sales 

data from other countries.  

Power BI Desktop - Get Data  
Let’s start with looking at the data files. The 

dataset contains sales data of VanArsdel 

and other competitors. We have 7 years of 

transaction data by day, product and zip 

code for each manufacturer. We are going 

to analyze data from 7 countries. 

 

USA sales data is in a csv file located in 

/Data/USSales folder. 

 

Sales of all other countries is in 

/Data/InternationalSales folder. Each 

country’s sales data is in a csv file in this 

folder. 

 

Product, Geography and Manufacturer 

information is in an excel file in 

/Data/USSales/bi_dimensions.xlsx. 

 

1. Open 

/Data/USSales/bi_dimensions.xlsx. 

Notice the first sheet has Product 

information. The sheet has a header and 

product data is in a named table. Also 

notice Category column has a bunch of 

empty cells. 

 

Manufacturer sheet has data laid out 

across the sheet and with no column 

headers and it has a couple of blank rows 

and a note in row 7. 

Geo sheet has geography information. The 

first couple of rows has data details. Actual 

data starts from row 4. 

We will start by connecting to data from 

these different files and perform data 

cleaning and transformation operations. 
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2. If you don’t have the Power BI Desktop 

open, launch it now. 

3. Select Already have a Power BI 

Account? Sign in option. 

4. Sign in using your Power BI credentials. 

5. Startup screen opens. Click on X on the 

top right corner of the dialog to close 

it. 

 
 
 

 
Let’s set up the locale to US English, to 

make it convenient to go through the rest 

of this lab. 

 

6. From the ribbon, select File -> Options 

and settings -> Options. 

7. In the left panel of Options dialog, 

select Regional Settings. 

8. From the Locale drop down select 

English (United States). 

9. Select OK to close the dialog. 

 
First step is to load data to Power BI 

Desktop. We will load USA Sales data 

which is in comma separated value (CSV) 

files. 

 
10. From the ribbon, select Home -> Get 

Data. 

11. Select Text/CSV. 

 

Note: Power BI Desktop has the capability 

to connect to 70+ data sources. We are 

using csv and excel data files in this lab for 

simplicity.   

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-data-sources/
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12. Browse to DIAD\Data\USSales folder 

and select sales.csv.   

13. Click Open. 

  
Power BI detects the data type of each 

column. There are options to detect the 

data type based on the first 200 rows or 

based on the entire dataset or not detect 

it. Since our dataset is large and it will take 

time and resources to scan the complete 

data set, let’s leave the default option of 

selecting dataset based on the first 200 

rows. 

After completing your selection, you have 

three options – Load, Edit or Cancel.   

• Load, loads the data from the 
source into Power BI Desktop for 
you to start creating reports.   

• Edit allows you to perform data 
shaping operations such as merging 
columns, adding additional 
columns, changing data types of 
columns as well as bringing in 
additional data.   

• Cancel gets you back to the main 
canvas.   

 
14. Click Edit as shown in the screenshot. 

A new window opens. 
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You should be in the Query Editor window 

as shown in the screenshot to the right. 

Query Editor is used to perform data 

shaping operations. Notice the sales file 

you connected to shows as a query in the 

left panel. You see a preview of the data in 

the center panel. Power BI predicts data 

type of each field (based on the first 200 

rows) which is indicated next to the 

column header. In the right panel, steps 

that Query Editor performs are recorded. 

 
Note: You will be bringing in sales data 

from other countries as well as performing 

certain data shaping operations. 

 
15. Notice Power BI has set Zip field to 

data type Whole Number. To ensure 

that Zip codes which start with zero 

don’t lose the leading zero, we will 

format them as text.  Highlight the Zip 

column. From the ribbon, select Home 

-> Data Type and update it to Text. 

16. Change Column Type dialog opens. 

Select Replace Current button which 

overwrites Power BI’s predicted 

datatype. 

 

 
 

  

Now let’s get the data that is in excel 

source file. 

 
17. From the ribbon, select Home -> New 

Source -> Excel. 

    

IMPORTANT! 

Changing the 

data type is a big 

deal to use later 
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18. Browse to DIAD\Data\USSales folder 

and select bi_dimensions.xlsx. 

 
Navigator dialog opens. 

 
19. Navigator dialog lists 3 sheets that are 

in the excel workbook. It also lists the 

Product named table. Select product 

from the left panel and in preview 

panel notice the first row is the 

header. This is not part of the data. 

20. Unselect product from the left panel. 

Select Product_Table. Notice this has 

only the contents of the named table. 

This is the data we need. 

 

Note: Table names are differentiated from 

Worksheet names by using different icons. 

 

21. From the left panel, select geo. In the 

preview panel notice the first couple 

of rows are headers that are not part 

of the data. We will remove them 

shortly. 

22. From the left panel, select 

manufacturer. In the preview panel 

notice the last couple of rows are 

footers that are not part of the data. 

We will remove them shortly. 

23. Select OK. (Make sure Product_Table, 

geo and manufacturer are selected in 

the left panel) 

Notice all 3 sheets are added as queries in 

the Query Editor. 
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Power BI Desktop - Adding additional data  
International subsidiaries have agreed to provide their sales data so that the company’s sales can be analyzed 

together.  You’ve created a folder where they will each put their data. 

To analyze all the data together you will 

want to import the new data from each of 

the subsidiaries and combine it with the 

US Sales you loaded earlier. 

 
24. Click on the New Source drop down 

in the Home menu tab of the Query 

Editor. 

25. Select More… as shown in the figure. 

 
Get Data dialog opens. 

     

26. In the Get Data dialog select Folder as 

shown in the diagram. 

27. Click Connect.  
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Folder dialog opens. 

28. Click Browse… button. 

29. In the Browse for Folder dialog 

navigate to the location where you 

unzipped the class files. 

30. Open the DIAD folder. 

31. Open the Data folder. 

32. Select the InternationalSales folder. 

33. Click OK (to close the Browse for 

Folder dialog box). 

34. Click OK (to close the Folder dialog 

box). 

 
Note: This approach uses folders instead 

of individual files. This will load all files in 

the folder.  This is useful when you have a 

group that puts files on an ftp site each 

month and you are not always sure of the 

names of the files or the number of files. 

All the files must be of the same file type 

with columns in the same order. 

  

Dialog displays the list of files in the 

folder. 

 

35. Since we want to combine data, click 

Combine & Edit. 

 

Note: Date accessed, Date modified and 

Date created might be different compared 

to the dates displayed in the screenshot. 

 

Combine Files dialog opens. By default, 

Power BI again detects the data type 

based on the first 200 rows. 

Notice there is an option to select various 

file Delimiters. The file we are working 

with is Comma delimited, so let’s leave 

Delimiter option as Comma. 

There is also an option to select each 

individual file in the folder (using Example 

File dropdown) to validate the format of 

the files. 
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36. Select OK. 

You will be in the Query Editor window 

with a new query called 

InternationalSales.   

37. If you do not see the Queries pane on 

left, click on the > icon to expand.  

38. If you do not see the Query Settings 

pane on the right as shown in the 

figure, click on View in the ribbon and 

click Query Settings to see the pane.  

39. Click on the Query InternationalSales. 

 

Notice that column Zip is of type Whole 

Number. Based on the first 200 rows 

Power BI thinks Zip is of type Whole 

Number. But zip code could be alpha 

numeric in some countries or leading 

zeros (similar to USA data). If we do not 

change the data type, we will see an error 

when we load the data shortly. So, let’s 

change Zip to data type Text. 

 

40. Highlight the Zip column and change 

the Data Type to Text. 

41. Change Column Type dialog opens. 

Select Replace Current button. 

 

 

In Queries panel, notice Transform File 

from InternationalSales folder is created. 

This contains the function used to load 

each of the files in the folder. 

 

If you compare InternationalSales and 

sales table, you will see the 

InternationalSales table contains two 

new columns, Source.Name and Country. 

 

 

IMPORTANT! 

Changing the data 

type is a big deal 

to use later 
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42. We do not need Source.Name 

column. Select Source.Name column. 

From the ribbon, select Home -> 

Remove Columns -> Remove 

Columns. 

 

 

 

43. Click on the drop down next to 

Country column to see the unique 

values.  

44. You will only see Australia as shown 

in the figure. Click on Load more to 

validate you have data from various 

countries included. 

 

You will see the countries, Australia, 

Canada, Germany, Japan, Mexico and 

Nigeria.  

 

45. Click OK. 

 

Note: You can perform various types of 

filters, sorting operations using the drop 

down to verify the imported data.  

 

 

 

Power BI Desktop – Data Preparation 
In this section, we will explore methods to transform data in the data model. Transforming the data by renaming 

tables, updating data types, and appending tables together ensures that the data is ready to be used for reporting. 

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-shape-and-combine-data/
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In some instances, this means cleaning the data up so that similar sets of data are combined. In other instances, 

groups of data are renamed so that they are more recognizable by end users and simplifies report writing. 

Power BI Desktop - Renaming tables 
The Query Editor window should appear 

as shown in the diagram.  

• If formula bar is disabled, you can turn 

on the formula bar from the View 

ribbon. This enables you to see the 

“M” code generated by each click on 

the ribbons. 

• Select the options available on the 

ribbon – Home, Transform, Add 

Column and View to notice the 

various features available.  

 
1. Under Queries panel, minimize 

Transform Files from InternationalSales 

folder. 

2. Select each query name in the Other 

Queries section. 

3. Rename them in the Query Settings -> 
Properties section as shown below: 

 

Initial Name Final Name 

sales Sales 

geo Geography 

manufacturer Manufacturer 

Product_Table Product 

InternationalSales International 
Sales 

  
Note: It is best practice to give descriptive 
query names and column names. These 
names are used in visuals and in Q&A 
section, which is covered later in the lab. 
 

    

 

 

Power BI Desktop – Using Fill feature  
Some of the data provided is not in the right format. Power BI provides extensive transformation capabilities to 

clean and prepare the data to meet our needs. Let’s start with Product query. Notice that Category column has a lot 

of null values. Looks like there are values in Category column only when the value changes. We need to fill it down 

to have values in each row. 
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4. From the left panel, select Product 

Query.  

5. Select Category column. 

6. From the ribbon select Transform -> Fill 

-> Down. 

 
Notice now all the null values are filled 
with the appropriate Category values. 

 
  

 
 

Power BI Desktop – Using Split feature  
 

In Product query, notice that the Product column. Looks like two fields are concatenated into one field with a pipe 

(|) separator. Let’s split them into two columns. This will be useful when we build visuals, so we can analyze based 

on both fields. 

7. From the left panel, select Product 

Query.  

8. Select Product column. 

9. From the ribbon select Home -> Split 

Column -> By Delimiter. Split Column by 

Delimiter dialog opens. 

10. In the dialog, make sure Custom is 

selected in the Select or enter delimiter 

dropdown. 

Note: Select or enter delimiter dropdown 

has some of the standard delimiters like 

comma, colon, etc. 

11. Notice in the text area, there is a 

hyphen (-). Power BI assumes we want to 

split by hypen. Remove hyphen symbol 

and enter pipe symbol (|) as shown in the 

screenshot. 

12. Select OK. 
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Note: If the delimiter occurs multiple 

times, Split at section provides option to 

split only once (either left most or right 

most) or the column can be split on each 

occurrence of the delimiter. 

 

In this scenario delimiter occurs only 

once, hence Product column is split into 2 

columns. 

 

Power BI Desktop – Using Rename Column feature  

Let’s rename the columns. 

13. Select Product.1 column. Right click 

next to the column name. 

14. Select Rename from the selection 

dialog. 

15. Rename the field to Product. 

16. Similarly rename Product.2 to 

Segment. 

17.  

 
   

 

Power BI Desktop – Using Column From Examples feature  
 

In Product query, notice that the Price column. You will see price and currency concatenated into one field. To do 

any calculations we just need the numeric value. It will be good to split this field into two columns. We can use the 

split feature like earlier or we can use Column From Examples. Column From Examples is handy in scenarios where 

the pattern is more complex than a delimiter. 
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18. From the left panel, select Product 

Query.  

19. From the ribbon, select Add Column -

> Column From Examples. 

20. In the first row of Column1 enter the 

first Price value which is 412.13 and click 

enter. 

Notice as you enter, Power BI knows that 

you want to split Price column. The 

formula it uses is displayed as well. 

21. Double click column header Text 

Before Delimiter to rename it. 

22. Rename the column to MSRP. 

23. Click OK to apply the changes. 

 
   

Notice MSRP field is of data type text. It 

must be a decimal. Let’s change it. 

24. Select ABC in MSRP column. 

25. From the selection dialog, select 

Decimal Number. 

 

Notice all the steps we performed on the 

Product query are being recorded under 

APPLIED STEPS in the right panel.  

 

Similarly, let’s create a currency column. 

26. From the left panel, select Product 

Query.  

27. From the ribbon, select Add Column -

> Column From Examples. 

28. In the first row of Column1 enter the 

first Currency value as USD and click enter 

Notice as you enter, Power BI knows that 

you want to split Price column. The 

formula it uses is displayed as well. 

29. Double click column header Text 

After Delimiter to rename it. 

30. Rename the column to Currency. 

31. Click OK to apply the changes. 
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Now that we have split Price into MSRP 

and Currency columns, we don’t need 

Price column. Let’s remove it. 

32. From the left panel, select Product 

Query.  

33. Right click next to Price column. 

34. Select Remove. 

 

Power BI Desktop – Using Add/Remove Rows feature  
 

In Geography query, notice that first two rows are informational. It is not part of the data. Similarly, in Manufacturer 

query the last couple of rows are not part of the data. Let’s remove them so we have a clean dataset. 

35. In the left panel, select Geography 

query. 

36. From the ribbon, select Home -> 

Remove Rows -> Remove Top Rows. 

37. Remove Top Rows dialog opens. Enter 

3 in the text box, since we want to 

remove the top 2 informational data rows 

and the blank 3rd row. 

38. Select OK. 

 

Notice the first row in Geography query 

now is the column header. So let’s make it 

a header. 

39. With Geography query selected in the 

left panel, from the ribbon select Home -> 

Use First Row as Headers. 

Notice column Zip is of data type number. 

Let’s change it to text as we did earlier. If 

we don’t we will see errors when we load 

the data. 

40. Select 123 next to Zip Column. From 

the dialog, select Text. 

41. Select Replace Current in the Change 

Column Type dialog. 
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42. From the left panel, select 

Manufacturer query. Notice the bottom 3 

rows are not part of the data. Let’s 

remove it. 

43. From the ribbon, select Home -> 

Remove Rows -> Remove Bottom Rows 

44. Remove Bottom Rows dialog opens. 

Enter 3 in Number of rows text box. 

45. Select OK. 

 

Power BI Desktop – Using Transpose feature  
 

46. From the left panel, select 

Manufacturer Query. Notice 

ManufacturerID, Manufacturer and Logo 

data is laid across in rows. And the header 

is not useful. We need to transpose the 

table to meet our needs. 

47. From the ribbon select Transform -> 

Transpose.  

 

Notice this transposes the data into 

columns. Now we need the first row to be 

the header. 

 
  

48. From the ribbon select Home -> Use 

First Row As Headers. 

 
Notice now Manufacturer table is laid out 
the way we need it with a header and 
values along columns. 
Notice on the right panel under APPLIED 
STEPS you will see the list of 
transformations and steps that have been 
applied.  
You can navigate through each change 
made to the data by clicking on the step. 
Steps can also be deleted by clicking on 
the X that appears to the left of the step.  
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The properties of each step can be 
reviewed by clicking on the gear to the 
right of the step.  

 

Power BI Desktop – Using Append and Conditional Column feature  
To analyze the Sales of all countries, it is 

convenient to have a single Sales table. 

Hence you want to append all the rows 

from International Sales to Sales.   

49. Select Sales in the Queries window in 

the left panel as shown in the figure. 

50. From the ribbon select Home -> 

Append Queries. 

Append dialog opens. There is an option 

to append Two tables or Three or more 

tables. Leave Two tables selected since 

we are appending just two tables. 

51. Select International Sales from the 

drop down and click OK. 

 

You will now see a new column in the 

Sales table called Country.  Since 

International Sales had the additional 

column for Country, Power BI Desktop 

added the column to the Sales table when 

it loaded the values from International 

Sales. 

You see null values in the Country column 

by default for the Sales table rows 

because the column did not exist for the 

table with USA data. We will add the 

value “USA” as a data shaping operation.  

52. From the ribbon select Add Column -> 

Conditional Column. 
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53. In the Add Conditional Column dialog, 

enter name of the column as 

“CountryName”. 

54. Select Country from the Column 

Name dropdown. 

55. Select equals from the Operator 

dropdown. 

56. Enter null in the Values text. 

57. Enter USA in the Output text. 

58. Select the dropdown under Otherwise 

and pick Select a column option. 

59. Select Country from the column 

dropdown. 

60. Click OK. 

This reads, if Country equals null then the 

value is USA else value is that of Country. 

  

61. You will see the CountryName column 

in the Query editor window. 

 

The original Country column is only 

required as a temporary column. It is 

not required in the final table for 

analysis and can be removed.    

62. Right click on the Country column and 

select Remove as shown in the figure. 

We can now rename CountryName 

column to Country.  

63. Right click on the CountryName 

column and rename to Country. 

64. Using Home -> Data Type, change the 

data type of the Country column to type 

Text. 

When the data is refreshed, it will process 

through all the “Applied Steps” that you 

have created. 
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The newly named Country column will 
have names for all countries, including the 
USA.  
You can validate this by clicking on the 
drop down next to Country column to see 
the unique values.  
 
65. At first, you will only see USA data. 

Click on Load more to validate you have 

data from all 7 countries.  

66. Click OK to close this filter. 

 

Typically, when exploring data, we load a 

subset of data. There are multiple ways to 

do this. From the ribbon, select Home -> 

Keep Rows -> Keep Top Rows OR Home -

> Keep Rows -> Keep Bottom Rows OR 

Home -> Keep Rows -> Keep Range of 

Rows. You can use any of these options to 

filter down to a subset of data. 

Our dataset has data from 2011 to 2017. 

For our analysis we want to start with the 

last 3 years of data (2015-2017). We don’t 

know how many rows. We can filter by 

year to get the subset. 

67. Select the arrow next to Date in Sales 

Query. 

68. Select Date Filters -> In the Previous… 

69. Filter Rows dialog opens. Enter 3 in 

the text box next to is in the previous. 

70. Select years from the dropdown. 

71. Select OK. 
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Now that International Sales data is 
appended to Sales, we don’t need the 
International Sales table to load to the 
data model. Let’s prevent International 
Sales table from loading to the data 
model.  
 
72. From the Queries panel on the left, 

select International Sales query. 

73. Right click and select Enable Load. 

This will disable loading International 

Sales. 

 

Note: The appropriate data from the 

International Sales table will load into the 

Sales table each time the model is 

refreshed. By removing the International 

Sales table, we are preventing duplicate 

data from loading into the model and 

increasing its file size. In some instances, 

storing very large amounts of data affects 

the data model performance. 

 

   

74. From the ribbon select View -> Query 

Dependencies. 

 

This opens Query Dependencies dialog. 

The dialog shows the source of each of 

the queries and dependencies. E.g. We 

see that Sales query has a csv file source 

and it has a dependency on International 

Sales query. This is a useful self-document 

that can be used to share knowledge with 

your team members. 

 

75. Select Close in the dialog. 

 

Query Dependencies view can be zoomed 
in and out as needed.  
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You have successfully completed import 
and data shaping operations and are 
ready to load the data into the Power BI 
Desktop data model which allows you to 
visualize the data.  
 
76. Click on File -> Close & Apply. 

   

All the data will be loaded in memory 
within Power BI Desktop. You will see the 
progress dialog with the number of rows 
being loaded in each table as shown in 
the Figure.  
 
Note: It may take several minutes to load 
all the tables. 
 
77. Select File -> Save to save the file 

after the data loading is completed. Name 

the file as “MyFirstPowerBIModel”. Save 

the file in \DIAD\Reports folder. 

  

  

 

Power BI Desktop – Data Modeling and Exploration 
In this section, we will learn the key parts of the Power BI desktop, to model and explore the data and build visuals. 

Power BI Desktop - Layout   
You will land on the main Power BI 

Desktop window. Let’s get familiar with 

the distinct sections available in the 

Power BI Window. 

 

1. On the top, you see the Home tab 

where the most common operations 

you perform are available. 

2. View tab has options to format the 

page layout.  

3. Modeling tab in the ribbon enables 

additional data modeling capabilities 
 

 

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-query-overview/
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like adding custom columns and 

calculated measures.   

4. Help tab provides self-help options like 

guided learning, training videos and 

links to online communities, partner 

showcase, solution templates. 

 

 

    

5. The Fields window on the right panel, 

is where you will see the list of tables 

which were generated from the 

queries. Click the   icon next to a 

table name to expand to the field list 

for that table. 

6. Visualizations panel on the right allows 

you to select visualizations, add values 

to the visuals and add columns to the 

axes or filters. 

7. The center white space is the canvas 

where you will be creating visuals. 

8. On the left side, you have three icons, 

Report, Data and Relationships. If you 

hover over the icons, you can see the 

tool tips. Switching between these 

allows you to see the data and the 

relationships between the tables. 

9. Click on the Data icon. Expand Sales 

table in the Fields as shown in the 

figure 

Scroll up and down to notice how fast you 

can navigate through ~ 3 Million rows.   
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10. Click on the Relationships icon on the 

left panel of Power BI Desktop. 

You will see the tables you have imported 

along with some Relationships. The 

Power BI Desktop automatically infers 

relationships between the tables. 

o Relationship is created between 

Sales and Product tables using 

ProductID column. 

o Relationship is created between 

Product and Manufacturer tables 

using ManufacturerID column. 

Power BI Desktop supports 1 to many or 1 

to 1 relationships between the tables. 

This means one of the tables involved in 

the relationship should have a unique set 

of values. 

Notice there is no relationship between 

the Geography and Sales tables. If you 

want to explore sales data across state or 

city or country, you will need to setup the 

relationship between the Geography and 

Sales tables. You will create the 

relationship shortly. 

Note: Tables may not appear as shown in 

the figure. You can zoom in and out of the 

Relationships page by dragging the zoom 

slider in the bottom right corner of the 

window. Also, if want to ensure you are 

seeing all the tables, use the fit to page 

icon: . Drag and move the tables to 

appear as shown in the figure. 

 

  

  

Power BI Desktop - Modeling and Data exploration   
In this section, you will do initial data exploration along with model enhancements to create a calculated column 

and set up relationships. 
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We loaded data from different countries. 

So let’s start with analyzing sales by 

country. 

1. Click on the Report icon on the left 

panel to navigate to the Report view. 

2. Select the Clustered column chart 

visual in Visualizations as shown in the 

screenshot.  

 

3. From the FIELDS section, expand 

Geography table and select Country field. 

4. From the FIELDS section, expand Sales 

table and select Revenue field. 

5. Resize the visual as needed by dragging 

the edges. 

Notice revenue of each country is the 

same. This is because there is no 

relationship between Sales and 

Geography tables. Let’s create one. 

Note: You now need to set up the correct 

relationship between these tables.  

To create a relationship between the two 

tables we need a “joining” or “relating” 

column.   

 

6. Click on the Relationships icon on the 

left panel to navigate to the Relationship 

view. 

7. Sales data is by Zip code. Hence, we 

need to connect Zip column from Sales 

table with Zip column in Geography table. 

You can do this by dragging the Zip field 

in Sales table and connecting the line 

with Zip field in Geography table. 

 

You will see a message stating that you 

can’t create a relationship because one of 

the columns must have unique values.  

The reason we don’t have unique Zip 

values in Geography is because multiple 

countries could have the same Zip code. 

Let’s concatenate Zip and Country 

columns to create a unique value field. 
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We need to create a new column in both 

the Geography table and the Sales table 

that combines “Zip” and “Country”. Let us 

start by creating a new column in the 

Sales table.  

8. Click on the Report icon on the left 

panel to navigate to the Report view. 

9. In the Fields section, click on the 

ellipsis next to Sales table. Select “New 

Column” as shown in the figure. 

You will see a formula bar appear as 

shown in the screenshot to help create 

this new column. 

10. We can combine or concatenate the 

Zip and Country columns into a new 

column called ZipCountry separated by a 

comma. Let us create this column called 

ZipCountry using the following calculation 

in the editor. 

 

ZipCountry = Sales[Zip] & "," & 

Sales[Country] 

11. Once you are done entering the 

formula click in the check mark on the left 

side of the formula bar. 

   
 

    

 

 

 

 

You will notice that as you type the 

expression the Power BI desktop guides 

you to choose the right columns using a 

Technology called Intellisense. As you 

type half way through you can select the 

right column by double clicking on it using 

your mouse or by continuing to hit tab 

until you see the correct name.  

The language you used to create this new 

column is called DAX (Data Analysis 

Expression) which is very similar to 

writing expressions in Excel where you 

are concatenating the two columns (Zip 

and Country) in each row by using the 

“&” symbol.  

You will see a new column ZipCountry in 

Sales table. The icon with a (fx) indicates 

    

 
 

 

 

 

 

   

IMPORTANT! 

If you get an error 

creating a new column 

here, make sure your Zip 

column is the Text Data 

Type. 

If you still have 

problems, ask! 
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you have a column that contains an 

expression, also referred to as calculated 

column.  

You can also create a new column by 

selecting the table and then clicking on 

Modeling -> New Column from the 

ribbon. Let us use this method to create a 

“ZipCountry” column in the Geography 

table.  

 

12. From Fields section, select Geography 

table and from the ribbon select 

Modeling -> New Column as shown in the 

figure. 

13. Formula bar appears. Enter the 

following DAX expression in the formula 

bar:  

ZipCountry = Geography[Zip] & 

"," & Geography[Country]  

You will see a new column ZipCountry in 

Geography table. The final step is to 

setup the relationship between the two 

tables using the newly created 

“ZipCountry” columns in each of these 

tables. 

   

 

14. Click on the Relationships icon on the 

left panel to navigate to the Relationship 

view. 

15. Drag ZipCountry field from Sales table 

and connect it to ZipCountry field in 

Geography table. 

Now we have successfully created a 

relationship. The number 1 next to 

Geography indicates it is on the one side 

of the relationship and * next to Sales 

indicates it is on the many side of the 

relationship.  
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16. Click on the Report icon on the left 

panel to navigate to the Report view. 

Notice the clustered column chart we 

created earlier. It shows different sales 

for each country. USA has the most sales 

followed by Australia and Japan.  

By default, it is sorted by Revenue. 

17. Click on the ellipsis on the top right 

corner of the visual. 

Notice there is option to Sort by Country 

as well.  

 

Now let’s analyze Sales by Country by 

Manufacturer and see if we get more 

insights. 

18. With the Clustered column chart 

selected, from the Fields section expand 

Manufacturer table. 

19. Drag and drop Manufacturer field to 

Legend section. 

 

There are many manufacturers and 

clustered column chart does not 

represent the information well. Let’s 

change the visual. 

 

20. With the Clustered column chart 

selected, from the VISUALIZATIONS 

section select Stacked column chart 

visual. 

21. Resize the visual as needed. 

 

Now we are able to figure out the top 

manufacturers by country. It will be nice 

to narrow down to the top 5 competitors 

to better analyze the data.  
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22. With Clustered column chart selected, 

scroll down to the Visual level filters 

section under VISUALIZATIONS panel. 

23. Expand Manufacturer under Visual 

level filters. 

24. From the Filter Type drop down 

select Top N. 

25. Enter 5 in the text box next to Top. 

26. From the FIELDS section expand Sales 

table. 

27. Drag and drop Revenue field to By 

value section. 

28. Select Apply filter. 

 

Notice now the visual is filtered to display 

the Top 5 manufacturers by Revenue. We 

see that VanArsdel has higher percentage 

of sales in Australia compared to other 

countries. 

 

We are interested in the top 5 

competitors by revenue. Let’s group them 

so we don’t have to add a filter in every 

visual.  

Before we do that let’s remove the Top 5 

visual level filter. 

 

29. With Clustered column chart selected, 

scroll down to the Visual level filters 

section in VISUALIZATIONS panel. 

30. Expand Manufacturer under Visual 

level filters. 

31. Hover over and select the Clear filter 

icon (erase) next to Manufacturer field. 
 

32. From the FIELDS section expand 

Manufacturer table. 

33. Select Manufacturer field. 

34. From the ribbon select Modeling -> 

New Group. Groups dialog opens. 

35. In the Ungrouped values section, 

using Ctrl key, select Aliqui, Currus, 

Natura and Pirum. 
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36. Select Group button. Notice a new 

group is added in the Groups and 

members section. 

37. Double click the newly created group 

and rename it to Top Competitors. 

38. Select VanArsdel from the Ungrouped 

values section and select Group button to 

create VanArsdel Group. 

39. Select the check box Include Other 

group. This will create an Other group 

which will include all the other 

manufacturers. 

40. Select OK to close Groups dialog. 

41. With the Stacked column chart 

selected, click on the X next to 

Manufacturer in the Legend section. This 

will remove Manufacturer. 

42. From the FIELDS section, drag the 

newly created Manufacturer (groups) to 

the Legend section. 

 

Now we can clearly see that VanArsdel 

has nearly 50% share in Australia.  

 

43. Hover over VanArsdel section of the 

Australia column. You will see a tooltip 

with the Revenue. 

44. Hover over Top Competitors section 

of Australia column to get the Revenue 

value. 

 

Let’s find a better way to view the data 

without creating a new visual. 
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45. Hover over one of the columns and 

right click. 

46. Select Show Data. 

You will be in Focus mode with the chart 

displayed on top and the data displayed 

below. It is easy to see that VanArsdel has 

a big percent of the Australian market. 

47. You can use the icon on the top right 

corner to switch to vertical layout. In this 

layout you will view the chart on the left 

and data on the right panel. 

48. Select Back to Report to go back to 

Report canvas. 

 

49. There is also an option to see the 

records. Hover over one of the columns 

and right click. 

50. This time select See Records. 

You will see the detailed records. 

51. Select Back to Report to go back to 

Report canvas. 

 

Note: See Records and Show Data options 

are also available in the ribbon under 

Data/Drill menu option. 
 

Let’s remove Manufacturer from the 

Legend and create a visual which 

represents Revenue by Manufacturer and 

check if it will help with any new insights. 

52. With the Stacked column chart 

selected, click on the X next to 

Manufacturer (groups) in the Legend 

section. This will remove Manufacturer. 

 



Version: 07.10.2018  Copyright 2018 Microsoft     35 | P a g e  
Maintained by:  Microsoft Corporation    

53. Click on the white space in the canvas. 

From the VISUALIZATIONS section, select 

Treemap visual. 

54. From the FIELDS section, expand 

Manufacturer table and select 

Manufacturer field. 

55. From the FIELDS section, expand 

Sales table and select Revenue field. 

56. Resize the visual as needed. 

 

We have Revenue by Manufacturer. Let’s 

figure out the interaction between the 

Stacked column chart and the Treemap 

visuals. 

 

57. Click on USA column in the Stacked 

column chart and notice the Highlighted 

section of Treemap updates. 

58. Click on Australia column in the 

Stacked Column chart and notice the 

Highlighted section of Treemap updates. 

59. Similarly, select VanArsdel in the 

Treemap and notice Stacked column 

chart is filtered. This confirms that 

VanArsdel has a big percent of the 

Australian market. 

60. To remove the filter select VanArsdel 

again. 

The interaction between visuals is called 

cross filtering. 

 

Previously we added Top 5 Visual level 

filter. Let’s add a filter to the Page level, 

so we are working with the Top 

Competitors and VanArsdel and filter out 

the other manufacturers. 

Page level filters apply to all the visuals on 

the page whereas Visual level filter 

applies to a visual. 

61. From the FIELDS section expand 

Manufacturer table. 

62. Drag Manufacturer (groups) field to 

Page level filters section under 

VISUALIZATIONS panel. 

63. Select Top Competitors and 

VanArsdel. 
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Let’s add a visual that will provide sales 

information over time. 

64. Click on the white space in the canvas. 

From the FIELDS section, expand Sales 

table. 

65. Select Date field. 

66. Select Revenue field. 

Notice a Clustered column chart is 

created. Also notice in the Axis section, a 

date hierarchy is created. There are 

arrows on the top bar of the chart. This is 

used to navigate through the hierarchy. 

 

67. Click on USA column in the Revenue 

by Country visual. Notice sales is on the 

upward trend over time. 

68. Click on Australia column in the 

Revenue by Country visual. Again, the 

trend is upwards. 

69. We see a similar scenario with Japan 

as well. 

With the current interaction the visuals 

are slicing the data. It will be nice to filter 

data across visuals. This might give us a 

better perspective. Let’s try that. 

 

 

70. Click on Australia column in the 

Revenue by Country visual. 

71. With the Revenue by Country visual 

selected, from the ribbon select Format -

> Edit Interactions.  

Notice on the top right of the other two 

visuals we see new icons with the 

slice/highlight icon selected. 

72. Select filter icon for both visuals. 

Notice now in both Revenue by Year and 

Revenue by Manufacturer data is filtered 

for Australia. 
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73. Now select Revenue by Year visual. 

74. Select filter icon on the other two 

visuals. 

75. Similarly, select Revenue by 

Manufacturer visual and select filter icon 

on the other two visuals. 

Once you are done, all the visuals should 

be in filter mode. 

76. With the Revenue by Manufacturer 

visual selected, from the ribbon select 

Format -> Edit Interactions to remove the 

icons. 

 

77. Click on VanArsdel in the Revenue by 

Manufacturer visual. Notice sales is on an 

upward trend over time. 

78. Click on Natura column in the 

Revenue by Manufacturer visual. Notice 

sales in 2017 for Natura was on a 

downward trend. 

Similarly, you can analyze other 

manufacturer’s performance. 

 

We had already noticed that VanArsdel 

has a big share of the market in Australia. 

Let’s check how VanArsdel has done over 

time in Australia. 

79. Click on VanArsdel in the Revenue by 

Manufacturer visual. 

80. Ctrl+Click Australia column in 

Revenue by Country visual. Now we have 

filtered the charts by both VanArsdel and 

Australia. We see a spike in 2017 sales for 

VanArsdel in Australia. 

81. Let’s see what’s happening in USA. 

Click USA column in Revenue by Country 

visual. 

82. Ctrl+Click on VanArsdel in the 

Revenue by Manufacturer visual. Now 

we have filtered the charts by both 

VanArsdel and USA. We see a steady 

growth. 
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Similarly, we can analyze data for 

different countries, manufactures and 

time frame.  

 

We are intrigued by the spike in 2017 for 

VanArsdel in Australia. Let’s investigate 

further. 

83. Click on VanArsdel in the Revenue by 

Manufacturer visual. 

84. Ctrl+Click Australia column in 

Revenue by Country visual 

85. Select the arrow on the top right 

corner of the Revenue by Year visual. This 

enables drill down capability. 

86. Select 2017 column in Revenue by 

Year visual. 

Notice you have drilled down to quarter 

level of 2017. There is a big spike in the 

4th quarter. Interesting let’s dig further… 

 

 

87. Click on the second icon on the top 

left of Revenue by Year visual. This drills 

down to the next level of the hierarchy 

which is month. 

Looks like sales picked up in September 

and October and is holding steady since 

then. Ok this is interesting. Now is this a 

yearly trend. Let’s check? 

88. Click on the first icon on the top left 

of Revenue by Year visual to drill up to 

Quarter level. 

89. Click on the drill up icon again to go 

up to Year level. 

 

 

90. Click on the third icon on the top left 

of Revenue by Year visual. This expands 

down to the next level of the hierarchy 

which is quarter for all the years. 

Notice 4th quarter sales have always been 

high but in 2017 there is a bigger spike in 

the 4th quarter. 

91. Let’s expand down to the month 

level. Click on the third icon on the top 
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left of Revenue by Year visual. This 

expands down to the next level of the 

hierarchy which is month for all the 

years. 

There is a lot of information on the visual 

and we must scroll left and right to 

compare.  

92. Click on focus mode icon on the top 

right of Revenue by Year visual.  

Now Revenue by Year takes over the 

complete canvas. Notice that sales has 

typically been high that last 4 months of 

the year. It confirms the spike in 2017. 

Drill up/down functionality is available in 

the ribbon as well.  

93. From the ribbon, select Data/Drill -> 

Drill up to move to Quarter level. 

94. From the ribbon, select Data/Drill -> 

Drill up to move to Year level. 

95. Click on Back to Report on the top left 

corner of the visual to go back to report 

canvas. 

96. Click on VanArsdel in the Revenue by 

Manufacturer visual to remove filters. 
 

 

Power BI Desktop – Data Exploration Continued 
 

In this section, you will continue to 

explore the data. You will investigate to 

see if a product segment has an impact 

on sales. 

At the end of the section, you will find 

that one of the reasons for the spike in 

sales in Australia for the year 2017 is 

158% growth of product Maximus UE-04.  
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Let’s continue to investigate our findings 

of VanArsdel’s sales spike in 2017 in 

Australia. We will start by adding a new 

page. 

1. Right click on Page 1 (bottom left). 

2. Select Rename Page. Rename the page 

to Market Analysis. 

3. Right click on Market Analysis page. 

This time pick Duplicate Page. We are 

duplicating the page since we can reuse 

some of the visuals. 

A new page is created, and you will be 

navigated to this new page. 

 

Let’s add a slicer so we can filter 

manufacturers. 

4. Click on the white space in the canvas. 

From the FIELDS section, expand 

Manufacturer table and select 

Manufacturer field.  

5. From the VISUALIZATIONS section 

select Slicer visual. 

6. You will see a list of Manufacturers. 

Select VanArsdel and notice all the 

visuals are filtered based on your 

selection. 

7. Hover over the top right corner of the 

visual and click on the down arrow. 

Notice you have the option to change the 

slicer from a list to a drop down. 

8. Select Dropdown. 

9. Select VanArsdel from the dropdown. 
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10. In the VISUALIZATIONS panel, scroll 

down to FILTERS section.  

Notice the Page level filters for 

Manufacturers. Since we have two pages 

and we want Manufacturer filter to apply 

to both pages it makes sense to move it 

to Report level filters. 

11. In the FIELDS section, expand 

Manufacturer table. 

12. Drag Manufacturer (groups) field to 

Report level filters. 

13. Select Top Competitors and 

VanArsdel. 

14. Click on “X” next to Manufacturers in 

Page level filters. 
 

We use the Manufacturer slicer to 

analyze one manufacturer at a time. 

Notice when we do this Revenue by 

Manufacturer Treemap visual is not the 

best representation of the data. Let’s 

change it. 

15. Select Revenue by Manufacturer 

Treemap visual. 

16. From the VISUALIZATIONS section, 

select Card visual. 

 

The card visual will give us the Revenue as 

we filter and cross filter the visuals. 

 

Notice all key dimensions/characteristics 

is in its own table with the related 

attributes except date. E.g. Product 

attributes are in Product table and we 

created a relationship between Product 

and Sales. 

It is good practice to have dimensions in 

different tables. In future if we need to 

add date attributes like Week number, 

Day of Week, Holiday, etc, we need to 

have a Date table. Let’s create Date table. 

 

17. Navigate to Data view by clicking on 

the Data icon on the left panel. 
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18. From the ribbon select Modeling -> 

New Table. 

Notice a new table is created in the 

FIELDS section on the right and formula 

bar opens. 

19. Enter Date =CALENDAR 

(DATE(2011,1,1), DATE(2017,12,31)) in 

the formula bar and click on the check 

mark. A Date table with a Date column is 

created. 

We are using 2 DAX functions: CALENDAR 

function which takes the start and end 

data. DATE function which takes year, 

month and date fields.  

We are creating Date from 2011 to 2017 

since our dataset has data for those 

years. 

We can add more fields to this table like 

Year, Month, Week etc. by using DAX 

functions. 

Notice Date field is of type Date/Time. 

Let’s change it to data type Date. 

 

20. Select the Date field in the Date table. 

21. From the ribbon, select Modeling -> 

Data type -> Date. 

 

 

Next, we need to create a relationship 

between the newly created Date table 

and Sales table. Previously we used the 

visual drag and drop feature to create a 

relationship. This time around let’s use a 

different option. 

22. From the ribbon, select Modeling -> 

Manage Relationships. 

23. Manage Relationships dialog opens. 

Select New button. 

24. Create relationship dialog opens. 

Select Date from the top dropdown. 

25. Select Sales from the second 

dropdown. 
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26. Highlight Date fields from both the 

tables. 

27. Select OK to close Create relationship 

dialog. 

28. Select Close to close Manage 

relationships dialog. 

29. Navigate to Report view by clicking on 

the Report icon on the left panel. 

Notice Revenue by Date chart looks 

different. Let’s fix it. 

30. Select Revenue by Date visual. 

31. From the Axis click on “X” to remove 

the Date field. 

32. From the FIELDS section expand Date 

table. 

33. Drag Date field to Axis section. 

Notice with the new Date field behavior is 

like earlier. 

 

There are two Date fields, it might get 

confusing to figure out which to use. Let’s 

hide the Date field in Sales table. 

34. From the FIELDS section, expand 

Sales table. 

35. Click on the ellipsis next to Date field. 

36. Select Hide. This hides Date field in 

the reports view. We have the option to 

view hidden fields and unhide fields as 

needed. 

 

Note: It is best practice to hide fields that 

are not used in reports like ZipCountry, 

ProductID, ManufacturerID. 

 

Let’s get back to our data story, Australia, 

VanArsdel and 2017 – remember 😊. 

Let’s check if the spike occurred in a 

specific region in Australia. 

37. Select Revenue by Country visual. 

38. In the FIELDS section, expand 

Geography table. 

39. Drag State field below Country in the 

Axis section. 

40. Drag District field below State in the 

Axis section.  
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We just created a hierarchy. 

41. Make sure VanArsdel is selected in 

the Manufacturer slicer. 

42. Enable Drill mode by selecting down 

arrow on the top right corner of Revenue 

by Country visual. 

43. Select Australia to drill down to State 

level. 

44. From Revenue by Year visual select 

2017 and notice Revenue by Country and 

State visual. 

45. From Revenue by Year visual select 

2016 and notice Revenue by Country and 

State visual. 

46. Similarly, select 2015. We don’t see a 

spike in a specific state.  

47. Select 2015 again to remove year 

filter. 

48. Drill up to country level. 

 

Let’s analyze by Product to figure out 

what’s happening there. Before we start 

with that let’s create a Product Hierarchy. 

This way we don’t have to drag multiple 

fields to the visual. 

49. From the FIELDS section, expand 

Product table. 

50. Click on the ellipsis next to Category. 

51. Select New Hierarchy.  

Notice a new field called Category 

Hierarchy is created in the Product table. 

52. Double click on Category Hierarchy 

and rename it to Product Hierarchy. 

 



Version: 07.10.2018  Copyright 2018 Microsoft     45 | P a g e  
Maintained by:  Microsoft Corporation    

53. Click on the ellipsis next to Segment. 

54. Select Add to Hierarchy -> Product 

Hierarchy. 

55. Click on the ellipsis next to Product. 

56. Select Add to Hierarchy -> Product 

Hierarchy. 

We have created a Product Hierarchy 

which is Category -> Segment -> Product. 

 

57. Click on the white space in the canvas. 

From the VISUALIZATIONS section select 

Clustered bar chart. 

58. From the FIELDS section, expand 

Product table. 

59. Select Product Hierarchy. Notice 

complete hierarchy is selected. 

60. From the FIELDS section, expand 

Sales table. 

61. Select Revenue field. 

 

Note: Make sure you have VanArsdel 

selected in the slicer. 

We see that VanArsdel has a presence in 

the Urban category and a small presence 

in the Rural category. 

62. Drill down Urban category (yes you 

are an expert drilling up and down 

hierarchy 😊). If not, select the down 

arrow on the top right corner of the 

visual. 

63. Select the Urban row to drill down to 

Urban segments. 
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64. In Revenue by Country visual make 

sure drill down mode is disabled. 

65. Select USA. Notice that Convenience 

and Moderation are the segments with 

most sales. 

66. In Revenue by Country visual select 

Japan. Notice that again Convenience and 

Moderation are the segments with most 

sales. 

67. In Revenue by Country visual select 

Australia. Notice that sales in Extreme 

segment is comparable to Convenience 

and Moderation. Let’s dive into Extreme 

segment and investigate further. 

 

68. In Revenue by Country visual select 

USA. 

69. Ctrl+Select 2017 from Revenue by 

Year visual. Notice Convenience and 

Moderation are the key segments in USA. 

 

70. In Revenue by Country visual select 

Australia. 

71. Ctrl+Select 2017 from Revenue by 

Year visual. Notice sales in Extreme 

category is higher than Convenience and 

Moderation segments. 

We need to investigate further… 
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72. Select the down arrow on the top 

right corner of Revenue by Country visual 

to enable drill model. 

73. Select Australia to drill down to State 

level. 

74. Select 2017 in Revenue by Year visual. 

75. Remove drill mode from Revenue by 

Category visual. 

76. Ctrl+Select Extreme Segment in 

Revenue by Category and Segment visual. 

77. Select 2016 in Revenue by Year visual. 

78. Ctrl+Select Extreme Segment in 

Revenue by Category and Segment visual. 

 

There is no significant spike by State. 

 

79. Select Extreme again to remove cross 

filtering between visuals. 

80. Drill up to Category level in Revenue 

by Category visual. 

 

Let’s add a matrix visual so we can view 

data in rows and columns. We can apply 

conditional formatting to the matrix 

visual to highlight outliers. 

 

81. Click on the white space in the canvas. 

From the VISUALIZATIONS section, select 

Matrix visual. 

82. From FIELDS section expand Product 

table. 

83. Drag and drop Product Hierarchy field 

to Rows section. 

84. From FIELDS section expand Sales 

table. 

85. Drag and drop Revenue to Values 

section. 
 

86. Enable drill mode in the matrix by 

selecting the down arrow on the top right 

corner of the visual. 

87. Select Urban row to drill down. 
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Well the text is too small, let’s format the 

matrix and make it more readable. 

88. In the VISUALIZATIONS panel, select 

the paint roller icon to format the visual. 

89. Scroll down and expand Values 

section. 

90. Scroll down and increase the Text 

size to 10. 

Notice there are a lot of formatting 

options. Feel free to explore them. 

91. Scroll up and expand Column headers 

section. 

92. Scroll to Text size and increase it to 

10. 

93. Scroll up and expand Row headers 

section. 

94. Scroll to Text size and increase it to 

10. 

 

Let’s add percent of total field. This will 

give us a better perspective. 

95. From FIELDS section expand Sales 

table. 

96. Drag Revenue field below the existing 

Revenue field in Values section. 

97. Select the arrow next to the newly 

added Revenue field. 

 

98. From the dialog select Show value as 

-> Percent of grand total. 

 

We see that in Australia, Extreme 

segment has highest market share. Let’s 

check across time if this is true. 
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99. In the Revenue by Year visual select 

2015 column. Notice Extreme segment 

has around 30% of the grand total.  

100. In the Revenue by Year visual select 

2016 column. Notice Extreme segment 

has around 30% of the grand total. 

101. In the Revenue by Year visual select 

2017 column. Notice Extreme segment 

has around 40% of the grand total. 

102. In the Revenue by Year visual select 

2017 column to remove the filter. 

 

Let’s drill down Extreme Segment and 

figure out if a Product stands out. 

 

103. In the matrix visual select Extreme 

row to drill down to Product level. 

104. Resize the visual as needed. 

105. Hover over matrix visual and select 

the ellipsis on the top right corner.  

106. Select Sort By % GT Revenue. 

 

We see the top Products. Let’s analyze 

top Products over time. 

 

107. In the Revenue by Year visual select 

2015 column. Notice Maximus UE-04 and 

11 are the top products.  

108. In the Revenue by Year visual select 

2016 column. Notice Maximus UE-16 and 

17 are the top products. 

109. In the Revenue by Year visual select 

2017 column. Notice Maximus UE-04 and 

21 are the top products. And Product 04 

has nearly 7% of the grand total. Product 

04 has a big spike. 

110. In the Revenue by Year visual select 

2017 column to remove the filter.  
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Earlier we created a calculated column 

(ZipCountry). Let’s create % Growth 

measure so we can compare sales over 

time. We are going to do this in two 

steps. 

 

But first, what’s the difference between 

measure and calculated column. 

Calculated column is evaluated row by 

row. We extend a table by adding 

calculated columns. 

Measure is used when we want to 

aggregate values from many rows in a 

table. 

 

111. In the FIELDS section, select Sales 

table. 

112. From the ribbon, select Modeling -> 

New Measure. Formula bar opens. 

113. Enter PY Sales = 

CALCULATE(SUM(Sales[Revenue]), 

SAMEPERIODLASTYEAR('Date'[Date]) 

114. Select the check mark next to the 

formula bar. You will see PY Sales 

measure in Sales table. 

 

Let’s create another measure. 

115. In the FIELDS section, hover over 

Sales table. 

116. Click on the ellipsis on the right 

corner. 

117. Select New Measure from the 

dialog. Formula bar opens. 

118. Enter % Growth = 

DIVIDE(SUM(Sales[Revenue])-[PY 

Sales],[PY Sales]) 

119. Select the check mark next to the 

formula bar. You will see % Growth 

measure in Sales table. 
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120. Select the matrix visual. 

121. In the FIELDS section, expand Sales 

table. 

122. Select newly created PY Sales and % 

Growth measures. 

Notice these fields need to be formatted. 

123. From the FIELDS section, select % 

Growth field. 

124. From the ribbon select Modeling -> 

Format -> Percentage 

125. Similarly, from the FIELDS section, 

select PY Sales field. 

126. From the ribbon select Modeling -> 

Format -> Currency -> $ English (United 

States) 

 

127. In the Revenue by Year visual select 

2017 column. Notice Maximus UE-04 has 

nearly 158% growth compared to last 

year. 

 

128. Select matrix visual. 

129. From the Values section, select the 

arrow next to % Growth. 

130. Select Conditional Formatting -> 

Background color scales. 

 

Note: Conditional formatting can be 

applied using font color or data bars as 

well. 
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Background color scales dialog opens. 

This dialog provides options to format 

background color either using rules or 

diverging colors. 

 

131. Select the Diverging checkbox. 

132. Select OK. 

 

Note: Conditional formatting can also be 

based on another column using Color 

based on drop down. 

 

  

 

 

Power BI Desktop – Data Visualization  
 

Having done the data exploration and visualization you have found good insights to share with your team. In this 

section, you will create a professional report from which you and your entire team can benefit.  

 

At the end of this section, you will build a 

report like the one shown in the 

screenshot. 

 

Let’s remove Revenue by Category 

clustered bar chart. 

1. Hover over Revenue by Category 

visual. 

2. From the top right corner select the 

ellipsis 

3. Select Remove to delete the visual. 
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Initially we added a filter to load 3 years 

of data. Let’s load the complete data. 

4. From the ribbon, select Home -> Edit 

Queries. Power Query Editor window 

opens. 

5. From the left panel, select Sales query. 

6. From the right panel, under APPLIED 

STEPS click on the X next to Filtered 

Rows1 to remove the 3-year filter. 

7. Select Home -> Close & Apply to load 

the data.  

Sales data is reloaded, this time all the 

data is loaded. It might take a couple of 

minutes as we are loading ~7 million 

rows. 

 

Make sure the report is filtered by 

VanArsdel using Manufacturer slicer. 

Remove all other filters. 

 

At this point your report page should look 

something like the screenshot. 

Once data is loaded, notice Revenue by 

Year visual. You will see columns for 

years 2011 through 2017. 

 

Let’s add a Date slicer so we can control 

how many years of data we want to 

analyze. 

8. Click on the white space in the canvas. 

From the VISUALIZATIONS section, select 

Slicer visual. 

9. From FIELDS section, expand Date 

table. 

10. Select Date field.  

Notice we have a range slicer with a 

slider.  

11. Move the slicer to filter the data to 

1/1/2013 to 12/31/2017 or type in the 

values. 
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12. Hover over the date slicer. 

13. Select the arrow from the top right 

corner. Notice following options are 

available – Before, After, List, Dropdown 

and Relative. Feel free to try out the 

various options. 

14. Select Relative. Notice this has 

options to filter data by the Last x years, 

months, days or Next x years, months, 

days, etc. Feel free to try out various 

options. 
 

15. Hover over Manufacturer slicer 

visual. 

16. On the top right corner select the 

arrow.  

17. Select List. 

18. in VISUALIZATIONS panel select the 

paint roller icon. This opens the 

formatting options available for a visual. 

19. Expand General section, select 

Horizontal from the Orientation 

dropdown. 

20. Select VanArsdel. 

21. Notice the Slicer visual is updated. 

You can resize the visual, so all the 

manufacturers are listed horizontally. 

Note: There are other options to change 

the Outline color, weight, etc. 

22. Collapse General section. 

23. Note: Expand Selection Controls 

section. Notice there is an option to 

enable Select All option in the visual. 

There is also an option to make the slicer 

multi select. Feel free to explore other 

formatting options. 

 

It will be nice to add logos of the 

manufacturer to the slicer. Let’s do it. 

24. From FIELDS section, expand 

Manufacturer table. 

25. Select Logo field. 

26. From the ribbon, select Modeling -> 

Data Category -> Image URL. Setting data 

category to Image URL helps Power BI to 
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understand that it is a URL and it can 

access the data. 

27. From the canvas, select Manufacturer 

slicer. 

28. From FIELDS section, expand 

Manufacturer table. 

29. Drag and drop Logo to Field section. 

30. Select Logo field. 

31. Resize slicer visual as needed. 

32. Select VanArsdel logo to filter all the 

other visuals. 

 

33. Select Revenue by Year visual. 

34. From VISUALIZATIONS panel, select 

Line and clustered column chart to 

change the visual type. 

35. From FIELDS section, expand Sales 

table. 

36. Drag and drop % Growth field to Line 

values. 

 

This provides a representation of the 

revenue and growth over time.  

   

37. Select Revenue Card visual. Let’s 

change this to a Gauge visual. 

38. From VISUALIZATIONS panel, select 

the Gauge visual. 

39. From FIELDS section, expand Sales 

table. 

40. Drag and drop PY Sales field to Target 

value. 

41. Resize the visual as needed. Now we 

can compare Revenue with the target. 

 



Version: 07.10.2018  Copyright 2018 Microsoft     56 | P a g e  
Maintained by:  Microsoft Corporation    

It will be nice to change the colors on the 

visuals.  

42. Select Gauge visual. 

43. From VISUALIZATIONS panel, select 

paint roller icon. 

44. Expand Data Colors section. 

45. Select the arrow next to Fill color. 

 

Notice you can pick a color from the 

default color palette or pick Custom 

colors. 

 

 
 

The Marketing department has provided 

a few standard color themes to be used 

across reports. We can use Report Theme 

feature in Power BI by uploading a theme. 

Report Theme requires a JSON file where 

the data colors, background, foreground 

and tableAccent colors are defined. The 

JSON file can be used across all the 

reports. 

Custom Report Theme is a Preview 

feature. Let’s enable it.  

46. From the ribbon select File -> Options 

and settings -> Options. 

47. From the Options dialog, select 

Preview features. 

48. Select Custom report themes. 

49. Select OK. 

To enable the feature, we need to restart 

Power BI Desktop. 

50. Feature requires a restart – dialog box 

opens. Select OK. 

51. From the ribbon, select File -> Save. 

52. From the ribbon, select File -> Exit. 
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53. Open Power BI Desktop. 

54. From startup dialog, select 

MyFirstPowerBIModel.pbix under Recent 

sources. 

 

Notice in the ribbon we have a new menu 

option called Switch Theme. 

55. From the ribbon, select Home -> 

Switch Theme -> Import Theme. 

56. File browser dialog opens. Navigate to 

/Data/Theme folder. 

57. Select DIADTheme1 file and select 

Open. 

58. Once theme is imported, a success 

dialog opens. Select Close. 

 

Notice colors on all the visuals updated. 

Your report should look something like 

the screenshot at this point. 

This one is good, but too much red in it. 

Marketing team has provided two more 

themes, let’s try the next one. 

59. From the ribbon, select Home -> 

Switch Theme -> Import Theme. 

60. File browser dialog opens. Navigate to 

/Data/Theme folder. 

61. Select DIADTheme2 file and select 

Open. 

62. Once theme is imported, a success 

dialog opens. Select Close. 

Notice the theme changes. 

63. Similarly, let’s try out DIADTheme3 by 

importing it. 
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Notice colors on all the visuals updated. 

Your report should look something like 

the screenshot at this point. 

 

This theme looks good. Now most of the 

visuals are blue in color, let’s add some 

contrast. 

 

 

64. Select the Gauge visual. 

65. From VISUALIZATIONS panel, select 

paint roller icon. 

66. Expand Data colors section. 

67. Select the drop down next to Target. 

Notice the color palette is different now. 

68. Select black color. Notice the change 

in the visual. 

 

69. Collapse Data colors section. 

70. Expand Data Labels section. 

71. Increase Text size to 10. 

72. Expand Target section. 

73. Increase Text size to 10. 
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74. Select matrix visual. 

75. Drill up to Segment level. 

76. Select Revenue by Country visual. 

77. Drill up to Country level. 

78.  From VISUALIZATIONS panel, select 

paint roller icon. 

79. Expand Data colors section. 

80. Select a light shade of gray as the 

Default color. 

81. Enable and expand Data labels. 

82. Change Display units to Millions. 

 

Notice there a lot of formatting options. 

E.g. visual title can be changed and 

formatted, you can add a border and 

background to the visual, etc. Feel free to 

explore the options.  

83. Select Revenue and % Growth by 

Year visual. 

84. From VISUALIZATIONS panel, select 

paint roller icon. 

85. Expand Data colors section. 

86. Select black color for % Growth. 

87. Select a light shade of gray as the 

Default Column color. 

 

Let’s add a report title. 

88. From the ribbon, select Home -> Text 

box. Notice a text box visual is added. 

89. Resize the visual as needed. 

90. Enter Manufacturer Analysis in the 

Text box. 

91. Highlight Manufacturer Analysis to 

format the text.  

92. Select Segoe (Bold) as the font. 

93. Select 36 as the font size. 

94. Resize the text box as needed. 
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95. From the ribbon, select View. 

96. Select the checkbox next to Show 

Gridlines and Snap Objects to Grid. This 

will help with aligning the visuals. 

97. Move and align the visuals like the 

screenshot. 

Uncheck Show Gridlines and Snap 

Objects to Grid options to disable these 

features. 

98. Rename the page to Manufacturer. 

 

 

 

 

 

We can also use a background image to 

format the reports. Let’s try it. 

99. Select + icon in the bottom of the 

page to create a new page. You will be 

navigated to a Page 1. 

100. Click on the white space in the 

canvas. 

101. From VISUALIZATIONS panel, select 

paint roller icon. 

102. Expand Page Background section. 

103. Select Add Image button. 

104. File browser dialog opens. Browse to 

/DIAD/Data folder. 

105. Select Background file. 

106. Select Open. 

 

107. From Image Fit drop down, select 

Fit. 

Notice we have a template which has 

place for header and slots for images. 

108. Navigate to Manufacturer page.  

109. Select Revenue by Country visual. 

110. From the ribbon select Home -> 

Copy. 

111. Navigate to Page 1. 

112. From the ribbon select Home -> 

Paste. 
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113. Resize the visual and place it as 

shown in the screenshot. 

114. Navigate to Manufacturer page.  

115. Select Manufacturer slicer. 

116. From the ribbon select Home -> 

Copy. 

117. Navigate to Page 1. 

118. From the ribbon select Home -> 

Paste. 

119. Sync visuals dialog opens. Select 

Sync.  

This will keep Manufacturer slicer in both 

the pages in sync. Changing slicer in one 

of the pages will update visuals in both 

the pages. 

120. Resize the slicer and place it as 

shown in the screenshot. 

 

121. Similarly, copy the report title, 

gauge, matrix and the line and clustered 

column visual. 

122. Resize and arrange the visuals as 

shows in the screenshot. 

 

Let’s add a logo. 

123. From the ribbon, select Home -> 

Image. 

124. File browser dialog opens. Browse to 

/DIAD/Data folder. 

125. Select VanArsdel_Logo file. 

126. Select Open. 

127. Resize the visual as needed. 

128. Drag the visual to the top left corner 

of the page. 
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Let’s change the font color of report title.  

129. Highlight Manufacturer Analysis. 

130. Select the arrow next to A for font 

color. 

131. Select white color. 

 

Out of the box, Power BI has a good 

selection of visuals. However, there is 

always a use-case where you need a 

custom visual. To meet this need, the 

visualization engine is open sourced. 

Power BI community contributes visuals 

which are available in the marketplace. 

You can add and use these visuals in your 

reports. 

There is also an option to create your 

own visual and import it into Power BI 

Desktop. 

Let’s add a custom visual.  

132. From VISUALIZATIONS section, 

select the ellipsis in the last row of 

visuals. 

133. Select Import from marketplace. 

134. Type play axis in the search box and 

select search. 

135. Select Add next to Play Axis 

(Dynamic Slicer). 

136. Import custom visual dialog opens. 

Select OK. 

Notice a new visual is added to the list of 

available visuals. 

 

137. Click on the white space in the 

canvas. 

138. From VISUALIZATIONS section, 

select the newly imported Play Axis 

visual. 

139.  From FIELDS section, expand Date 

table. 

140. Select Date field.  
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141. From VISUALIZATIONS panel, select 

paint roller icon. 

142. Expand Colors section. 

143. Enable Show all option. 

144. Resize and position the visual as 

shown in the screenshot.  

145. Enable drill mode in matrix visual. 

146. Select Extreme category to drill 

down to Extreme products. 

147. Select Play in the Play axis visual. 

Notice all the visuals update as play axis 

moves through years. You can view 

Product performance over time as well as 

performance of countries over time. Play 

axis provides an option to analyze data 

over time (or any other dimension) across 

all visuals in the page. 

148. Once you are done playing through 

the years, in the matrix visual drill back 

up to Product Category level. 

149. Disable drill mode in matrix visual. 

There are a lot of custom visuals available 

and new ones are added periodically. 

 

Now we have a report ready, let’s use 

Bookmarks to tell the story we 

discovered. Bookmarks capture the 

currently configured view of a report 

page, including filtering and the state of 

visuals which makes it easy to present the 

story. 

150. From the ribbon, select View. 

151. Select the checkbox next to 

Bookmarks Pane to enable Bookmarks. 

BOOKMARKS pane opens. 

152. Click on Add in BOOKMARKS pane. 

This will add the current state of the 

visual to the bookmark. 

153. Click on the ellipsis next to the 

newly created Bookmark 1. 

154. Select Rename to rename it to Initial 

State 
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155. In Revenue by Country visual, select 

USA column. 

156. Hover over Revenue by Country 

visual and select the ellipsis on the top 

right corner. 

157. Select Spotlight. 

158. In the BOOKMARKS pane, select 

Add. This will add a new bookmark with 

the current state of the report.  

159. Click on the canvas. 

160. Select Australia in Revenue by 

Country visual. 

161. In the BOOKMARKS pane, select 

Add. This will add a new bookmark with 

the current state of the report. 

 

162. From the BOOKMARKS pane, select 

View. You are in Bookmarks slide show 

mode. 

You will be in the first bookmark which 

we called Initial State. Notice on the 

bottom of the report pane there is an 

option to navigate between bookmarks. 

163. You can use the arrows to navigate 

between bookmarks and tell your story. 

164. From BOOKMARKS pane, select Exit 

to exit Bookmarks slide show mode. 

 

If time permits, feel free to explore other 

options available with Bookmarks like 

Selected Visuals and more as you 

continue to build the story. 

 

165. From the ribbon, select View. 

166. Uncheck Bookmarks Pane. 

167. Collapse the Visualizations and 

Filters pane by clicking on the arrows. 

Report should look as shown in the 

figure. Save the file. 

168. Select File -> Save. 

 

You have built your first report!!! 
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169. Navigate to /DIAD/Reports folder. 

170. Open DIAD Final Report.pbix file.  

 

This file uses the same dataset that you 

used for the lab. We have added a few 

more visuals and formatted the reports. 

Feel free to explore the report. 

 
 

You have successfully completed the hands-on lab in creating a report to share to your team. The next 

section covers creating a dashboard from this report so that you can easily share it to your team. You have 

learned a quick overview of various functionality in Power BI Desktop to get accelerated. There are a lot 

more features for you to build upon this on your own data.   
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Power BI Service  
  

You will now leverage the report authored using Power BI Desktop and create a dashboard for VanArsdel data 

analysis team and share it with the CMO. A Power BI Desktop file with additional reports / visuals is provided. Please 

use this for the next section of the lab.  

Power BI Service - Publishing Report  
 

1. If you have not signed up for a Power 

BI account, go to 

http://aka.ms/pbidiadtraining and sign up 

for Power BI with a business email 

address.  

2. If you have not already opened 

app.powerbi.com page, please open the 

browser and navigate to 

http://app.powerbi.com. 

3. Sign in to Power BI using your user 

account. Once logged in, you will see a 

screen like the screenshot. 

 

 
 

4. If the left navigation is collapsed, 

select  icon below Power BI on the 

top left of the screen to expand the left 

navigation. 

Following options are listed in the left 

navigation: 

Favorites: Lists all your favorite 

dashboards (we will create a favorite 

in a later section). 

Recent: Lists the most recent 

dashboards you have viewed. 

Apps: List all the apps you have 

installed. 

Shared with me: Lists the dashboards 

that are shared with you (we will 

share dashboards in a later section). 

Workspaces: Lists all the workspaces 

you are assigned. By default, you are 

assigned My Workspace. 

 

http://aka.ms/pbidiadtraining
http://app.powerbi.com/
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5. Select the down arrow next to My 

Workspace. Notice DASHBOARDS, 

REPORTS, WORKBOOKS and DATASETS 

section are empty. Let’s import a Power 

BI Desktop file and create dashboards. 

 

Note: If you have previously signed into 

Power BI, then your screen will look 

different. You will be directly navigated 

to your Workspace skipping the 

Welcome page. 

Let’s publish the report to Power BI 

Service and then we will come back to 

the browser. 

6. Navigate to /DIAD/Reports folder. 

7. Open DIAD Final Report.pbix file.  

8. From the ribbon select Home -> 

Publish. 

9. If you have not already logged into 

Power BI, a Sign in dialog opens. Please 

sign in. 

10. Once you are signed in, Publish to 

Power BI dialog opens. Select My 

workspace from the dialog. 

11. Click Select. 
 

Publishing to Power BI dialog opens. 

Once completed, a success message is 

displayed. 

12. Select Got it to close the dialog. 

 

Now we have published the report to 

Power BI service. Let’s navigate back to 

the browser and start exploring. 
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13. Once you are in the browser, notice a 

message appears stating the dataset is 

ready. Select X on the top right corner of 

the dialog to close it. 

 

Notice under My Workspace, you will see 

REPORTS -> DIAD Final Report and 

DATASETS -> DIAD Final Report. 
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Power BI Service – Building Dashboard  

In this section, we will create a 

dashboard that will help compare 

VanArsdel’s market share and 

performance over time. 

 

At the end of the section, we will create a 

dashboard that looks like the screenshot. 

 

Let’s start with exploring the report. 

14. From the left menu, select REPORTS -

> DIAD Final Report. You will be 

navigated to the report you just 

uploaded. 

15. In the map visual, enable drill down 

by hovering over the visual. 

16. Select the down arrow on the top 

right corner of the visual. 

17. Select Australia to drill down to State 

level. 
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18. In the map visual, disable drill mode 

by selecting the down arrow on the top 

right corner of the visual. 

19. Select the bubbles on different 

states and notice that as you select the 

states, other visuals get cross filtered. 

The behavior is like that of Power BI 

Desktop. 

20. Select the top arrow on the top left 

corner to drill up to Country level. 

 

21. Hover over the bubble chart on the 

bottom right of the screen. 

22. Select Focus mode icon so the visual 

fits in the canvas. 

23. Select Extreme from the legend. This 

will highlight the performance of Extreme 

segment over time. Notice the spike in 

2017. 

24. Select the Play axis on the bottom 

left of the screen. This will show the 

revenue and % growth of each Product 

Segment over time. 

25. Select Extreme from the legend again 

to remove the filter. 

26. Select Back to Report on the top left 

to navigate back to report view. 

 

Let’s pin visuals to the dashboard. 

27. Hover over VanArsdel Market Share 

card visual. 

28. Select the pin icon on the top right of 

the visual. Pin to dashboard dialog opens. 

29. We do not have a dashboard yet. 

Let’s create one. With New dashboard 

selected, enter VanArsdel in the text box. 

30. Select Pin. 

 

Notice alert messages are displayed 

stating the dashboard is ready to view. 
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Notice in the left panel, VanArsdel 

Dashboard is created under 

DASHBOARDS. 

 

31. From the left panel, select 

DASHBOARDS -> VanArsdel. 

Notice the VanArsdel Market Share tile is 

pinned to the dashboard. 

32. Click on VanArsdel Market Share, 

notice you are navigated to the report.  

 

Tiles in dashboard are not interactive. 

 

33. Hover over % Growth by 

Manufacturer visual. 

34. Select the pin icon on the top right of 

the visual. Pin to dashboard dialog opens. 

35. Make sure VanArsdel is selected in 

the dropdown. 

36. Select Pin. 

 

37. Close out alert dialogs. 

38. Hover over Revenue by Year and 

Manufacturer visual. 

39. Select the pin icon on the top right of 

the visual. Pin to dashboard dialog opens. 

40. Make sure VanArsdel is selected in 

the dropdown. 

41. Select Pin. 
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42. Close out alert dialogs. 

43. Navigate to By Manufacturer page. 

44. From the top right corner, select the 

down arrow. Notice manufacturer slicer 

displays. 

45. Select VanArsdel from the slicer. This 

will filter the visuals. 

46. From the top right corner, select the 

up arrow. Notice manufacturer slicer 

collapses. 

 

47. Pin the gauge visual to the 

dashboard. 

48. Pin Revenue by Country visual to the 

dashboard. 

49. Close out alert dialogs. 

 

Note: VanArsdel filter is applied to the 

tile that is pinned to the dashboard. 

 

50. From the left panel, select 

DASHBOARDS -> VanArsdel. 

Notice all the visuals are pinned as tiles 

to the dashboard.  

You will see the visuals on the dashboard 
like the screenshot. 

 

Each visual on the dashboard is called as 
a tile.  The tiles represent the data 
chosen and will be kept up to date as the 
data in the data model updates. Tiles are 
not interactive. 

 

Let’s organize the dashboard now. 
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51. Select and move the gauge tile as 

shown in the screenshot. 

52. Select the bottom right corner of the 

tile and move it diagonally to change the 

image size. 

 

Tiles can be of various sizes (1x1 to 5x5). 

Drag the tile using the bottom right 

corner to resize. As you are dragging, 

note the gray shadow which indicates the 

size of the tile when you stop dragging. 

 

53. From the top menu, select Add tile. 

Add tile dialog opens. 

54. Select Image as the source. 

55. Select Next. 

56. In URL text box, enter 

https://raw.githubusercontent.com/Char

lesSterling/DiadManu/master/Vanarsdel.

png 

57. Select Apply. 

 

Notice a new tile with VanArsdel logo is 

added to the dashboard. 

 

58. Resize and rearrange the tiles as 

shown in the screenshot. 

 

https://raw.githubusercontent.com/CharlesSterling/DiadManu/master/Vanarsdel.png
https://raw.githubusercontent.com/CharlesSterling/DiadManu/master/Vanarsdel.png
https://raw.githubusercontent.com/CharlesSterling/DiadManu/master/Vanarsdel.png
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Revenue by Country tile shows Revenue 

by Country for VanArsdel, so let’s rename 

it. 

59. Hover over Revenue by Country tile. 

60. Select the ellipsis on the top right 

corner of the tile. 

61. Select Edit Details. Tile Details dialog 

opens. 

62. Change Title to VanArsdel Revenue. 

63. Select Apply. 

 

It will be nice to have a visual that 

represents Market Share by country. 

Notice on the top of the visual, there is 

an option to Ask a question about your 

data. 

64. In the text box start typing, 

VanArsdel market share. Notice a card 

visual is created. 

65. Continue typing VanArsdel market 

share by country. Notice a bar chart is 

created. 

66. Continue typing VanArsdel market 

share by country as treemap. Notice a 

treemap visual is created. 

 

Note: Remember we renamed table. One 

of the reasons we did it is to make it user 

friendly for Q&A. 
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67. From the right panel, select the 

arrow next to VISUALIZATIONS to 

expand the section. 

68. Select the paint roller icon. 

69. Enable Data labels. 

 

Note: The visual can be modified and 

formatted like we did in Power BI 

Desktop. You can expand FIELDS section 

to add fields like Power BI Desktop. 

 

70. From the top right of the screen, 

select Pin Visual. 

71. Pin to dashboard dialog opens. Select 

Pin to pin the visual to VanArsdel 

dashboard. 

72. Close the alert dialogs. 

73. Select Exit Q&A to navigate back to 

the dashboard. 

 

Notice the visual is added as tile to the 

dashboard. Clicking on the tree map 

visual will navigate you back to the Q&A 

section. 

 

74. Hover over the line chart on the 

dashboard. 

75. Select the ellipsis on the top right 

corner. 

76. Select View Insights. 
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You will be navigated to Focus mode for 

the line chart.  

77. Scroll on the Insights panel to review 

the various insights Power BI can 

generate. Notice that there is an option 

to pin insight visuals to the dashboard. 

78. Click on Exit Focus mode on the top 

left to navigate back to the dashboard. 

 

79. Hover over VanArsdel Market Share 

tile. 

80. Click on the ellipsis on the top right 

corner of the tile. 

81. Select Manage alerts. Manage alerts 

dialog opens. 

82. Select Add alert rule dialog. 

Notice you can add Above and Below 

threshold and notification frequency can 

be set. 

This is an introduction to managing 

alerts. Complete functionality is not 

covered in this lab.   

83. Select Cancel to close the dialog. 

84. Select Don’t Save. 

  

85. Click on VanArsdel Market Share to 

navigate to the report. 

86. In map visual, right click on Australia 

bubble and select Drillthrough -> By 

Manufacturer. 

You will be navigated to By Manufacturer 

page of the report with Australia filter 

applied to the report page. 
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87. Hover over matrix visual.  

88. Select focus mode icon on the top 

right corner of the visual. 

89. From the top menu, select Explore -> 

Show Next Level. Notice now data is at 

Product Segment level. 

90. From the top menu, select Explore -> 

Drill up. 

 

91. This time from the top menu, select 

Explore -> Expand to next level. Notice 

now data is at Segment level but laid out 

as a hierarchy.  

92. Select Back to Report to navigate 

back to the report view. 

 

Notice all the functionality that is 

available in Power BI Desktop is available 

in the service. E.g. Show Data, See 

Records, etc. 
 

93. From the top menu, select View and 

enable Bookmark pane. Bookmark pane 

opens on the right. 

94. Select View in the Bookmark pane. 

Notice you can view and navigate 

through the bookmarks using the arrow 

in the bottom of the screen. The behavior 

is like in Power BI Desktop. 

95. Select Exit in Bookmark pane to close 

it. 
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Power BI provides an option to get quick 

insights into the complete dataset. 

 

96. In the left panel, hover over 

DATASETS -> DIAD Final Report. 

97. Select the ellipsis. 

98. Select Quick Insights. 

 

It might take a few minutes for the 

insights to be created. Once insights are 

ready a message appears of the top right 

corner. 

 

99. Select View insights. 

  

A quick insights report is displayed based 

on the dataset. This provides insights into 

data you may have missed and helps to 

get a quick start with creating 

dashboards. 

Hovering over each report provides an 

option to Pin it to a dashboard. 

 

Marketing team has captured data from 

social networks and built a Power BI 

report. Let us publish this report to 

Power BI service and analyze the data. 

100. From the bottom of the left panel, 

select Get Data. 

101. Get Data screen is displayed. Under 

Import or Connect to Data, select Files. 
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102. From Get Data -> Files screen select 

Local File. 

103. File browser dialog opens. Navigate 

to /DIAD/Reports folder. 

104. Select Social.pbix file and click 

Open. 

 

 

105. Once the report is published, an 

alert message appears. Close the alert 

dialog. 

In the left panel, notice under REPORTS, 

we see Social. 

106. Select REPORTS -> Social to be 

navigated to the Twitter page of the 

Social report.  

Marketing team has captured the 

retweets of #VanArsdel. Notice there is a 

spike in 2017. Does this have any 

correlation to the spike in sales in 

Australia? Let’s investigate. 

107. Hover over Retweets visual and 

click on Focus mode icon. 

 

 

108. Enable drill mode. 

109. Drill down to month level for the 

year 2017. 

Notice there is a big spike in retweets in 

the last few months of 2017. Maybe this 

has a correlation to the spike in sales. 

110. Drill back up to Year level. 

111. Select Back to Report to navigate 

back to report view. 
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112. Hover over Retweets visual. 

113. Select the pin icon on the top right 

of the visual. Pin to dashboard dialog 

opens. 

114. Pin the visual to VanArsdel 

dashboard. 

 

115. Close the alert dialogs. 

116. From the left panel, select 

DASHBOARDS -> VanArsdel to navigate 

to the dashboard. 

Notice two new tiles are added to the 

dashboard. The retweets tile we just 

pinned and a default tile that is added 

when a new dataset is added. 

117. Hover over Social.pbix tile. 

118. Click on the ellipsis on the top right 

corner. 

119. Select Delete tile to remove the tile. 

 

Notice you can have tiles from multiple 

reports and Q&A section on a single 

dashboard. 
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Power BI Service – Sharing Dashboard  

Now that you have a dashboard built, 
let’s share it with your colleagues. 

 

1. Select DASHBOARDS -> VanArsdel to 

navigate back to the dashboard. 

2. You can share your dashboard with 

your team using their email address.  

Click on Share in the top right of the 

screen.   

3. Enter email address of the members 

of your team separate by “;”. Power BI is 

connected to Azure Active directory. 

4. Enter appropriate message in the text 

box below the email addresses.  

5. You can allow recipients to share 

these dashboards with other team 

members. If you do not want the users to 

re-share, please deselect the checkbox 

and then Share the dashboard. 

 

Power BI service will send out email 

notification if the option is selected. 

Once the recipient accepts the invite, the 

user will get a read only copy of the 

dashboard and will see any changes to 

the dashboard you make periodically.   

If the dashboard is backed by tiles from 

on premise SSAS then the recipients’ 

credential is passed through to SSAS and 

the Power BI service retrieves the data 

that can be accessed by the recipient. 

 
 

 

6. Navigate back to VanArsdel 

dashboard. 

7. Notice on the top right of the menu 

bar, there is options to add this 

dashboard to the favorites. Click on 

Favorite option. 

8. Now click on Favorite in the left panel. 

Notice the dashboard is added to the list. 

This is an easy way to access all your 

favorite or most used dashboards quickly. 

 



Version: 07.10.2018  Copyright 2018 Microsoft     82 | P a g e  
Maintained by:  Microsoft Corporation    

9.  Click on the ellipsis on the top right 

corner of the page, next to Share option. 

Notice there are options to duplicate, 

print and refresh dashboard 

On the top right corner of the screen, 

next to Favorite, there is Set as featured 

option. Set as Featured dashboard sets 

the dashboard as the default dashboard 

that user will land on every time they 

login. 

 

10. Select Set as Featured.  

11. A confirmation dialog is displayed. 

Select Set as Featured Dashboard. This 

sets VanArsdel as the featured/default 

dashboard. 

 

12. Navigate back to VanArsdel 

dashboard. 

13. If you have not already done so, 

move the visuals to look like the 

screenshot. 

You have successfully built a dashboard. 
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Dashboard in a Day provides an introduction to some of the key functionalities available in Power BI. Here 

are a few references that will help you with your next steps with Power BI. 

 

Getting started: http://powerbi.com  

Power BI Desktop:  https://powerbi.microsoft.com/desktop  
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Community site https://community.powerbi.com/ 

Power BI Getting started support page: https://support.powerbi.com/knowledgebase/articles/430814-

get-started-with-power-bi  

Support site https://support.powerbi.com/  

Feature requests https://support.powerbi.com/forums/265200-power-bi  

Power BI course https://www.edx.org/course/analyzing-visualizing-data-power-bi-microsoft-dat207x-0 
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is subject to a license that requires Microsoft to license its software or documentation to third parties 

because we include your feedback in them. These rights survive this agreement. 

MICROSOFT CORPORATION HEREBY DISCLAIMS ALL WARRANTIES AND CONDITIONS WITH 

REGARD TO THE DEMO/LAB, INCLUDING ALL WARRANTIES AND CONDITIONS OF 

MERCHANTABILITY, WHETHER EXPRESS, IMPLIED OR STATUTORY, FITNESS FOR A PARTICULAR 

PURPOSE, TITLE AND NON-INFRINGEMENT.  MICROSOFT DOES NOT MAKE ANY ASSURANCES 

OR REPRESENTATIONS WITH REGARD TO THE ACCURACY OF THE RESULTS, OUTPUT THAT 

DERIVES FROM USE OF DEMO/ LAB, OR SUITABILITY OF THE INFORMATION CONTAINED IN THE 

DEMO/LAB FOR ANY PURPOSE. 

DISCLAIMER 

This demo/lab contains only a portion of new features and enhancements in Microsoft Power BI. Some of 

the features might change in future releases of the product. In this demo/lab, you will learn about some, but 

not all, new features. 

 


