
Maplytics™ – User Manual 

 

Page 1 of 204 

   

 

 

 

 

 

 

 

MAPLYTICS™ – User Manual 

 

 

 

 

 

 

 

 

 



Maplytics™ – User Manual 

 

Page 2 of 204 

   

Contents 
INTRODUCTION ..................................................................................................................................................... 8 

LANGUAGE SUPPORT ............................................................................................................................................. 9 

MAPLYTICS CONFIGURATION (PERSONALIZATION) ............................................................................................. 10 

MAPLYTICS SECURITY TEMPLATE ......................................................................................................................... 10 

INDIVIDUAL RECORD MAP ................................................................................................................................... 15 

Steps to add the Map to other entity forms ....................................................................................... 16 

AREA OF SERVICE ................................................................................................................................................. 17 

Add Area of Service tab ..................................................................................................................... 17 

Create an Area of Service field ........................................................................................................... 18 

View Area of Service data on a map ................................................................................................... 18 

Using Map button .............................................................................................................................. 18 

Adding Detail map on form ................................................................................................................ 19 

DETAIL MAP ......................................................................................................................................................... 20 

Plot.................................................................................................................................................... 22 

By Location .................................................................................................................................... 22 

By Region....................................................................................................................................... 24 

By Drawing .................................................................................................................................... 25 

By Territory.................................................................................................................................... 26 

By Template................................................................................................................................... 27 

Cluster map ....................................................................................................................................... 30 

Cluster Area ................................................................................................................................... 30 

Spider cluster ................................................................................................................................. 31 

CATEGORY ........................................................................................................................................................... 32 

Multiple categorization for multiple entitles ...................................................................................... 32 

Multiple categories for single entity ................................................................................................... 33 

DATA GRID IN DETAIL MAP .................................................................................................................................. 36 

Highlight pushpins ............................................................................................................................. 38 

Mass Action Buttons .......................................................................................................................... 38 

TOOLTIP CARD ..................................................................................................................................................... 42 



Maplytics™ – User Manual 

 

Page 3 of 204 

   

Quick Call to Action Buttons .............................................................................................................. 42 

Hover ................................................................................................................................................ 44 

RESET MAP .......................................................................................................................................................... 45 

SUMMARY CARD ................................................................................................................................................. 46 

LAYER MENU ....................................................................................................................................................... 47 

Show/Hide Labels .............................................................................................................................. 48 

Show/Hide Territory List .................................................................................................................... 48 

CONTEXTUAL MENU ............................................................................................................................................ 49 

POINT OF INTEREST (POI) LOCATIONS.................................................................................................................. 51 

PROXIMITY SEARCH ............................................................................................................................................. 53 

Proximity by Distance ........................................................................................................................ 53 

Concentric Proximity Search .......................................................................................................... 54 

Proximity by Time .............................................................................................................................. 55 

Show Travel Distance ......................................................................................................................... 56 

Show Travel Distance for Truck ...................................................................................................... 56 

OVERLAY .............................................................................................................................................................. 57 

Overlay by Territory ........................................................................................................................... 57 

Overlay by File ................................................................................................................................... 58 

Save Shape/Excel file in territory ....................................................................................................... 59 

Save Shape file ............................................................................................................................... 59 

Save Excel File ................................................................................................................................ 60 

Convert Overlay to territory............................................................................................................... 61 

CENSUS DATA VISUALIZATION ............................................................................................................................. 62 

Configuration for Census data ........................................................................................................... 62 

Configuration for attributes ............................................................................................................... 63 

SHAPE OPERATIONS ............................................................................................................................................ 66 

Difference ......................................................................................................................................... 66 

Intersection ....................................................................................................................................... 67 

Union ................................................................................................................................................ 67 

Union Aggregate ................................................................................................................................ 68 

Disjunctive union ............................................................................................................................... 68 



Maplytics™ – User Manual 

 

Page 4 of 204 

   

TERRITORY MANAGEMENT .................................................................................................................................. 70 

By File ................................................................................................................................................ 71 

By Region .......................................................................................................................................... 72 

By Drawing ........................................................................................................................................ 73 

By Territory ....................................................................................................................................... 74 

By Overlay ......................................................................................................................................... 75 

Layer Menu ....................................................................................................................................... 76 

Territory Alignment Tool.................................................................................................................... 76 

Create new territory .......................................................................................................................... 77 

Auto Territory creation ...................................................................................................................... 79 

Assign territories to record ............................................................................................................ 82 

Register to Windows Service .......................................................................................................... 83 

Draft territories ................................................................................................................................. 87 

Create territory on one click .............................................................................................................. 88 

By Shape file .................................................................................................................................. 88 

By excel file.................................................................................................................................... 89 

Alignment of Existing territories ........................................................................................................ 90 

Move to ......................................................................................................................................... 90 

Copy to .......................................................................................................................................... 91 

Shape Operations in Territory Management ...................................................................................... 91 

DEFINING GEOGRAPHIES FOR SALES TERRITORY USING MAPLYTICS .................................................................... 92 

BULK GEOGRAPHIES BY UPLOADING AN EXCEL FILE ............................................................................................ 94 

MULTIPLE TERRITORIES ASSIGNED TO RECORDS.................................................................................................. 96 

DETAIL MAP ON CRM DASHBOARD ..................................................................................................................... 98 

SAVED TEMPLATE VISUALIZATION ON CRM ENTITY FORM .................................................................................. 99 

ROUTING OPTIMIZATION ................................................................................................................................... 101 

Directions Card ................................................................................................................................ 101 

Truck Route ..................................................................................................................................... 102 

Optimize Direction........................................................................................................................... 105 

Merged Route and Plot View ........................................................................................................... 108 

Default Origin and Destination......................................................................................................... 109 



Maplytics™ – User Manual 

 

Page 5 of 204 

   

Snap waypoint ................................................................................................................................. 110 

Along the Route ............................................................................................................................... 111 

Route Redirect and Copy Route Links............................................................................................... 113 

Redirect with Google Maps .......................................................................................................... 113 

Redirect with Waze ...................................................................................................................... 114 

Print Route ...................................................................................................................................... 115 

Download map ................................................................................................................................ 116 

AUTO SCHEDULING ............................................................................................................................................ 117 

Auto scheduling card ....................................................................................................................... 118 

Advanced Preferences ..................................................................................................................... 120 

User Details ................................................................................................................................. 121 

Meeting Details ........................................................................................................................... 122 

Existing meetings ......................................................................................................................... 123 

Transition bar .................................................................................................................................. 125 

Create Activities .............................................................................................................................. 126 

Configuration Details for Auto Scheduling........................................................................................ 127 

CHECK-IN/CHECK-OUT ....................................................................................................................................... 130 

Configuration .................................................................................................................................. 130 

View Related Check-In/Check-Out records ....................................................................................... 130 

Check-Out ....................................................................................................................................... 131 

Default Radius ................................................................................................................................. 132 

Geofencing ...................................................................................................................................... 133 

Geofence Radius .......................................................................................................................... 133 

Creating Check-In/Check-Out records .............................................................................................. 134 

Visualize Check-In/Check-Out records on Detail Map ....................................................................... 136 

Analyze Check-In/Check-Out records ............................................................................................... 137 

Visualizing Related Records ............................................................................................................. 138 

Visualizing Related Record (Appointments/Accounts, etc.) for Check-In/Check-Out records ........ 138 

Visualizing related Check-in/Check-Out records for plotted records (Appointments, Accounts, etc.)

 .................................................................................................................................................... 140 

POWERAPPS COMPONENT FRAMEWORK .......................................................................................................... 141 



Maplytics™ – User Manual 

 

Page 6 of 204 

   

Map View Control for Record .......................................................................................................... 141 

Map Edit Control for Record ............................................................................................................ 144 

Map View Control for Dataset ......................................................................................................... 145 

Detail Map Control for Dataset ........................................................................................................ 147 

HEAT MAP ......................................................................................................................................................... 150 

Select Display .................................................................................................................................. 152 

Boundary ..................................................................................................................................... 152 

No Boundary................................................................................................................................ 152 

Pie chart ...................................................................................................................................... 153 

Column chart ............................................................................................................................... 153 

SUPPORT FOR CDS ............................................................................................................................................. 157 

Import Maplytics solution ................................................................................................................ 159 

Access Maplytics in PowerApps ....................................................................................................... 162 

MAPLYTICS DASHBOARD ................................................................................................................................... 163 

Steps to add Maplytics View to Dashboard ...................................................................................... 163 

Create a route dashboard ................................................................................................................ 164 

WORKFLOWS ..................................................................................................................................................... 167 

Configure Geocoding workflows for custom entities ........................................................................ 168 

Configure Territory Assignment workflow for custom entities ......................................................... 172 

Configure Get Time Zone workflow.................................................................................................. 173 

Configure Driving Instructions workflow .......................................................................................... 177 

MAPLYTICS BATCH PROCESSING TOOL .............................................................................................................. 182 

SET COLORS AND PUSHPINS FOR CATEGORIES .................................................................................................. 188 

MAPLYTICS – TABLET / MOBILE ......................................................................................................................... 189 

Detail Map ....................................................................................................................................... 190 

Proximity ..................................................................................................................................... 191 

Concentric Proximity Search ........................................................................................................ 191 

Summary Card ............................................................................................................................. 192 

Search POI ................................................................................................................................... 192 

Category Filter ............................................................................................................................. 193 

Current Location .......................................................................................................................... 194 



Maplytics™ – User Manual 

 

Page 7 of 204 

   

Set GPS Location as the current location ...................................................................................... 194 

Tooltip Card ................................................................................................................................. 195 

Contextual Menu ......................................................................................................................... 195 

Routing – Tablet / Mobile ............................................................................................................ 197 

Merged Route and Plot View ....................................................................................................... 198 

Save Route and Plot Saved Routes ............................................................................................... 198 

Along the Route Search ............................................................................................................... 199 

Route Redirect and Copy Navigation Links ................................................................................... 200 

Heat Map – Tablet / Mobile ............................................................................................................. 201 

Summary card ............................................................................................................................. 201 

Pie chart in Heat Map .................................................................................................................. 202 

Column chart in Heat Map ........................................................................................................... 202 

Dashboards – Tablet / Mobile .......................................................................................................... 203 

CONTACT US ...................................................................................................................................................... 204 

 

 

 

 

 

 

 

 

 



Maplytics™ – User Manual 

 

Page 8 of 204 

   

Introduction 

Maplytics™ is a leading Certified for Microsoft Dynamics 365 (CfMD) geo-analytical mapping app. 
Maplytics empowers users across verticals with the power of Geographical Data Visualization, Optimized 
Routing, Automated Appointment Planning, Proximity Search, Heat Maps, Shape Overlay, Census data 
visualization and Territory Management to drive better sales, improve business processes and engage 
right customers at the right time. 
 
Maplytics is available for Microsoft Dynamics versions CRM 2013 and above and supports all deployment 
models of CRM On-Premise (IFD as well), CRM Online and Partner-hosted. It uses the API services provided 
by Bing maps. The following are the highlights of Maplytics: 
 
 Ease of access 

 Compatible with Dynamics 365 App for 

Phones and Tablets 

 Multiple language support 

 Plot multiple OOB & custom entities on map 

 Area of Service 

 Search nearby records with Proximity Search 

 Auto Scheduling for multiple users 

 Track field reps’ activities with Check-In 

 Custom icons for pushpins 

 Multiple category on plot card 

 PowerApps Component Framework 

 Multiple categorization for single entity 

 Multiple territories for a record 

 Spider Cluster 

 Building Marketing list 

 Pie Charts and Column Charts in Heat Map 

 Overlay 

 Merged Plot and Route view 

 Maplytics Security Template 

 Point of Interest search 

 Layer Menu 

 Concentric Proximity search 

 Bulk geographies upload 

 Shape operations 

 Territory Management 

 Auto-Territory Creation 

 Draft Territories 

 Census data visualization 

 Support for CDS 

 Data grid resizable 

 Plot Saved Templates on individual records 

 Configurable categorized color-coded 

pushpins  

 Routing with multiple waypoints 

 Along the Route search 

 Ability to Save & Share Driving directions 

 Sales analysis with Heat Maps 

 Summary Card on Detail and Heat Map 

 Configurable color for Heat Map measure  

 Maplytics Dashboards with configurable 

queries  

 Geocoding Confidence Rating 

 Route Redirect for turn by turn navigation on 

mobiles and tablets 

 Seamlessly integrated within Dynamics  

 CRM / Dynamics 365 Customer Engagement  View travel distance on proximity search 
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Language Support 

Maplytics is a multi-language solution currently available in six different languages namely: 

 English 

 Spanish (Español) 

 German (Deutsche) 

 French (Français) 

 Portuguese (Português) 

 Turkish (Türk) 

 Arabic ( ى  (عرب

  Maplytics auto-detects the user language 

set in Dynamics CRM and sets its 

language accordingly.  

To check user language set in Dynamics 

CRM, please go to Settings > Options > 

Languages 
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Maplytics Configuration (Personalization) 

Each user of Maplytics can customize Maplytics configuration according to their preference. The user can 

configure Zoom level, Current Location, default origin and destination and a couple of other settings like 

Map more, default summary grouping, etc. Please go to Settings > Maplytics Configuration Details > 

Select Maplytics Configuration record for the required user (users added in Team Maplytics)> Set 

according to the preference  

Refer to ‘Maplytics Configuration Details (Personalization)’ section of Installation Manual for a detailed 

description of personalization settings.  

Maplytics Security Template 

System admin and Maplytics admin can provide selective access of Maplytics actions to the Maplytics 
users. They can select the required Mass actions & other actions in the list and save it as a Security 
template. They can further assign this template to the required users so as to provide the access of the 
selected actions in the template to the respective Maplytics users.  
To create a Security Template,  
Go to the Maplytics App > Settings > Maplytics Security Templates > New > ‘General’ tab > Give a name 
and ‘save’ the template. 
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To assign a template to the Maplytics users, Admins can add 
the Maplytics Configuration Detail records of the Maplytics 
users under the section of ‘Maplytics Configuration Details’, 
to whom the template has to be assigned.  

 
 

 

 

 

 

 

 

 

 

 

In order to assign the Security Template to multiple users at once. Admins can also add teams/users using 

the button ‘Manage users’ from the Ribbon bar.  They can also remove the required users/teams from 

the list. Thus, using ‘Manage users’ admins can easily manage the users assigned with any Security 

Template. 
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Admins can choose whether they want to assign the template to Users or Teams by adding them. They 

can also choose to remove the users/teams from the list. They can also see the list of teams and respective 

users added from those teams.  

  

Note: A Maplytics Security template can be assigned to the users belonging to any team, however, 

they should also exist into the Maplytics team.  
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Go to Action Configuration > Select the required actions to be made available to the users assigned with 

this template and save. 

 
Along with using the ‘Remove’ button, to unassign any template to a user, admins can also Go to Maplytics 
App > Settings > Maplytics Configuration Details > Select the record of the required user> Remove the 
lookup value for the field of ‘Maplytics Security Templates’   
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Note:  

 All the actions will be visible to a user, if no template is assigned to the user 

 Only System Admin and Maplytics Admin will be able to access the Maplytics Security Template Entity 
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Individual Record Map 

A tab to display an Individual Map section has been added by default on the Account, Contact and Lead 

records as a part of the Maplytics solution. 

 
Here, two types of pushpins are plotted on the map: 

 Orange color pushpin: 

This always indicates the record location on the map. This pushpin is movable on the map. If the 
user is not satisfied with the automatic geocoding information stored for the record, they can 
manually move the pushpin to the exact location of their choice. As the user moves the pushpin, 
the geocoding information (Latitude and Longitude) is updated in the bar at the top. Use the 
Update button to save the updated geocoding information.  

If the application is not able to geocode the address provided, the user can edit the address in the 
Address text box and click on Search button. This will help the user to geocode the address.  

Set the ‘No Auto Geocoding’ option to ‘Yes’ available on the left-hand side, if the user has manually 
set the geocoding information and do not want the automation to override the geocoding 
information. 

 Related Record Pushpin: 
The related records are indicated by star pushpins. Related records correspond to all 1:N 

relationship between the plotted Entity and the user can set a default relationship which should 

always be plotted whenever this map is loaded. The user can further see related record 

information by clicking on it. The user can plot maximum two relationships here. The user can use 

‘Relations’ drop-down to select the available relationships for this Entity. Check the Entity Map 
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settings (refer to Installation Manual) to set Default relationship and adding more relationships 

to ‘Relations’ dropdown.  

 

Steps to add the Map to other entity 

forms 

Open the Entity form and go to the ‘Insert’ 
tab. 

Click on ‘Web Resource’ button, as shown 
in the screenshot. 

 

 

In the Add Web Resource dialog, select 
“ikl_/Maplytics/Maplytics.IndividualMap.html” 
web resource and check the Pass record object-
type checkbox as shown in the screenshot. 

Click OK, then Save and publish the form to see 

the Map on the entity form. 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

Note: To plot a particular address on the Map, it should be geocoded and the Latitude & Longitude 

should be set for that address. For geocoding you need to execute Maplytics Geocoding workflow for 

the records. 
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Area of Service 

The user can view the data in a proximity or a region around an individual record as defined by the user 
in the Area of service.  

 

Add Area of Service tab 

To add Area of Service tab, Open the Entity form and go 
to the ‘Insert’ tab. Click on Web Resource button, as 
shown in the screenshot.  
 

  

 
 
 
 
 
 

 

 

In the Add Web Resource dialog, select 
“ikl_/Maplytics/Maplytics.AutoSearchFilters.ht
ml” web resource and check the ‘Pass record 
object-type’ checkbox. 

The preferred number of rows in formatting is 15. 

Click OK, then Save and publish the form to see 
the Map on the entity form. 
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Create an Area of Service field 

To save the values entered in the Area of Service, the user needs to create a field for the Entity for which 
Area of Service has been added. Go to Entity form > New field. Enter the following values:  
Name - Area of Service 
Data type – Multiple Line of Text 
Maximum Length – 10000 
Select the field in the respective Entity map for the Area of Service field.  

  

The values when entered and saved into the Area of Service, the corresponding data will be plotted on 
the map.  

View Area of Service data on a map 

To view the Area of Service data on the map, there are two ways:  

 Using Map button – the results are shown in a map opened in a different tab 

 Adding Detail map on form – the results are shown in a map added on the same record 

Using Map button 

The user can open the Detail map to view the corresponding Area of Service data plotted on the map. 
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Adding Detail map on form 

 

To add a Detail map to show the data of Area of 

Service, follow the steps mentioned below: 

Open the Entity form and go to the ‘Insert’ tab. 
Add two columns.  
 
 

Click OK, then Save and publish the form to see 
the Map on the Entity form. 
 
 
 
Enter the required values into Area of Service, save it and click on the refresh button on the Detail map to 
view the data plotted.   

 
 

After adding Area of Service tab in the entity form 
as mentioned above, follow the steps mentioned 
below to add the Detail map on the entity form.  
 
To add a detail map, Click on ‘Web Resource’ 
button. In the Add Web Resource dialog, select 
“ikl_/Maplytics/Maplytics.DetailMap.html” 
web resource, add “form” as custom parameter 
(data) and check the ‘Pass record object-type’ 
checkbox as shown in the screenshot. The 
preferred number of rows in formatting is 15. 
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Detail Map 

Maplytics buttons are added to the Entity forms as well as the Entity Homepages so that it can be easily 
accessed from anywhere.  

 
Using this button, the user can invoke the Maplytics application for detailed geographical analysis.  
Maplytics provides both ‘Heat Maps’ view as well as ‘Detail Map’ view of the Dynamics CRM data. These 
views can be easily accessed from the buttons added to the command bar in entity home pages and 
other views. 
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Selecting a few records and clicking on the ‘Detail Map’ button on a particular Entity Grid view will open 
the following window; 

It will automatically plot the selected records from the view on the map. Records that do not have their 
latitude/ longitude will be ignored and will not be plotted on the Map.  
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Plot 

There are five different search options to plot the data on Map: 

 By Location 

 By Region 

 By Drawing 

 By Territory 

 By Template 
 

 
 

By Location 

This helps the user to plot the data using the geocoding of each record. 
By Location search option also allows the user to perform 
Proximity/Radius Search based on Distance or Time.  

The Current Location is fetched from the user’s personalization record. 
The user can also set a new current location using the contextual menu. 
Refer to the section of the Contextual menu.   

 

 

 

 

Select Datasource dropdown will list out all the Entities (OOB and 

Custom) configured for Maplytics and the active views (System views, 

Personal views, Maplytics Dashboards and Marketing Lists) that are 

available for the selected Entity type. The user can choose one of the 

views to plot all the records available in that view.  

 

 

 

 

 

Note: The user can also configure the ‘Search Options’ to be visible on the map. Refer ‘Setup 

Entity Map’ section of Installation Manual for further instruction. 

Note: The user can also configure the ‘Views List’. Refer ‘Setup 

Entity Map’ section of Installation Manual for further instruction. 
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The user can select additional entities using the ‘+’ button. The user is 

allowed to specify a maximum of 3 Datasources for plotting the data 

at a time. This allows for viewing Dynamics CRM data across Entities 

in a single view on the map.  

After selecting multiple entities, the user can click on the ‘Search’ 

button to plot the records for the selected entities. This helps the user 

to visualize three entities on a single map. 

 

 

 

 

 

 

 

 

Note: User can define the colors as well as pushpin shapes of 

the Entity – view combination. Refer to ‘Setup Entity Map’ 

section of Installation Manual for further instructions. 
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By Region 

This helps the user to plot the data by the region of records, i.e., City, 
State, County, Country, PostalCode, PostalCode Sector, Postal 
Code(Outward Code), Postal Code Areas. The user can plot multiple 
regions under a particular region type. 

 Postal Code: The smallest postcode category, such as a zip 
code. 

 Postal Code Sector: The second ‘1’ is called “Postcode Sector”. 
Example: CA1 1 

 Postal Code(Outward Code): This is called Outward Code, the 
part of the postcode before the single space in the middle. 
Example: CA1 

 Postal Code Areas: The next largest postcode category after 
Postcode1 that is created by aggregating Postcode1 areas. 

 

  
 

 

 

 

Note:  

 The regions that were plotted using the option of Post code Areas before will now be plotted 
by using the option of Post code sector.   

 The regions will be plotted as per the Bing maps.  

https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fen.wikipedia.org%2Fwiki%2FPostcodes_in_the_United_Kingdom%23Overview&data=02%7C01%7Cv-szczup%40microsoft.com%7C65818020a8fc4120be9108d618ac626f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636723526031148736&sdata=uIf6X6f4o349Rg6LSBtVlpIXeqzCk4kDyXjSZjRzWbE%3D&reserved=0
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By Drawing 

This helps the user to plot data by defining their own shapes. The user can use the ‘Drawing tool bar’ to 
draw the following shapes:  

 Freehand drawing  

 n-sided polygon 

 Circle 

 Rectangle 

The user can further edit the drawn shapes by using the following options in the Drawing tool bar: 

 Edit  

 Erase 

 Fill color 

 Stroke color 
 

 
 

 
 
 
 
 
 
 
 
 

Note: While creating an n-sided polygon, use the ‘Esc’ key from keyboard to close the shape.  
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By Territory 

This helps the user to plot the data defined in a particular sales 
territory. The user can select multiple territories in ‘Select Territory’ 
option and respective Datasource & view to plot the territories along 
with the records assigned with them. 
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By Template 

This helps the user to plot the predefined search criteria in Detail Map. The user can save the search 
criteria as a template and use the ‘By Template’ search option to quickly plot the data with that search 
criteria. This helps the user to save a considerable amount of time.  

 

For example, if any user is assigned with a task 
where the requirement is to regularly plot ‘My 
Active Accounts’ records in 2 miles of a 
particular location and filter a particular 
Industry, then the By Template option can be 
beneficial. 

 

The User can use the button ‘Save template’ to 
save the search criteria as a template and define 
the access level of the Template while saving the 
template as described below: 

 Personal – The users can limit the usage of 
this template to themselves 

 Public – Anyone in the organization can 
use this template 

Apart from saving information of Plot Records, 
Category card, and filters from Grid, it also saves 
the Zoom level & Center of the map. 

 

 

Default Template 

User can set the Default Template within their respective Configuration Detail record and view the 

predefined search criteria saved in the template plotted by default on the Detail Map.  

To set a template as Default, user need to Go to the Maplytics App > Settings > Maplytics Configuration 

Details > Respective User Configuration Detail record > General > Default Template > Select required 

template.  

Note: Please assign ‘Maplytics User’ security 

role to Team Maplytics before exploring this 

functionality.  
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When clicked on the ‘Detail Map’ button, it will plot the default template selected in the respective user’s 

Maplytics configuration detail record by default on the map.  
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Note: Default Template will not open if, 

 User selects a few records in Entity home grid and then clicks on Detail map button. 

 User expands a dashboard to open on Detail map. 

 User has saved Default template with search criteria other than By location/ Proximity 

Search and uses the ‘Map’ button on a specific record to open the map. In this case, the 

respective record will be plotted on map. 

 User has set Area of Service on a record and is using the ‘Map button’ on the record to open 

the map. 

Note: Below are some exceptional cases for Default template where the plotted data might vary.  

 If Default template has been saved with search criteria By Location and the user uses the 

‘Map’ button on a record to open the Map, in this case, the respective record will be plotted 

as the current location along with other records selected within the Default template. 

 If Default template has been saved with search criteria Proximity Search and the user uses 

the ‘Map’ button on a record to open the Map, in this case, the respective record will be 

plotted as the current location replacing the initial current location set in the template. Thus, 

the records will be plotted within the specified radius from the respective record’s location 

which is now the current location on the map.   
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Cluster map 
 
The user can select this option to group the closely positioned pushpins into a cluster. A cluster shows the 
number of pushpins in the cluster. The user can zoom in further to break down the cluster into smaller 
clusters or zoom out to group closely positioned clusters into one. 

 

Cluster Area  

The user can hover on any cluster to see the ‘Cluster area’ which shows the data spread. The data spread 
is based on the area covered by the pushpins existing in the cluster.  
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Spider cluster   

The user can click on any cluster to view the pushpins existing in the same in the form of a ‘Spider cluster’. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: Spider clusters can be visualized only for records less than or equal to 50.   
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Category  

Users can choose any attribute for the selected entity to categorize the data on the map and visualize the 
pushpins color-coded based on the selected attribute.  

Multiple categorization for multiple entitles 

User can plot a maximum of three entities on the map and can also select one attribute for each of the 
three datasources selected to categorize them. The screenshot below shows the categorization of the 
records of Account, Lead and Opportunity based on the attributes Annual revenue, Rating and Estimated 
Revenue respectively.  
 

 

 
 
 
 
 

Note:  

 User can choose respective categories for at a maximum of three different entities.  

 The user can define the color as well as shape of pushpins for each parameters of category. 
Refer to Pre-Define Colors for Category section for further details.  

 User can also choose the field attributes to be visible in Category list. Refer to ‘Setup Entity Map’ 
section of Installation Manual for further instruction. 
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Multiple categories for single entity  

Users can also plot a single entity records categorized by 

multiple attributes e.g. Account records categorized by Open 

revenue, Originating lead, Owner. Users can also choose an 

entity twice or thrice with two or three different views 

respectively and choose at a maximum of three attributes to 

categorize the entity records.  

While plotting a single entity categorized by three attributes, 

three category cards will open up for the three attributes. For 

example, the screenshot below shows Accounts plotted on the 

map which is categorized by three different attributes viz. 

Annual Revenue, Industry and Owner and three different cards 

have opened up for each of them.  

 

 

 

 

Note: User can select a maximum of three attributes to 
categorize a single entity.  
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The category cards shown above states which category is represented by which pushpin. The categories 

are represented with the following three different parts of every single pushpin.  

  

  

  

All the above three icons combine to form a pushpin which will represent the plotted records. Each of 

the three parts represent three different categories with different colors shown within the category card. 

For example, the category card ‘Account – Annual revenue’ shows that the icon represents the 

Account records that belong to different ranges of Annual revenue with different colors. The category 

card ‘Account-industry’ shows that the icon  represents the Account records that belong to 

different industries with different colors and the category card ‘Account-Owner’ shows that the icon  

represents the Account records that belong to different owners with different colors. 

In case, the user has selected only two attributes in order to categorize the entity records, the pushpin 

that will be used to represent two categories will be . 

The plotting of categories follows AND condition. This means that if the user deselects a category in one 

category card, then all the pushpins for records that belonging to that category will be hidden from the 

map even if any of the records belong to any other categories as well. For instance, if the user deselects 
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the category of Annual revenue between 5000-10000, then all the pushpins for the records that belong 

to this category will be hidden from the map even if any of these records belong to other category like 

owner or industry.  

In the screenshot below, three categories have been selected viz. Annual Revenue, Industry and Owner.  

 
In the screenshot below, only two categories have been selected viz. Annual Revenue and Industry.  
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Data Grid in Detail Map 

The Data Grid is available at the bottom of the Detail map which can be opened using the yellow button 
‘View Data’. All plotted pushpins represent a unique record in Dynamics CRM and data grid helps the users 
to access these records from the map screen, filter the data further and perform some mass actions. Order 
of columns in the grid depends upon the Dynamics CRM View selected to plot the data and in the case of 
Marketing Lists & Maplytics Dashboard records, it is same as that of the Entity-View selected in Entity 
Map. The users can also customize the data columns to be visible in the grid by adding/removing columns 
from the Entity view.   

 
Filter & Sort Data: 
The user can use the filter present on the top of every column to filter the data further selecting any of 
the conditions and entering the respecting value.  
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User can see the filter icon at the column header to understand based on which column the data has been 
filtered. Further, user can also click on any of the column header to sort the data and can see the arrow 
icon at the column header to understand based on which column the data has been sorted. User can 
deselect some of the records and see at the bottom the number of records selected from the list

 
Reset: 
This will reset the grid to the initial search. 
 
Parent Record / Related Record: 
This is useful when the user is dealing with plot related records functionality. The user can switch between 
child data and parent data using this button. 
 
Resizable Data grid: 
Double click on     Expand button to view the data grid in full screen. Double click on      Collapse 
button to view the default size of the data grid. Use can also click once and drag to resize the data grid to 
the desired size.  
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Highlight pushpins 

User can click on any record within the Data Grid to highlight the respective pushpin on the map. User can 
also click on any pushpin on the map to highlight the respective record in the Data grid.  

 

Mass Action Buttons 

The user has the option to take actions on the plotted records like adding to route or executing the 
workflow on selected records in the grid. Defined mass actions are as follows: 

 Add To Route: This option will add selected data points to the route. The user can add at max 25 
data points to the route 

 Save Data: The selected records can be saved as static Marketing List or Personal View in 
Dynamics CRM 

 Change Owner: The user can assign the owner of the plotted records by selecting a user or a Team 

 Manage Territory: The User can assign or change the territory of selected records 

 Send Email: The user can send a mass email to the selected records. User can select any one the 
available email templates or a new email to write their own content. User can also choose to keep 
the recipient as To/Cc/Bcc in the email.  
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Select regarding: If user needs to send bulk emails and also wants to keep a specific record in the 
Regarding field into the email. They can select the option of ‘Select Regarding’. To view this option, 
they can follow the steps mentioned below.  
o Open the respective record to be set in Regarding field from the ‘Map’ button on the record. 

In the screenshot below, we have taken an Account ‘Gourmet to your door’ as an instance.  

 
o Now plot the required records to whom the mail has to be sent and Go to Mass actions to 

choose the option of ‘Send email’. Here, we have plotted Contacts.  

 
o Once clicked on ‘Send Email’ from ‘Mass Actions’, user can select the option of ‘Select 

Regarding’ and  the Account that we plotted earlier ‘Gourmet to your door’ will be set by 
Default within the Regarding field. 
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 Execute Workflow: The user can execute any on-demand workflow with this functionality 

 Export To Excel: The user can use this feature to export data from the map to excel. This 
functionality adhere to CRM security roles, if the user does not have the permission to ‘Export 
Data to Excel’ in CRM then that user will not be able to export data from Maplytics 

 Create Activities: User can create activities for non-activity Entity records currently selected in 
“View Data grid.” The user can define the Activity, Subject, Duration, Owner(User/Team) and 
Priority. The user can also select the number of activities they want to create from Mass actions. 
The activity selected in respective Entity maps can be seen in the Mass actions list under the label 
of “Create activities”, by clicking this label below window will open which will list the activity 
selected in respective entity map.  

 Associate Records: This helps the user to associate a record with the plotted record(s) on map.  

To do this, user needs to open the map using 'Map' button on the record they want to associate. 
In the below screenshot we have opened map from an Account. 

  
Once the map is opened, plot the required Entity & View to associate the Account. Now, click on 

‘Mass actions’. 

 

 

Note: This option will be visible only if the map has been opened using map button on a 
record.  
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In the below screenshot, we have plotted Contacts on the map using Proximity Search.  

 
Within Mass Actions, click on ‘Associate Records’to open the window. Here, the relationships 

between both of the entities, the records plotted and the record from which the map has been 

opened will be listed. User can select the relationship through which they want to associate the 

records . Here, the record from which the map was opened has been selected by default. User 

can also select another record as per their requirement to associate with the plotted records.  

 

 

 Auto Scheduling: This can be used to create a schedule for one or more users automatically.  Refer 
to the section of Auto scheduling to know how Auto Scheduling works.  

Note: This option will be visible in Mass Actions only if the map has been opened using map 
button on a record.  
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Tooltip Card  

User can click on any pushpin to open a tooltip card. 
This card will display the data like Address, Account 
name etc. which is defined in the Tooltip Mapping 
section of the Entity Map.   
 
 
 
 
 
 
 
 

 
 
 
 
 
User can also set a particular record as ‘Origin’, 
‘Destination', ‘Add to Route’ under Direction, ‘Set as 
Current Location’ and ‘POI location’ from the Tooltip 
card.  
 
 
 

 
 
 
 

Quick Call to Action Buttons 

User can associate quick action buttons. This helps in saving time while switching between screens to take 
actions. First four actions are the default actions and cannot be changed by the user. User can further add 
actions for creating records for activities and related entities. The default records are as follows: 
 

 Change Owner      : Assign an owner to the respective record by selecting a user or a team 

 Open Record      : Open record directly from this screen to edit any field 

 Plot Related Record      : Plot One-to-Many Relationships/Related records of a particular record as 
shown below: 
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Select the required relationships from the list and click on ‘Plot Records’ button. Related records will be 
plotted as shown below. Use ‘Parent Records’ button to switch between Parent and Related records data 
points.  
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 Run workflow   : The user can execute on-demand 
workflows on an individual record. When clicked on this 
button, it will open a window which will list down all the 
on-demand workflows available for respective Entity as 
shown below:  

 
 
 

 
 

The user can customize the rest of the actions according to their requirement. For example, user can add 
Email, Add Task, Appointment and Quote and many more.  

 Email      : Send email to this record  

 Add Task      : Add task to this particular record 

 Appointment      : Schedule appointment with this record  

 Quote       : Create Quote related to the plotted entity record 
 

The user can define these actions under ‘Advance Settings’ in 
Entity Maps. Go to Setting > Entity Map > Select Required 
Record > Advance Settings > Tooltip Card Actions or refer to 
‘Setup Entity Map’ section of Installation Manual for further 
instructions.  

Hover 

User can hover on Dynamics CRM Records plotted on the map to have a quick glance at its details. 

 
The user can have a maximum 6 different attributes here apart from the title attribute. Refer to the ‘Setup 
Entity Map’ section of Installation Manual for further instruction.  
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Reset Map 

User can use the button of ‘Reset Map’ to reload the map with the initial Detail map 
settings.  
 
 
 
 
 
 
 
 
 

 
 
 

Note:  

 This action will clear all the data plotted on map 

 The refresh map button will show the same data on the map in the following conditions: 
o Expanding the map or plotting a route from a dashboard 
o Using the map button from an individual Entity record page 
o Plotting a route or a template 
o Plotting records by selecting the records from the Entity records page 
o User had set a default template for the Detail map 
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Summary Card 

The user can click on any enclosed area to get the summarized information of the plotted records in that  
area in a summary card. The area clicked will get highlighted and the respective data will be visible in the 
data grid. The user can customize the settings for this under the Summary card section in the respective 
‘Entity Maps’. Refer to ‘Setup Entity Map’ section of Installation Manual for further details.  

 
With territories plotted on the map, Summary card also provides a button to ‘Open Record’ that can be 
used to open the respective territory from the map itself.    
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Layer Menu 

This helps the user to select the required data among the multiple data plotted on the map. The user can 
use the toggle buttons on the Layer menu card to show or hide the required layers of the data to be shown 
on the map without removing the same from map. 

 
The layer menu card will show the following icons for the respective layers mentioned:  

 

Layer type Icon Layer type Icon 

Data source 
 

Territory 
 

Route 
 

POI 
 

Proximity  Cluster Pushpin 
 

Drawing Shape 
 

Shape Operation 
 

Region Shape 
 

Overlay- Shape file 
 

Plot-child 
 

Territory Management – 
Shape file  

 

 

     Note: Layer menu card is collapsible but a user can not close this card exclusively. 
 

     Note:  

 Layer icon for Data source layer, POI layer and Plot-child layer will change depending upon 
pushpins visible on map 

 If category is selected in the plot card, the layer menu card will show only the default pushpin 
for the Data source layer 
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Show/Hide Labels  

User can click on the ‘Show label’  button to view the labels for the pushpins, regions as well as 
territories plotted on the map. User can again click on ‘Hide Label’  to hide the labels showing on the 
map. The option for showing/hiding labels is available for every individual layer of data plotted on the 
map. 

 
 

Show/Hide Territory List 
With territories plotted on the map, layer menu 
will also show an option of Show/Hide List for the 
layer of territories. User can click on the 

show/hide list button  option to open the list 
of territories plotted on the map.  
 

User can select or deselect the territories which are 
required to be plotted on map. User can further 
change the name, select a color and select the 
manager for the respective territories and also save 
the same with the ‘Save’ button within the ‘Territory 
List’ card. 
 
 

     Note: Show Labels is available for less than 5k records. 
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Contextual Menu 

User can right click on the map to open Contextual menu. It provides 
commonly used features in Dynamics CRM like creating a new record, set 
origin/destination or selecting map zoom level on the map, etc. The 
contextual menu provides the following options:  
 

 

 
 
 
 
 
Create New Record:   
User can right-click anywhere on the map or POI result 
icons and create a record for that particular location. This 
will save the record with the details of the address and 
the geo-coordinates (Latitude & Longitude).  
 

Directions:  

 Set As Origin: This option will set the address of the pushpin/map location as the start location of the 
route. 

 Set As Destination: This option will set the address of the pushpin/map location as the end location 
of the route. 

 
Add to Route: This option will set the address of the pushpin/map location as a middle waypoint(s) of the 
selected route. For example, the user has selected Point A & B as orgin & destination respectively for a 
route and now clicks on the ‘Add To Route’ option, the Point B will remain as the destination and will 
become the Point C. The address of the selected pushpin will become the Point B of the route. 
 

Set as Current location: User can click on any pushpin or anywhere on the map to set the address of the 
pushpin or the location as the current location respectively, which can be used for Proximity search.  

 
Set as POI Location:  
This option helps the user to set the location for the Point of Interest (POI) searches like ATMs, restaurants, 
Airports, etc. Setting the POI location, user can search for various Geo-tagged & Bing mapped locations 
around it. 
 
Save Settings: 
User can save the default settings for the following options. These settings will be saved in the 
Configuration details record of the user: 

 Current location: This will save the location as the default current location. 

Note: Create new record option will not available 

for existing record pushpin 
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 Map zoom level: This sets the zoom level and map center for the Map. After this setting is done, 
whenever the user will open the Detail Map, it will be zoomed down to the location set here.  

 Origin: This sets the location as the default origin. 

 Destination: This sets the location as the default destination 
 
Show Territory: 
User can right click anywhere on the map or at any record to select the option ‘Show Territory’ from the 
Contextual menu. This will plot the respective territory to which the selected location or the record 
belongs to. Further, user can click on ‘Hide territory’ from Contextual Menu to hide the plotted territory. 

 
 
User can also click on any pushpin to get a contextual menu. Along with the 
options mentioned above, this will provide the following options: 
 
Open record: User can open the record form right from the map and can 
further edit the details for the record. 
 
Actions: User can perform the following actions on the pushpin selected: 

 Add Task: This option helps the user to create a new task in Dynamics 
CRM regarding the selected record. 

 Schedule Appointment: The user can use this option to create a new 
appointment for the selected record.  

 Manage Territory: The user can assign/re-assign a territory to the 
selected record from the map and hence can manage the territory. 
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Point of Interest (POI) Locations  
User can search for any geo-tagged Bing-mapped locations called points of interest (POI) like ATMs, 
restaurants, hotels, coffee shops, etc. near a specified location. This can also be plotted alongside the CRM 
data. User either can right-click on map to set the location as the POI location or can directly enter the 
required location in the POI card.  

 
User can either click on any of the POI icons or manually search for required POI location by entering the 
respective keyword in the search bar. 

 
Based on the selected POI location icon or the entered keyword, the results will be loaded. 
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Apart from plotting POI data, user can also add the plotted businesses in Dynamics CRM record as leads, 
accounts, contacts, or any custom entity by using the Create New Record option in the POI card or 
Contextual menu. (Refer to Contextual menu section) 

 
 

Note:  

 The option to enter a keyword to search POI locations is only available while searching in USA.  

 For each POI location search, only 25 locations will be plotted on the map.  
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Proximity Search  

User can search for the nearby records around a required location using Proximity Search. This will help 

the users to understand the proximity of the nearby records in regards to the selected location. There are 

two different options to perform a Proximity Search: 

1. Proximity by Distance  

2. Proximity by Time.  

 

Current Location: User can select any location or a record as the current location. This is used to specify 

the center point for the Proximity search. By default, this field displays the address stored in the Maplytics 

personalized record of the logged in user. This is always represented by a green color pushpin on the map 

and also indicated right next to the current location message box.  

Proximity by Distance 

This option will calculate the straight line distance between the current location and all the points which 
fall in the proximity parameter as shown below: 
 

 
 
Enter the radius for the Proximity search. The user can also add decimal values with a scale of 2 for the 
radii. The Proximity can be provided either in Miles or Kilometers. The User can also hover over a pushpin 
and see the distance from current location.  
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Concentric Proximity Search 

This new addition to Proximity based on Distance allows users to perform up to 3 proximity search 
simultaneously. The user needs to enter the distance values separated by a comma (,) and all the points 
that fall in the defined proximity parameter will be plotted. 
 

 
 
The Concentric proximity zones are represented by different colors for easy visual analysis. The user can 
also click on individual proximity zones to highlight the circle and open the Summary Cards for that 
proximity parameter. 
The user can also filter the data points based on the proximity zone and their proximity distance from the 
current location in the ‘View Data’ grid.  

 
 

 
 
 

Note: User can enter integer value from 0.1 to 2000 for distance proximity search. 
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Proximity by Time 

This option will calculate how many points fall in ‘x’ minutes or hours of driving distance from current 
location.  The Proximity can be provided in either Minutes or Hours. The User can also hover over a 
pushpin and see the distance from current location.  
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Show Travel Distance 

While performing Proximity Search by Distance or Time, if the user wants to see the actual travelling 

distance from the current location till each of the individual pushpins, they can select the checkbox of 

‘Show Travel Distance’ to view the Shortest Travel Distance on the hover and view data grid.  

 

Show Travel Distance for Truck 

 

Once the user selects the option of ‘Show Travel Distance’, 

user will get an option to an Asset and Hazardous material. 

This will provide the list of the assets created in the Asset 

entity within the CRM. If the user wants to search for the 

shortest travel distance for truck, they can choose to 

select the respective Asset and if any Hazardous material 

is being carried out or select none from the following list: 

• Combustible   

• Corrosive   

• Explosive   

• Flammable   

• Flammable Solid   

• Gas   

• Goods Harmful To Water   

• Organic   

• Poison   

• Poisonous Inhalation   

• Radioactive  

• Other 

• None 

 

Note:  

 If user has not selected any asset here, by default, the travel distance will be calculated as 

per driving by car.   

 The feature of ‘Show Travel Distance’ based on driving by truck uses a separate key. Every 

time the travel distance is searched based on driving by truck, 3 transaction limits of the key 

are consumed for each pushpin that appears within the proximity. 
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Overlay 
 

This helps user to view the Dynamics CRM records along with 
shape/excel files and existing territories plotted on the map. User can 
also view the ‘layer menu’ to select or deselect the layers so as to show 
or hide the same respectively. Using Overlay user will easily be able to 
understand and analyze the data spread in required shape file regions 
and territories. 
 

User can select the following two options: 
 Territory – This option helps the user to select among the list of 

existing territories 
 File – This option helps the user to select among the list of 

shape/excel files. The file should be in a territory in order to be 
visible in the list. 

 
 
 
 
 

Overlay by Territory 

User can select the option of Territory and select the territories they want to plot. Along with this, they 

can also select any datasource & view. This will help them view the datasource records along with the 

Overlay of territories selected.  
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Overlay by File 

User can select a excel/shape file saved in CRM to plot the same on the map. Further users can select the 
following options as well. 
 
Category Attributes: An attribute can be selected to categorize the regions plotted by file.  
Summary Attributes: One or more attributes can be selected to show the same in the Summary card. The 
attributes selected within the ‘Configuration’ of the saved file in the Territory Entity will be selected by 
default. User can deselect them and can select other attributes. 
 
Users can also uncheck the option of ‘Plot All Regions’ if they do not want to plot all regions from the file. 
In this case, they can right click at any location on the map to select the option of ‘Show region’ from the 
Contextual Menu. This will help them to view the region for the respective selected location. User can 
again click on ‘Hide Region’ from the Contextual Menu to hide the region for the respective selected 
location. Further, user can also open the respective territory within which the file is saved using the ‘Open 
record’ button on the Summary card.  
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Save Shape/Excel file in territory 

A file should be saved in a territory in order to be visible in the list of the files to be plotted as an Overlay. 
Follow the steps mentioned below to save the shape/excel file in a territory: 

 Go to Settings > Business Management > Sales Territories > Create a sales territory > Save  

 Go to Territory Map Preview > Select Option > Shape file/Excel file > Save 

 

Save Shape file 

Within the Territory Map preview, user can select the option of ‘Shape file’ and select the color to view 

the regions in the same.  
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Save Excel File 

Within the Territory Map preview, user can select the option of ‘Excel File’ to select an excel file to the 

territory. User can also select the color to view the regions in the same. They further need to select the 

following options in order to save the excel file as per their requirement: 

Select Region Type: User should select the region type based on which the boundaries of the regions from 

the excel file is to be plotted.  

Select Region Value: User needs to select the column from the excel file that contains the values for the 

selected Region Type.  

Select Main Region: User needs to select the column from the excel file that contains the value for the 

biggest region for the selected Region type in order to plot the regions accurately. For example: If the 

Region type selected is Postal code, so the Main Region should be preferably Country. If the column of 

country is not available then the column with the values for respective States or Cities can be selected.  
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Convert Overlay to territory  

User can use this button to convert an overlay record 
to a territory. After the overlay record is converted, it 
becomes a territory which can be searched in the 
option of ‘Territory’ in Overlay.  

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note:  

 Supported file types for shape files are .shp, .kml and .geojson and excel files are .xlsx, .csv 

 In a territory, either a shape/excel file can be saved or geographies can be created  

 Only one shape/excel file can be saved in one Territory 
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Census data Visualization 

This feature helps the user to visualize census data on the map. Census data provides the information 
about the population for a whole country or parts of country. Visualization of this data on Maplytics will 
help the user to analyze various information of the required area in a country like Housing units, Area 
land, Area water, population demographics, etc. and take strategic decisions. A few census data are 
available by default within Maplytics. These default census data are provided by Bing maps for USA. User 
can also plot their own census files on the map which contains census data. User can configure categories 
to see colored regions as per the configuration and also configure attributes to see on Summary card and 
hover on region. 
 
To plot the census data, user can choose the option of ‘Files’ in the feature of Overlay. Please refer to the 
section of ‘Overlay’. Further users can select the following options as well. 
 
Category Attributes: An attribute can be selected to categorize the regions plotted by file.  
Summary Attributes: One or more attributes can be selected to show the same in the Summary card. The 
attributes selected within the ‘Configuration’ of the saved file in the Territory Entity will be selected by 
default. User can deselect them and can select other attributes. 

Configuration for Census data 

User can configure the Census files provided by Maplytics in the Dynamics CRM. Please refer to the section 
of ‘Configure’ in Installation manual for the steps to configure. This will save some census files in CRM 
provide by Maplytics. 
 
While configuring the census data into Dynamics CRM, territories will get created within which the 
respective census data will be saved in the form of geographies. To view the saved census data, Go to 
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Settings > Business Management > Sales Territories. Following are the territories for census data saved 
on configuration: 

 England-Cities 

 Germany-Postalcodes 

 NewYork-Postalcodes 

 USA 111th Congressional Districts 

 USA Counties  

 USA States 

 USA-Postalcodes 

Configuration for attributes 

User can configure the attributes available in the census data/shape files to show on the map, create 
categories for attributes and select the colors to visualize the categorized data on the map. This allows 
the user to frame the data how they want to view on the map.  
 
Go to Settings > Business Management > Sales Territories > Territories with census data/shape files 
saved > Configuration  
 

 Attribute Configuration: 
o Summary Attributes:  

User can select the attributes to show on the Summary card shown on the click on the 
regions in the census data/shape file plotted on the map.  

o Hover Attributes: 
User can select at a maximum of 6 attributes that will be shown on the hover on the 
regions in the census data/shape file plotted on the map. 

o Data grid Attributes: 
User can select the attributes from the census data/shape file to be shown as columns in 
the data grid in Detail map. 

 
 Category Configuration 

User can create categories for the attributes in the census data/shape file. Creating categories will 
help the user to view the categorized census data for the required attributes in the desired colors. 
Some categories are provided by default for configured census data. User can click on              New 
button to create a new category for any attribute. User can also click on     ‘Edit’ and       ‘Remove’ 
to make changes or delete the existing categories respectively.   
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 Create filters and define colors 
After clicking on Edit/New button, user can filter the attributes and define colors for the 
ranges of the filtered attributes.  
o Attribute: This shows the name of the Attribute for which the category has been 

created/will be created.  

o Display Name: User can type a name for the category which should be displayed in the 

list of the categories. 

o Save: User can click on save button to save the changes made. 

o Discard: User can click on Discard button to discard the changes made. 

o Filter: User can set various filter conditions for the category. 

o Value: User can set values for respective filters set. 

o Color: This can be used to set colors for individual filters set. The user can click on the         

Auto Set button to set random colors for all the values.  

o Add/Remove: Click on Add or Remove to add a new filter or delete the filter respectively. 
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After the user has created categories, user can plot the census data along with an attribute selected to 
visualise the categorised Census data on the map as shown below: 
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Shape Operations 

With the help of Shape operations, users can perform Binary operations on the shapes drawn on the map. 
These operations can only be performed under the Search option of ‘By Drawing’ in the Plot card and 
Territory management section. Please refer to the section of Territory management for the shape 
operations in Territory management.  
 
User can open the ‘by drawing’ search option and right click on the shapes and can choose the option of 
‘Shape operations’. The following five operations can be performed on the shapes: 

Difference 

This highlights the shape(s) obtained by subtracting the overlapped ones from the selected shape  
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Intersection 

This highlights the shape(s) where the selected shape and other shapes overlap. 

 

Union 

This adds all the shapes overlapped on the selected shape 
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Union Aggregate 

This performs union operation on all the shapes that are drawn on the map. If a shape does not overlap 
with any other shapes, it highlights such shapes and the union of the rest of the overlapping shapes.  

 

Disjunctive union  

This highlights the shapes that are not overlapped and lie in the selected shape & the shapes that are 
linked with the selected shape. 
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Undo – While performing operations, user can use the option of ‘Undo’ to go only one step back 
into the binary operations performed  
Reset – Using the option of reset, user can remove all the operations that are performed on the 
shapes drawn on the map  
 
 
 
 
 
 
 
 
 
 

Note:  

 To perform any operation, two or more shapes should overlap.  

 For Union Aggregate, there should be more than one shapes with or without overlap. 

 The highlighted shapes are new shapes as resultants of the operations performed. User 
can click on the highlighted shapes to view the summary card and the data in the view 
data grid.  
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Territory Management 

Territory management helps the user to create new territories manually as well as automatically and align 
the existing territories as well to get proper distribution of territories. User can plot required regions, draw 
shapes or directly upload shape files/excel files to get the required regions plotted on the map to create 
territories for the same. User can create territories multiple automatically based on count of records or 
use the territory Alignment tool to select the required regions and create new territories for the same. 
While creating multiple territories automatically, user can also save the territories as a draft and rework 
on the draft to get the territories created as per the requirement. Further, user can plot the existing 
territories and edit them to get proper distribution of territories.  
 

To access Territory Management, Go to Detail map > More Options > Territory Management  

 
 
 
User can use the search options to plot shape 
files, excel files, search by region, draw a shape 
or plot existing territories on the map. There 
are five search options:  

 By File 

 By Region 

 By Drawing 

 By Territory 

 By Overlay 
 
 
 
 
 

Note: Users other than System Admin, can use Territory management only if they are given the role 

of Maplytics Territory Manager 
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By File 

This helps user to plot the shape files and excel files on the map that store geographical information and 
attributes of the geographic features. User can plot the following two types of files:  

 Shape files: The supported file formats are .shp, .kml and .geojson 

 
 Excel files – The supported file formats are .xlsx, .csv 
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By Region   

 
This options helps the users to search for regions on the map 
by City, State, County, Country, PostalCode, PostCode 
Sector, PostCode(Outward Code), PostalCode Area.  
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By Drawing 

This helps the user to draw a shape on the map using the Drawing Tool Bar. 
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By Territory 

This helps user to plot the existing territories on the map.  
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By Overlay 

Users can select this option of ‘By Overlay’ to select any 

shape/excel file saved in CRM to plot the same on the 

map. Users can also select an attribute within ‘Category 

Attribute’ to categorize the regions plotted on map. 

Also, they can select one or more attributes within 

‘Summary Attribute’ to show on Summary card when 

clicked on any region plotted on the map. 

  

 

Note: If user has plotted any territory or shape/excel file using the feature of ‘Overlay’ within the ‘Plot 

records’ card and moves to ‘Territory Management’ card so the option of ‘By Overlay’ will retain the 

selection of the same while working with Territory Management. 
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Layer Menu 

This helps the user to select the required data among 

the multiple data plotted on the map. The user can use 

the toggle buttons on the Layer menu card to show or 

hide the required layers of the data to be shown on the 

map without removing the same from map. If user is 

using the ‘Plot Records/POI/Directions card’ and has 

plotted Datasource Records, POI locations or Route and 

has proceeded for Territory Management, the plotted 

layers of data will be retained and will be listed in the 

section of ‘Pushpin Layers’ of the Layer menu. The data 

plotted using the Territory Management card will be 

listed in the ‘Territory Management Layers’ section of 

the Layer menu. 

Territory Alignment Tool 

This tool has four options respectively as mentioned below:  

 Select/Deselect: User can select 
regions/shapes/territories one by one on the map 

 Deselect All: User can deselect all the selected 
regions/shapes/territories on the map 

 Select Multiple: This is a freehand selection which helps the user to select multiple 
regions/shapes/territories on the map 

 Delete: User can delete the shapes/regions/geographies plotted on the map  
Note: If the delete option is used on the existing territories, it will delete the selected 
geographies from the existing territories. 
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Create new territory  

User can select some of the regions/shapes using the ‘Alignment Tool’ and right click to create a new 
territory.  User can also select the required manager who will be responsible for the respective territory. 
 

 

 
 

 

Note: Users who have already been assigned as a manager for another territory will not be visible in 

the list of users to be selected as a manager of the territory. 



Maplytics™ – User Manual 

 

Page 78 of 204 

   

 



Maplytics™ – User Manual 

 

Page 79 of 204 

   

Auto Territory creation 

User can create territories automatically based on a shape/excel file and count of records plotted on the 

map to get the desired number of balanced territories. To do this, user can go to Territory Management 

and use the option of ‘By File’ to upload a Shape file or an Excel file to get it plotted on the map. User can 

also choose the option of ‘By Overlay’ to plot a saved shape/excel file on the map. 

Now, user can go to the ‘Plot Records Card’ and select the required ‘DataSource’ and the respective ‘View’ 

to plot the same on the map. These records will be distributed among the territories that are to be created.  
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Using the options of ‘Select’ or ‘Multi-select’ from the ‘Alignment Tool’ user can choose the required 

regions and right click to select the option of ‘Create Territory’ to open the window. Here, user can select 

the option to ‘Create Multiple Territories’ and enter the number of territories they want to create out of 

the selected regions on the map. In the screenshot below, we have entered 4 for an instance.  

 

 

 

This will calculate the number of records and divide the selected regions automatically to get 4 balanced 

territories. By default, territories will be named as Territory_0, Territory_1, Territory_2 and so on. User 

can change the names as per their requirement.  

 

Note: Only those records which lie within the regions selected will be considered while creating 

multiple balanced territories.  

Note: The count of records in the territories created automatically might vary slightly. 
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User can also set the required user as a manager for the territories processed, by clicking on the ‘Select 

manager’ icon. 

 

 

 

Note: Users who have already been assigned as a manager for another territory will not be visible 

in the list of users to be selected as a manager of the territory. 
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User can also set the colors for the territories using the option of ‘Fill color’.  

 

User can further choose to take an action on the territories processed on the map by using ‘Actions’. There 

are three Actions available: 

Create: If the user is satisfied with the territories 

processed, then they can choose this option to create the 

territories processed on the map within the CRM.  

Save: If user needs to work on the territories processed to 

further make any changes or take an opinion on the same 

from a colleague, they can use this option to save the 

territories processed as Draft Territories within the CRM. 

Realign: User can further rework on the territories 

processed using this option. This will allow the user to 

revise the number of territories processed.  

Assign territories to record 

If user chooses to create territories from the 

‘Actions’, then after creating the territories, user 

will be asked if they want to assign the territories 

created to the respective records plotted on the 

map. User can click on ‘Yes’ to do so.  
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Register to Windows Service 

If the number of records is more than 9K, then user needs to register to Windows service in order to create 

multiple territories. With more than 9K records plotted on the map when user tries to create multiple 

territories then the below message will be shown and these records will be processed by Windows Service. 

When the user clicks on ‘Confirm’ then it will create the territory records with the status ‘Process by WS’ 

and Windows Service will process these territories by distributing the records to create the specified 

number of balanced territories based on the number of records.  

 

Windows service runs at the interval that user will set. For example, user can set it for every 1 hour. When 

windows service runs and finds territories with the status ‘Process by WS’ then it will process them one 

by one. It takes one territory and performs the logic and distributes the records properly to create the 

respective number of territories and while updating these territories it changes the status of those 

territories to draft. User can plot this draft territory and create the respective territories into the CRM. 

To install Windows Service, user can go to the ‘Batch processing tool’.  
 

1. To get the tool, Extract the Batch Processing tool .zip file from the extracted Zip folder of 
downloaded Maplytics solution.  
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2. Run the BatchProcessingTool as Administrator as shown below. 

 

 
 

3. Once the user runs the tool, the following window will open where they need to enter the 

credentials and click on ‘Next’. 

 
 

4. Once user clicks on ‘Next’, it validates the credentials and if credentials are valid then the below 

window shows up. Here, user needs to select the option to Install/Uninstall Territory Distribution 

Windows Service and click on ‘Install’. 
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Once clicked on ‘Install’ the ‘Territory Windows Service’ will be installed in the PC as shown below. 

User can click on ‘Uninstall’ to uninstall ‘Territory Windows Service’.  

 

User can start and stop windows service using ‘Start’ and ‘Stop’ button. 

 

To update the windows service run interval, user needs to change “RUNINTRERVAL” in the app 

config of windows service (Inogic.Maplytics.TerritoryDistribution.exe.config). 
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Note: Make sure the PC in which the Windows Service is installed is running all the time because if 

the PC is turned off, the Territory Windows Service will also get turned off and it will not perform 

any task. 
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Draft territories 

If the users need to further work on the territories processed 

or needs to make any changes, they can choose the ‘Save’ 

from the Actions and save the territories processed as a 

‘Draft territories’ within the CRM. 

 

 

 

 

 

 

 

After saving a draft, user can use the option of ‘By Territory’ within the ‘Territory Management’ card to 

plot the draft territories saved in CRM and rework on them. Further, user can choose to save it again as a 

draft with the updates done or create the respective territories in the CRM using the option of ‘Create’ 

from the Actions. If user wants to create the respective territories from the draft, they can also choose 

whether or not to delete the respective draft territory.  
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Create territory on one click 

User can create multiple territories with a single click on ‘Create Territory’ button. User can plot shape 
files or excel files on the map to view the shapes required as geographies and follow the steps mentioned 
below to create territories: 
 

By Shape file 

After plotting a shape file on the map, user can click on the ‘Create Territory’ button to create a new 
territory with the plotted shapes as geographies or create the plotted shapes as geographies into a 
selected existing territory.  
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User can provide the name for the new/existing Territory to be created and select the column from the 
excel file for ‘Select Geography Name’ and the respective names of geographies will be fetched from the 
file.  
 

By excel file 

After plotting an excel file, user can click on the ‘Create Territory’ button to create territories with the 
shapes plotted on the map as Geographies. The names of the territories and the respective Geographies 
will be fetched from the excel file.  
The excel file should in the supported file format as mentioned below.  
Name: Name of the Geography. 
Search Option: Bulk geography feature is available only for the ‘By Region’ option, so this value should 
always be ‘1’. 
Color: Color should be in Hexadecimal format i.e. (#DAF7A6). If the user enters the color in other format 
then the default color (Blue) will be set. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Region 
Type: There are 6 region types that the user can define to create the geography. (Country, State, County, 
City, PostalCode1, PostalCode2). 
Region Value: If the user needs to create the geography based on Postal Code, then they can define the 
postal code values in this column. To define multiple geographies in single territory, use the comma 
separator (,). 
Territory: This is a lookup value to define which geography belongs to which territory. 
Manager: The names of the users can be provided here. While creating territories, the managers for the 
respective territories. However, the column of ‘Manager’ is not mandatory to be in the excel file. 

Note: For Territory management: 

 The column of ‘Territory’ should contain the Names of the territory(ies) 

 Color: Color should be in Hexadecimal format i.e. (#DAF7A6). If the user enters the color in 

other format then the default color (Green) will be set.  

 There are 8 region types that the user can define to create the geography. (Country, State, 
County, City, PostalCode1, PostalCode2, PostalCode3, PostalCode4). 
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Alignment of Existing territories 

 
User can plot the existing territories and align them to get the proper distribution of the regions. User can 

use the following two options to align the territories. 

Move to 

User can select some geography(ies) of one or more territories and move it to another plotted existing  
territory or create a new territory. This will remove the geographies from the original territory.  
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Copy to  

User can select some geography(ies) of one or more territories and copy it to another plotted existing 
territory or create a new territory while keeping the geography in the original territory.  

 

 

Shape Operations in Territory Management 

User can perform Binary operations on the shapes, regions or territories plotted on the map. User can 

select the shapes on which they want to perform operations and right click on them to select the Binary 

operations. There are five Binary options available: Difference, Intersection, Union, Union Aggregate and 

Disjunctive Union. Please refer to the section of the Shape operations to know more about these Binary 

operations.   

 

 

Note:  

 The shapes should overlap each other to be available for performing shapes operations 

 There should be a layer of drawing overlapped with the shapes on which binary operations has 
to be performed 

 The required shapes should be selected before performing Binary operations 
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Defining Geographies for Sales Territory using Maplytics 
 

The users can create sales territories using the native Dynamics CRM ‘Sales Territories’ feature and define 
geographies for the sales territories on a map using Maplytics. 
 
To create geographies for sales territory, go to Settings > Territories and click on ‘New’ to create a sales 
territory. With Maplytics a ‘Geographies’ Entity is added on the territory. User can use this feature to 
visualize and create geographies for the sales territory. To create a new geography, click on ‘Add New 
Geography’. 
 

 
In the section ‘General’, provide a name for the Geography. 

 
Within the section ‘Map preview’, the user has the option to visualize the geography on a map ‘By Region’ 
or “By Drawing’. The ‘By Region’ option lets the user to plot the geography based on region types and the 
user has the freedom to choose the color for the plotted region.  
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The ‘By Drawing’ option lets the user to plot the geography by drawing a shape on the map and the user 
can further edit the shape based on their needs.  

 

Note: User can define multiple geographies for a single territory. 
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Bulk Geographies by uploading an Excel file 
 
The users also have the option to upload multiple 
geographies through an Excel files supported by 
CRM using the Bulk Geographies feature in 
Maplytics. 
 

 
 
To upload the geographies in bulk, the user 
first needs to export an Excel template. Go to 
Settings > Data Management > Imports > 
select the ‘Excel Templates’ and then click on 
the ‘Create Excel Template’ option. 
Select the ‘Excel Template’ and in the ‘Select 
data’ section, select the ‘Geography’ Entity in 
the ‘Filter by entity’ field. 
 
Click on ‘Edit Columns’ and select the below 
columns; 

 
 
 

The excel file should in the supported file format as mentioned below: 
Name: Name of the Geography. 
Search Option: Bulk geography feature is available only for the ‘By Region’ option, so this value should 
always be ‘1’. 
Color: Color should be in Hexadecimal format i.e. (#DAF7A6). If the user enters the color in other format 
then the default color (Blue) will be set. 
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Region Type: There are 6 region types that the user can define to create the geography. (Country, State, 
County, City, PostalCode1, PostalCode2). 
Region Value: If the user needs to create the geography based on Postal Code, then they can define the 
postal code values in this column. To define multiple geographies in single territory, use the comma 
separator (,). 
Territory: This is a lookup value to define which geography belongs to which territory. 
 

 

Note: For Territory management: 

 The column of ‘Territory’ should contain the Names of the territory(ies) 

 Color: Color should be in Hexadecimal format i.e. (#DAF7A6). If the user enters the color in 

other format then the default color (Green) will be set.  

 There are 8 region types that the user can define to create the geography. (Country, State, 
County, City, PostalCode1, PostalCode2, PostalCode3, PostalCode4). 
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Multiple Territories assigned to records 

If a user needs to assign more than one territory to the entity records, user can enable the feature of 

Multiple Territories for a record. This feature will help the user to visualize records which lie in single or 

multiple territories. After assigning the territories, they can plot the territories to visualize the respective 

records lying into them.  

To start using the feature of Multiple Territories for a record, user can follow the steps mentioned below: 

Step 1: Enable Multiple Territories 

Go to Settings > Maplytics > Maplytics Configuration Details > Default configuration detail record > 

Configuration option > Select ‘Enable Multiple Territories’. 

 

Step 2: Creating N: N relationship of entity with Territory. 

Go to Settings > Customizations > Customize the System > Entities > Select Entity > N: N Relationships > 

New Many-to-Many Relationship 

Step 3: View the list of territories assigned to a record 

User can add a sub-grid to show the territories that an 

entity record is associated with. This step is optional, 

even if a sub grid is not added, the assigned territories 

will get associated with the records in background. 

 

 

  

Step 4: Select relationship for the field ‘Territory Relationship’ in Attribute mapping section of Entity 

map. 

Go to Settings > Maplytics > Entity maps > Attribute mappings > Territory Relationship > Select ‘Entity - 

Territory’ relationship   

 

 

 

Note: User cannot undo this option, once selected and saved. 
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Step 5: Assign territories to records 

User can either run Batch Processing tool or the Inogic.Maplytics.AssignTerritoryWorkflow on the 

records to assign the territories to the records.  

After assigning the territories, user can choose the Search option of ‘By territory’ to plot the territories 

along with the respective records. The below screenshot shows two territories plotted on the map, 36120, 

Montgomery, AL and Montgomery, AL which overlap on each other and have three pushpins in common.  
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Detail Map on CRM Dashboard 

To include the Maplytics Detail Map component on the Dashboard, click on the ‘new’ button and select 
‘Add Web Resource’. Select ‘ikl_/Maplytics/Maplytics.DetailMap.html’ web resource. The User can 
further modify this web resource by including some custom parameter. For Example, if the user wants to 
plot a route from a dashboard like Appointment Planner. The user can automate the complete process.   

 
 
Custom Parameter(data) : You need to provide the Custom Parameter(data) as  

 <Dashboard Name>||dashboard||true 

 Appointment Planner||dashboard||true 
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Saved Template Visualization on CRM Entity Form 

Users can include the Maplytics Detail Map component that loads a saved template associated with the 
Entity record on the Entity Form. For this, the user needs to create a ‘Template’ lookup field on the Entity 
form where user can select the required Maplytics Template. The user also needs to select the name of 
that field in the ‘Template’ field under ‘Define Attributes’ section on the Entity Map for that particular 
entity. 

 
On the Entity form, the user needs to ‘Insert’ a new Tab and select ‘Add Web Resource’. Select 
‘ikl_/Maplytics/Maplytics.DetailMap.html’ web resource. The user now needs to add a Custom 
Parameter for the saved templates.  

 Custom Parameter (data): Provide the Custom Parameter(data) as savetemplate  
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Now, when the user selects a Maplytics Saved Template on the ‘Template’ lookup field on the Entity form, 
the selected template will be plotted on the Detail Map component added on the Entity form.  
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Routing Optimization  
 

User can select some locations on the map as waypoints to plot an optimized route. User can follow this 
route to visit the required locations and complete their meetings. User can also redirect themselves for 
turn-by-turn navigation in order to reach the right location on time.  
 

Directions Card 

Directions card provides the user with all the routing features. 
The user can open the Directions Card directly by clicking on 
Directions tab.  
 
The Directions Card also opens up when the user adds a 
waypoint(s) to the route either through the Contextual Menu, 
ToolTip Card or using the ‘Add to Route’ mass action. User can 
select the required waypoints and the leaving/arriving time.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: The user can add a maximum of 25 waypoints in 

the direction functions. 
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Once the waypoints are selected, the user can choose the 
mode of transports like Driving, Walking, Transit or Truck 
to view the route.  
The user can select different options to reduce the time, 
toll, highways, etc. by clicking on the Options button. Some 
of these can be auto-selected using Maplytics 
Configuration Settings.  
The user can drag and drop the waypoints to change the 
order of route.  

Truck Route 

To start using Truck route, please contact crm@inogic.com. Once the user has contacted us at 
crm@inogic.com for the truck route, the user will be provided with a Maplytics license with Truck routing 
enabled into it.  
To start using Truck route, user needs to update the license and then configure as mentioned below:  
 
Update the license: Go to Maplytics App > Settings > License registration > Click on Activate. 
Configure: Go to Maplytics App > Settings > License registration > Configure Tab > Configure. Here the 
Asset data will be configured to the users Dynamics CRM. 

 

Note: To start using Truck route, please contact 

crm@inogic.com 

mailto:crm@inogic.com
mailto:crm@inogic.com
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Assets data configuration will create some sample records for Trucks which user can select while using 
the feature of Truck routing. User can click on the ‘New’ button to create new records of Assets. They can 
also edit and save changes to the configured Assets.   

 
After the sample records for trucks have been configured, user can enable the truck routing. To enable 
truck routing, go to Maplytics App > Settings > Maplytics Configuration Details > Default Configuration 
Detail record (with no user) > Advanced Settings > Enable Truck Route.  

 



Maplytics™ – User Manual 

 

Page 104 of 204 

   

User can choose the truck icon on the Direction card to plot 
the route for a truck. On the selection of the truck icon a 
window will pop up to enter the Asset details.  
Within the Asset Details, user can either select one of the 
sample truck types or select the custom option to enter their 
own details and then click on ‘Go’ to plot the route.  
 
 

The Asset Details will be as follows:  
 

1. Asset type: The asset for which the route has to be 
plotted. It can be selected from the following list 
of configured sample records. User can also select 
‘custom’ to enter their own details.  
• Trailer 1 
• Trailer 2 
• Trailer 3 
• Trailer 4 
• Trailer 5 
• Trailer 6 
• Custom 

2. Axles: The number of axles. 
3. Dimension Unit: The unit of measurement of 

width, height, length. Can be one of the following 
values:  

 Meter  

 Feet 
4. Height: The height of the vehicle in the specified dimension units. 
5. Length: The length of the vehicle in the specified dimension units. 
6. Width: The width of the vehicle in the specified dimension units.  
7. Weight Unit: The unit of measurement of weight. Can be one of the following values. 
8. Weight: The weight of the vehicle in the specified weight units. 
9. Hazardous Materials: List of one or more hazardous materials for which the vehicle is 

transporting. Possible values are: 

• Combustible   
• Corrosive   
• Explosive   
• Flammable   
• Flammable Solid   
• Gas   
• Goods Harmful to Water   
• Organic   

Note: Optimization of the route with the Shortest 

Distance will not be available when Truck is selected as 

the mode of transport. 
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• Other 
• Poison   

 Poisonous Inhalation   
• Radioactive  
• None 

 
 

Optimize Direction 
 

This can be selected from the Options. This option will 
provide the users with the optimized route direction 
between their waypoints keeping Origin & Destination 
as fixed waypoints.  
 
 
 
 
 

Once the user clicks on ‘Go’ the route will be plotted and the directions will be available on the Directions 
Card.  

 
User can view all the details regarding the pushpins on the route in the view data grid in the tab named 
as entity_Route. for example: Contact_Route. Each waypoint on the route will be represented by a 
pushpin. User can hover or click on any pushpin to view the details of the waypoint. If the waypoints are 
records saved within Dynamics CRM, it will open the tooltip card on its click showing the respective data 
configured for tooltip card.  
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If the waypoint is just a location, on a click it will 
open a tooltip card showing its address and an icon 
which can be used to create a record for the 
location. This includes the Default origin and 
destination pushpin as well.  
 
 
 
 
 
 
 

 
User can also choose to show or hide the layer of 
route from the layer card.  
 
 
 

Route Sharing: 
 

Maplytics also helps the user to share a route in 
different ways.  
 

Email Route:  
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The user can email the route to any of the Dynamics CRM records using email route option. 
 

Save Route: 
 

Users can also save their route plotted. The route record will 
also save the information like number of waypoints, total 
distance and time for the route. User can add the route to 
an existing route or save the route with a name & owner as 
a new route.  

 
 
User can also update any route directly using the update 
button. User can search for route existing in the required 
duration and click on the update button besides the 
required route.  
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Clear Route: 
 
The user can use the Clear Route button to clear 
the route from the map. This will just clear the 
route and directions card will still be opened for 
further use. 
 
 
 
 
Another important feature of Maplytics is Routing across multiple waypoints. All the routing features in 
Maplytics can be accessed from the Directions Card. 
 

Merged Route and Plot View 

Now, when the user plots the data and then creates a route, both the plotted data and the route will stay 
on the map for an easy Route Management. This makes it easy for the user to add more waypoints to the 
route without switching between Plot and Directions card. 

 

 
 
 
 
 

Note: The route will remain on the map unless the user clicks on the ‘Clear Route’ button or closes the 

Directions Card 
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Default Origin and Destination 

User can set default origin and destination for Route management.  
Go to Settings > Maplytics > Maplytics Configuration Details > Record of the user 

 
There are six options to select: 

 User Mailing Address - Reads address from User mailing address 

 User Other Address - Reads address from User other address 

 Business unit Bill to Address - Reads address from logged in user’s Business units bill to address 

 Business unit Ship to Address - Reads address from logged in user’s Business units ship to address 

 None - If user do not want to set default origin/destination 

 Other : It will have its own multiline textbox associated where user can enter their own address 
 

 
 
 
 
 
 
 
 
 
 

Note: If a user uses the “Plot route” button to plot a “Route” activity record on the  

Detail map, the Default origin/destination will not be set in the Direction card 
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Snap waypoint 

This helps the user to edit a plotted route just by dragging the route to the required point on the map. 
 

 
 
Drag to a location: User can drag a point on the route to a required location on the map. This will add the 
location as a waypoint at the dragged point in the route. This will also update the Directions card with the 
newly added waypoint. 
  
Drag to a pushpin: User can also drag a point on the route to a pushpin plotted on the map. This will 

detect the record and add the record’s location at the dragged point in the route. This will also update 

the Directions card with the newly added waypoint. 

 
Note: The option of snapping waypoints is not available for a route create for trucks. 
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Along the Route 

This feature provides the user the ability to search the records 
that fall in the defined proximity along the route. The default 
value for Along the Route search can be configured in the 
Maplytics Configuration record. This will find all the records 
with the defined search parameter and that falls in the entered 
proximity along the route. 
 
 
 

 
 
 
 

Note: The user can add the value between 0 – 25. The user can also add decimal values with a scale of 

2 for the radius. 
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The Along the route records is also saved when the user saves the route. However, if the user has selected 
multiple Datasources on the Plot Card, only the first Entity and View combination in the Select Datasource 
will be saved for along the route search in the saved route. 
 
If the user has plotted data on the map and opens a saved route 
that has along the route parameter saved as well: 

 The user can either click on ‘Confirm’ to clear the plotted 
records and search along the route records with the 
Datasource saved in the route. 

 Or, the user can click on ‘Cancel’ to search along the route 
records with the existing plotted data, ignoring the 
Datasource saved in the route. 

 
 
If the user opens the Directions card directly without plotting the 
data or opens a saved route without the along the route parameter 
saved, they have the option to select the Datasource for the Along 
the route search directly on the Directions Card.  
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Route Redirect and Copy Route Links 

After plotting the route, user can use the ‘Redirect’ button 
to open the ‘Navigation Links’ popup on the browser as well 
as the Dynamics 365 App for Phones and Tablets.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
The user can click on individual links for route navigation from point A – B, B – C, and so on. User can also 
select the application within the User Configuration record to navigate the route. Refer the section of 
‘Maplytics Configuration Details (Personalization)’ in the installation manual to select the application. 
These links will redirect the route to the app selected in the configuration.  
 

Redirect with Google Maps 

User can view the turn-by-turn navigations on Google Maps site on desktop and Google Maps App on 
Phones and Tablets. User can also choose to view the complete route.  
 
 
 
 
 

Note:  

 The maximum waypoints to show the complete route is 10 waypoints. 

 By Default, the navigation will be redirected to Google Maps. 
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Redirect with Waze 

User can view the turn-by-turn navigations on Waze site on desktop 
and Waze App on Phones and Tablets. This will show the navigation 
links from current location to the waypoints. 
 
 
 
 
 
 
 
 
 
 
 
 
Redirection on mobiles: User can click on the route navigation 
buttons to redirect on the Google maps/Waze. 
The user can also use the ‘Copy Links’ button to copy the links to 
send them as an email or save it into a note.  
 

 
 

Note: 

 By default, the links will be redirected in Google 
Maps. 

 The links redirect on the Dynamics 365 App for 
Phones and Tablet works with Dynamics 365 v9.x  

 For other devices and Dynamics 365 v8.2, users can 
use the ‘Copy Links’ button. 

Note: The checkpoints should be under 3000 miles from the 

current location to view routes on Waze. 
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Print Route 

User can print a Route as well as the adjoining Map. 
User can plot a route on map, click on the ‘More 
Options’ button to click on ‘Print Route’ button.  

 
Clicking on the ‘Print Route’ button will open a new window with the map and Route on the page, which 
can be seen in the below screenshot: 
Click on the Print Icon to print the map and route instructions.  

 
 
 

Note: 

 Routing requires a minimum of two waypoints provided to create a route. 

 A4 size paper with landscape mode is recommended while printing. 
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Download map 

Using the Download map button, the user can download the map as visible on the screen. 

 
 
 

 
 
 

Note: Download map is not supported for Internet Explorer. 
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Auto Scheduling 
 

Auto Scheduling helps users to create an optimized schedule to be followed on the field over a span of 
days by the concerned field professionals. The user can perform Auto scheduling on the required set of 
records (eg. clients) to create Appointments and optimized routes, with the considerations of existing 
appointments, the preferred days of working, different meeting durations, availability of the selected 
users etc. This feature will help user to create appointments and optimized routes based on shortest time 
in order to provide an effective plan, hence saving the time and increasing the field productivity. 
 

Users can contact at crm@inogic.com to get the access of the feature and they will be provided with a 
Maplytics license with Auto Scheduling enabled into it.  
 

 
 
To perform Auto Scheduling user can go to the Mass Actions within the View Data grid. They can plot the 
Entity records on the map that are needed to be visited and open the ‘view data’ grid at the bottom to 
check the number of records plotted on the map and deselect the records that are not required. 
 

 

 
After plotting the required records to be scheduled for, user can Go to Mass actions > Auto scheduling. 
This will consider all the records that are plotted on the map and will proceed to the Auto Scheduling 
page.  
 
 
 
 
 

Note: The visibility of the option of ‘Auto scheduling’ into Mass Actions will be based on the 

Maplytics Security Template if any assigned to the user. Please refer to the section of ‘Maplytics 

Security Template’. 

Note: Auto Scheduling can be performed on a maximum of 100 records plotted on the map  

mailto:crm@inogic.com
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Auto scheduling card 
 

User can set the basic preferences as per the requirement so as to consider the same while creating a 
schedule. Users can also have these prefilled by setting default values for the preferences within their 
Configuration Detail Record. Please refer ‘Configuration Detail Record’ section Installation Manual to see 
configuration for Auto Scheduling. 

 
Consider Existing meetings: Select this option to consider 
existing meetings saved in CRM assigned to the selected 
users. 
 
Select users: Select the Maplytics user(s) to create 
Automated schedule for them. A maximum of 10 users can 
be selected to create an automated schedule. 
 
Period: The number of days the schedule should be for. The 
meetings will be distributed among the number of days 
selected here. User can choose any one option from the 
following:  
 

 1 Day 

 2 Days 

 3 Days 

 4 Days 

 5 Days 

 1 Week  

 2 Weeks 

 3 Weeks 

 1 Month 
 

Duration: The time frame required for each meeting. User 
can choose any one of the following options. User can also 
change duration for individual meetings in Advanced 
Preferences. User can further change the duration of 
individual meetings in the ‘Advanced Preferences’. 

 5 Minutes 

 10 Minutes 

 15 Minutes 

 20 Minutes 

 30 Minutes 

 45 Minutes 

 60 Minutes 

 75 Minutes 

 90 Minutes 

 120 Minutes 
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Start Time: Time to start the schedule of each day. User can enter the time in 12-hour format (hh:mm)  
 
End Time: Time to end the schedule of each day. User can enter the time in 12-hour format (hh:mm)  

Break Time: Starting time of Break for each day. User can enter the time in 12-hour format (hh:mm)  

Break Duration: Duration of the break during each day. User can select any one of the following options:  

 0 Minutes 

 5 Minutes 

 10 Minutes 

 15 Minutes 

 20 Minutes 

 30 Minutes 

 45 Minutes 

 60 Minutes 

 75 Minutes 

 90 Minutes 

 120 Minutes 
 
Buffer time: User can add extra time to the schedule as buffer to be used in case of unforeseen situations 
to avoid changing the schedule. 

 5 Minutes 

 10 Minutes 

 15 Minutes 

 20 Minutes 

 30 Minutes 
 
Working days: User can select the days for which the selected users will be working. The meetings will be 
distributed only within the working days selected here. User can select any day between Sunday, Monday, 
Tuesday, Wednesday, Thursday, Friday, and Saturday. At least one day should be selected.  
 

 

Note:  

 If the logged-in user has set default values for the preferences in the respective Maplytics 
Configuration detail record, while opening the Auto scheduling section, the preferences will 
get prefilled with the same.  

 If the logged-in user selects any other single user, the preferences will get prefilled if there 
are default values set in the Maplytics Configuration detail record of the respective selected 
user.  

 If the logged-in user selects multiple users, the preferences will get prefilled if there are 
default values set in the Default Configuration detail record. 
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Advanced Preferences 

User can further click on ‘Advanced preferences’ within 
the Auto Scheduling card to select further preferences to 
be considered while creating an automated schedule.  
 
 
 
 
 
 

 
 
Meetings Per Day: User can select the average meetings that should be scheduled for a day. A minimum 
of 1 and a maximum of 20 meetings can be selected.   
 
Continuous Schedule: Instead of starting the route from the origin every day, if the route should be started 
on the ending location of the previous day, user can set it as ‘Yes’. For example: A user starts the first day 
from Brookwood in Alabama, USA to follow the route assigned and reaches Alexander city, Alabama which 
is the destination of the route for the day. Now, if the ‘Continuous Schedule’ is enabled, the user does not 
need to go all the way to Brookwood to start the route for the next day, instead the user can directly go 
to the first appointment scheduled for the second day, from Alexander City itself. 
 
Reschedule Existing Meetings: If the option of ‘Consider Existing Meetings’ has been selected within the 
Auto scheduling card, then the option of enabling ‘Reschedule Existing Meetings’ will be available. User 
can select ‘Yes’ in order to reschedule existing meetings. This might change the respective owners as well 
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to get the highest optimization. If the existing meetings are needed to be met at the set appointment 
time, the user should select ‘No’.  
 

 
 

User Details  

Selected users will be listed here along with the space 

provided for the Origin and Destination locations for 

the same. If the default locations for Origin and 

Destination are set in the default configuration details 

of the users, the same will be prefilled here. If not, 

then user can click on ‘Edit’ and enter the required 

locations for Origin and Destination for the respective 

users. Location for Origin will be mandatory here.  

 

User can also uncheck any users in this list if they do not want to create an automated schedule for any 

user.  

 

Note: If both Onsite and Offsite existing meetings have been considered, then, enabling reschedule 
existing meetings will make changes only to the Onsite meetings. 
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Meeting Details 

The details of the records selected to create the schedule will be listed here. Users can also deselect any 
record if they do not want to add the record to be considered while creating the schedule.  

 
User can also click on the individual duration of meetings to change it for the respective meetings as well 
as enter a value in the blank space to filter the data based on the entered value. In the below screenshots 
the data has been filtered by meetings with the duration of 40 minutes and city Montgomery. User can 
filter the data for with the values for other columns as well. 
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Existing meetings 

If user has selected ‘Consider Existing Meetings’ in the Auto Scheduling card, the Appointments, Bookable 

resource bookings etc. saved in CRM owned by the selected users will be listed here. User can also change 

the Meeting type of Onsite meetings to Offsite. They can further deselect the listed meetings or Activities 

they do not want to consider and also filter the meetings based on specified values. User can choose one 

among the options under ‘Select Meeting’, i.e. All Meetings, Appointments, Service activities or Bookable 

resource bookings to view the same in the list below that. Admins can also select the Activities within the 

Default Configuration Detail records that are needed to be considered here while Considering Existing 

Meetings.  

 

User can click on ‘Proceed’ to get the optimized routes and appointments scheduled for the respective 
users based on the preferences provided by the user for the selected working days. Routes for each user 
will be shown on the map with different colors. User can select the required users in the card to view the 
route for the respective user. 
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It will show the route for the selected user and the respective details of the meetings will also be available 
into the data grid below. 
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 Transition bar 

User can use the transition bar to view the route planned for the 

selected user for different days. User can either click on the arrow 

buttons to go to the previous or next day’s plan or they can also 

select the date in the Calender to go directly to the date required. 
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Create Activities 

User can save the schedule as Routes and Activities in the 

Dynamics 365 using ‘Create activities’ button. The user can 

create the following activities:   

 Appointments 

 Service Activities 

 Bookable Resource Bookings 
 
User can also select the option of ‘Create Route(s)’ in order to save the planned routes into ‘Route’ Activity 
Entity.  
 

 
 
Go to Detail Map: Using this button, user can go back to 
the Detail map 
 

Note: To make the option of Bookable resource booking visible, user needs to enable the OOB or any 
custom entity to create the bookable resource bookings.  
 

Note: All the scheduled data will be cleared, if ‘Go to Detail Map’ button will be used. To save the 

schedule created, user can use the option of ‘Create activities’.   
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Configuration Details for Auto Scheduling 
 

System admin and Maplytics admin can set the default settings for Auto Scheduling in the Default 
Maplytics Configuration Detail record. They can also set the start time as the default start time for the 
first activity as well as default values for other preferences for Auto Scheduling. 

 
Go to Maplytics App > Settings > Maplytics Configuration Details > Default Configuration details record 
for the user > Auto Scheduling 
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Admins can also select the Activities that are needed to be considered while Considering Existing Meetings 

in Auto Scheduling. If no Activities are selected here Auto Scheduling will consider all the Activities while 

Considering Existing Meetings. If Admins have selected Activities here then only selected activities will be 

considered while Considering Existing Meetings in Auto Scheduling.   
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Users can also set the default settings for Auto Scheduling in their respective Maplytics Configuration 
Detail record.  
Go to Maplytics App > Settings > Maplytics Configuration Details > Configuration details record for the 
user > Auto Scheduling 
  

 

Note: Create Activities for Custom Entity: 
 A custom entity should be linked to any OOB Entity into Entity Maps in order to Create 

Activities for the Entity 
 If a custom entity has its own address, the option to create Appointment and Service Activity 

will not be available. The user can only create activity of Bookable Resource Bookings  
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Check-In/Check-Out 
 
Check-In feature enables users to register their arrival and departure time for the Check Points while 
navigating on field with the help of Check-In and Check-Out buttons. These buttons will help to tag the 
geo-coordinates of the location while a user is visiting a meeting. This will also help the management to 
track the activities of the field professionals as well as the time they have spent on every meeting.  

Configuration 

To get started with the feature of Check-In, the first step is to configure Maplytics. Configuration will 

create the Entity Map for the Check-In entity. Please refer to the section of ‘Configure’ under the ‘Initial 

Setup - Maplytics License Activation, Configuration for Entity Map, Dashboards and Census data’ within 

the Installation manual.  

This feature can be enabled for any OOB or custom entity within their respective Entity Maps. To enable 
this, System Admin/Maplytics Admin can follow the steps mentioned below. The following screenshot 
shows the entity map of Appointment for an instance.  
 
Go to Settings > Maplytics > Entity Maps > Open Required Entity Maps Record > General Tab > Enable 
Check-In > Set the value to ‘Yes’ & click on ‘Save’. 

 
 

View Related Check-In/Check-Out records 

User can choose to view the related Check-In/Check-Out records for the plotted records (Appointments, 
Accounts, etc.) using the feature of ‘Plot Related Records’. To plot related Check-In/Check-Out records, 
user needs to select the relationship. To select the relationships, user can follow the steps mentioned 
below. We have provided the steps for Appointments for an instance.  

Note:   

 The default value for ‘Enable Check-In’ is set to ‘No’. 

 User cannot undo this option, once selected and saved.  

 After enabling this feature, please wait for a while before using this. 
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Go to Settings > Entity Maps > Required Entity Maps record > Configuration > Related Records 
Configuration > Relationship List > Select appointment - ikl_checkinentity  
 
User can also refer to the section of ‘Related Record Configuration’ under the Entity Maps within the 
Installation manual for the same.  

 

Check-Out 

After enabling the feature, user can also enable the option of ‘Check-Out’. This way the user can first click 

on the Check-In button while visiting the meeting and then can click on the Check-Out button while 

completing the meeting. Here, the geo-coordinates for both the locations will be saved which will also 

help the management to track the time spent on the meetings.  

In order to enable Check- Out, System 

Admin/Maplytics Admin can follow the steps 

mentioned below:  

Go to Settings > Maplytics Configuration Details > 

Default Configuration Detail Record (the one with 

no user name) > Check-In tab > Set the value for 

Enable Check-Out to ‘Yes’ & click on ‘Save’. 

Note:  User needs to select the respective Relationship with Check-in for every entity within their 
respective entity maps for which they want to see the related Check-In/Check-Out records. 
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Default Radius 

It is the distance that the System admin/Maplytics admin can set to consider the accuracy of the Check-
In/Check-Out records created by the field professionals. If the Check-In/Check-Out record do not lie within 
this radius then it will be considered as invalid record and will be shown with a pushpin with this Red 

Cross. For example:  

 

Note:   

 The default value for ‘Enable Check-Out’ is set to ‘No’.  

 User can anytime disable this option.  

 Check-Out option can only be enabled for entities for which the feature of Check-In has been 
enabled.   

 Check-Out can be enabled/disabled only at Organization level. 

 Check-Out button will only be available for the records for which the user has checked-in.  

Note:  By default, Geofence radius is 0.20 kilometers or miles depending on the unit set in User 
Configuration Detail record. 
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Geofencing 

Geofencing is creating a virtual geographical boundary of a specified Geofence radius around a record. If 
Geofencing is enabled, user needs to be within this radius to successfully Check-In/Check-Out for a record. 
If the user is not within this radius, the user will not be able to Check-In/Check-Out and will be shown a 
message specifying that they need to be within ‘n’ Km/Mi of distance from the Check-In/Check-Out 
location. This will help the management to have only valid Check-In and Check-Out records done by the 
field professionals. 
 
In order to enable Geofencing, System Admin/Maplytics Admin can follow the steps mentioned below: 
 
Go to Settings > Maplytics Configuration Details > Default Configuration Detail Record > Check-In tab > 
Geofencing > Set the value for Geofencing as ‘Yes’  

 
 

Geofence Radius 

After enabling Geofencing, System Admin/Maplytics Admin can set the default value for Geofence radius, 
which will be considered while a user Checks-In, or Checks-Out.  

 

 

Note:   

 By default, Geofencing is disabled in which case the user can Check-In/Check-out from any 
location. 

 By default, Geofence radius is 0.20 kilometers or miles depending on the unit set in User 
configuration Details record. 

 



Maplytics™ – User Manual 

 

Page 134 of 204 

   

Creating Check-In/Check-Out records 

 
While navigating on field user can Check-In and Check-Out against any record. This can be done in the 
following two ways: 
 

 From Record Form: User can open the required record (Appointments, Accounts etc.) and click on 
Check-In/Check-Out button on the ribbon. 
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Note:   

 User needs to allow to read the GPS location of the device in order to Check-In/Check-Out. 

 The Check-Out button will be available in the place of Check-In button after the user 
Checks-In. 
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 Through Detail Map: User can click on any plotted records (Appointments, Accounts etc.) to open 

the Tooltip Card and click on the Check-In/Check-Out button. 
 

 
 

Visualize Check-In/Check-Out records on Detail Map 

To analyze the activities of field professionals, Check-In/Check-Out records can be plotted on the map 

like other entity with the help of the Plot Card. User can select ‘Check-In’ as the Datasource and select a 

required view to visualize the records from that view.  

 

Note: Multiple Check-In/Check-Out records can be created for any record (Appointments, Accounts, etc.) 
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Analyze Check-In/Check-Out records 

After plotting the records for Check-In and Check-Out, user can analyze the pushpins by distinguishing 
between the following two kinds of pushpins: 

 Valid Check-In/Check-Out: When a user Checks-In/Checks-Out within the Default Radius or 

Geofence Radius, it is a valid record and will be represented by pushpin. 

 Invalid Check-In/Check-Out: When a user Checks-In/Checks-Out outside the Default Radius it is 

represented by pushpin. 
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Visualizing Related Records  

 
After plotting the records for Check-in, user can also choose to view the records(Appointments, Accounts 
etc.) against which the plotted check-ins and check-outs were created.  
 

Visualizing Related Record (Appointments/Accounts, etc.) for Check-In/Check-Out records 

After selecting the relationship, user can choose to view the related record for any Check-in and Check-
Out record plotted on the map.  

 
The related record can be visualized in the following two ways: 

 By Contextual Menu: User can right click on any Check-In/Check-Out pushpin to open the 

‘Contextual menu’ and click on ‘Show Related Record’. This will plot the related record for the 

selected pushpin. To hide the related record, user can again right click on the same Check-

In/Check-Out pushpin to open ‘Contextual Menu’ and click on ‘Hide Related Record’. 

 



Maplytics™ – User Manual 

 

Page 139 of 204 

   

 By Tooltip Card: User can click on the Check-In/Check-Out pushpin to open the Tooltip Card and 
click on ‘Show Related Record’ from the ‘Tooltip Card Actions’. To hide the related record, user 
can again click on same Check-In/Check-Out pushpin to open the Tooltip Card and click on ‘Hide 
Related Record’. 
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Visualizing related Check-in/Check-Out records for plotted records (Appointments, Accounts, 

etc.) 

After selecting the relationship for the required entity within the entity map as suggested above, user can 
click on any plotted record to open the Tooltip card and click on ‘Plot related record’ to plot the related 
Check-In/Check-Out records. 
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PowerApps Component Framework  
 
User can add custom controls on fields or grids within Dynamics CRM. These custom controls will help the 
user to view the respective records on the map on the record form or the entity grid without switching to 
any other screen. This will enhance the user experience while working with views and individual records. 
User can add the following custom controls: 

Map View Control for Record  

User can add this control on any of the field with the Data type ‘Single Line of Text’ of the record to view 

the respective record plotted on the map. User can further view the Address and geo-coordinates on the 

hover of the pushpin.  

 

Steps to Add control: To add the control to a field within a record form, user can follow the steps 

mentioned below:  

1. Go to Settings > Advanced Settings > Customizations > Customize the System > Components > 

Entities > Required Entity  

Here, we have taken the Lead entity for an instance. Within Leads, go to Forms > Main Form > Select 

a field > Change Properties  

 

 

 

 

Note: The data type of the field on which user needs to add control should be ‘Single Line of Text’. 
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2. Go to Controls > Add Control > Select Map View Control for Record > Add 

 

 

 

 

 

 

 

 

 

 

Note: Please uncheck the option of ‘Display label’ within the field properties for better visualization. 
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3. User can choose to allow the control on Web, Phone or Tablet. Click on ‘OK’ > Save & Publish.  

4. User can open any record of the entity to view this control added on the field.  
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Map Edit Control for Record 

User can add this control on any of the field with the Data type ‘Single Line of Text’ of the record to view 

the respective record plotted on the map. User can hover on the pushpin to see the coordinates as well 

as the address of the pushpin. User can further drag the pushpin around and drop it on the required 

location to update the new Address and the geo-coordinates for the record. User can also type in the 

address in the space provided and click on the update button to update the Address and the geo-

coordinates for the record. Before updating this, the user will be shown a message where user can also 

choose if they want to save address and the geo coordinates or only the geo coordinates.  

Steps to Add control: To add the control to a field within a record form, user can follow the steps 

mentioned above while selecting ‘Map Edit Control for Record’ in the Step2.  After adding the control user 

can open any record of the entity to view this control added on the field.  
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Map View Control for Dataset  

User can add this control to any entity to visualize all of the records of the view or sub-grid on a map. User 

can further hover on the pushpins to view the information regarding the records. The information on the 

hover of the records is customizable. To add more information on hover, please refer to the section of 

Advanced Settings within the Entity maps in the Installation manual. User can also click on the pushpins 

to highlight them. Highlighting multiple pushpins can help the users to perform various actions from the 

ribbon on all the highlighted records at once. User can also right click on any pushpin to open the 

respective record.  

 

Steps to Add control: To add this control on an entity grid, user can follow the steps mentioned below:  

1. Go to Settings > Advanced Settings > Customizations > Customize the System > Components > 

Entities > Required Entity  

Here, we have taken the Contact entity for an instance. Within Contacts, go to Controls > Add Control 

> Select Map View Control for Dataset > Add 
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2. User can choose to allow the control on Web, Phone or Tablet. Click on Save > Publish.  

 

3. User can open any view of the entity to view this control.  
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Detail Map Control for Dataset 

User can add this control to any entity or dashboard to visualize all of the records of the view, sub-grid or 

dashboard on a map. User can also click on the pushpins to highlight them. Highlighting multiple pushpins 

can help the users to perform various actions from the ribbon on all the highlighted records at once. Detail 

Map Control provides the user with the freedom of using Maplytics features right from the page without 

switching to any other screens. User can perform the following Maplytics features.  

 Plot entity records – User will be able to view all entity records for that view on the map. They can 

hover on the pushpins to view the details regarding the pushpin and click on the pushpin to open 

the tooltip card for the pushpin. User can use right-click to open the contextual menu to open the 

record, set the respective location as current location, POI location, the origin for the route, a 

waypoint or the destination for the route.  

 Plot categorized data- User can also select an attribute under the option of ‘Select category’ to 

categorize the plotted data based on the selected attribute.   

 Proximity search – User can set any location as the current location from the tooltip card or 

contextual menu with a right-click on any location on map. Once the user sets the current location, 

they can perform Concentric Proximity Search and can look for the Line-of-Sight Distance on the 

hover or the tooltip card for any record plotted.  

 POI locations – User can set any location as the POI location from the tooltip card or contextual 

menu with a right-click on any location. Once the user sets the POI location, they can use the POI 

card and view any geo-tagged Bing mapped locations by clicking on the icons available or entering 

the keyword for the required location. For example: Dentist.  

 Route – User can set any location as the origin, destination or a waypoint from the tooltip card or 

contextual menu by right clicking on a record or anywhere on the map and get the route created 

for the waypoints selected. User will get further options like selecting the unit for the distance, 

avoiding highways etc. within the direction card. User can also use the turn-by-turn navigation 

directions given within the direction card to navigate themselves for the route.  

 Map mode and labels- Two map modes are available viz. Road and Aerial view. User can also 

select to view the labels of regions on the map. 

 
Adding control: To add this control on an entity grid, user can follow the steps mentioned below:  

4. Go to Settings > Advanced Settings > Customizations > Customize the System > Components > 

Entities > Required Entity  

Here, we have taken the Contact entity for an instance. Within Contacts, go to Controls > Add Control 

> Select Detail Map Control for Dataset > Add 

 

Note: There are some limitations to some of the features mentioned above which will be available in 
our future releases. 
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5. User can choose to allow the control on Web, Phone or Tablet. Click on Save > Publish.  
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6. User can open any view of the entity to view this control.  
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Heat Map 
 
Clicking on the Heat Map command button will bring up the Heat Map Screen.  

  
Select Datasource: 
This option helps the user to choose the Entity and view combination to analyze the data. 
 

Select Measure: 
This helps the user to define the aggregation method to be used to color code the region. By default, it is 
based on number of records (i.e. ‘By Count’). The user can change this to any other field attribute from 
the drop-down. Dropdown contains the list of all numeric and currency fields.  
 

Select Category: 
This option helps the user to filter data. The user can modify the search result using selection in the 
Category option.  
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Select Region Type: 
 

This option helps the user to define the geography level for aggregation. The user can choose any option 
from the drop-down:  

 City 
 State 
 County 
 Country 
 PostalCode: The smallest postcode category, such as a zip code. 
 PostCode Sector: The second ‘1’ is called “Postcode Sector”. Example: CA1 1 
 PostCode(Outward Code): This is called Outward Code, the part of the postcode before the single 

space in the middle. Example: CA1 
 PostalCode Areas: The next largest postcode category after Postcode1 that is created by 

aggregating Postcode1 areas. 
 Territory: This option will use the Sales Territory defined in Dynamics CRM.  

 

 
 

The default option is to summarize the addresses by City. You can find the default settings on the 
Maplytics Configuration record for the individual user as shown below: 

 

Note:  

 The regions that were plotted using the option Post code Areas before will now be plotted by 
using the option of Post code sector.   

 The regions will be plotted as per the Bing maps.  

https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fen.wikipedia.org%2Fwiki%2FPostcodes_in_the_United_Kingdom%23Overview&data=02%7C01%7Cv-szczup%40microsoft.com%7C65818020a8fc4120be9108d618ac626f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636723526031148736&sdata=uIf6X6f4o349Rg6LSBtVlpIXeqzCk4kDyXjSZjRzWbE%3D&reserved=0
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Select Display 

There are four options available to analyze data on Heat Map. Default Heat map display can be selected 
using Maplytics Configuration Settings.  

Boundary 

This will create Heat Map on basis of selected region type like City, Postal Code, Country, State, Territory, 
etc. 

 
No Boundary 

This option does not consider the region type. It simply creates a Heat Map by the density of the measure 
selected without geographical boundaries.  
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Pie chart 

Users can view the data in the form of Pie charts based on the heat of the attribute selected in the 
Measure and Filter.  Pie charts help the users to analyze the data on the basis of comparative data shown 
by the Pie charts on the map. 

 
Column chart  

Users can view the data in the form of column charts plotted on the basis of the heat of the attribute 
selected in the Measure and Filter. User can easily analyze the plotted data on the basis of the proportions 
shown by the respective columns. 
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o Hover: On hover, it shows the details of that Boundary/Pie chart/Column chart 
o Summary Card: The user can click on any Boundary/Pie chart/Column chart to get the summarized 

information of the same.  

 

 
 

 
 

Note: If Pie chart/Column chart is selected as the Display type, the option of Territory under Region 

Type will not be available. 
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Search: 
Clicking on the ‘Search’ button will plot the addresses of all the records that were selected in the view and 
has already been geocoded. Records that do not have their latitude/longitude updated in the record will 
be ignored and will not be plotted on the map. 
 

Summary card: 
Every time the users create a heat map visualization, a 
‘Summary Card’ summarizing the aggregate 
information for the complete heat map will open up. 
This gives the users a brief summary of the heat map 
they created. The measure is also summarized by 
default. 
  
 
 
 

The user can also click on any region plotted on the 
map to open the summary card for that region. This 
will also filter the data of the region in the data grid. 
To differentiate between the summary cards, the 
individual summary cards have the region 
name/number as the title.  
 

If the user has selected a field attribute in the ‘Filter’ 
dropdown, the summary card will further 
summarize the information for the selected 
category filter as well.  
 

Export to Excel: The search results are listed by the grouping selected at the bottom of the screen and 

user can further export these data points using this button as shown below; 

 
This functionality adhere to CRM security roles, if the user does not have permission to ‘Export Data to 
Excel’ in CRM, then he/she will not be able to export data from Maplytics.  
Zoom Level of Heat Map uses personalized ‘Zoom Level’ setting for the logged in user. Also, the color scale 
for the Measure will be fetched from the defined ‘Heat Map Measure Color Scale’ in the Entity Category 
configuration on the Entity Map for that particular entity.  

Print: Clicking on the print button will print the heat map, as shown in the screenshot below:  
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Note: A4 size paper with landscape mode is recommended while printing. 
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Support for CDS 
If user does not have Dynamics CRM, they can still use Maplytics by subscribing for the PowerApps 

platform. This platform comes packaged with some base entities that includes Accounts and Contacts 

along with other platform entities to provide support for it security and other infrastructure. 

To use Maplytics within PowerApps, user can follow the steps mentioned below: 

A. Go to admin.powerapps.com > log in using PowerApps credentials.  
B. Click on ‘New environment’ > Enter the details > Create an environment  

 

 
 Click on ‘Create database’ > Select the required details > Create database 

   
 Click on ‘Navigate to other Applications’ > All apps > Powerapps > Select required environment 

https://admin.powerapps.com/
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Import Maplytics solution  

 Click on solutions at the left navigation pane > Import > Maplytics. This will create the Maplytics 
App. 
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 To access the Maplytics App, click on Apps at the left navigation pane > Select Maplytics App.  
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Clicking on the Maplytics app, following Maplytics dashboard will open.  

 
o Activate and configure Maplytics  

To access the Maplytics user needs to Activate and Configure Maplytics to start the license 
and configure the basic Entity maps, Dashboards and Census data.  

 Go to Settings > License registration > Click on Activate  
 Go to Settings > License registration > Click on Configure 

o Add users to Maplytics team   
 Go to Settings > Teams > Maplytics team > Add users 

 
 
 
 
 
 
 
 
 
 
 

Note:  
1. Entities of leads, Cases, Opportunity, Invoices are not available in PowerApps 

2. Marketing lists are not available  

3. While configuring, four Entity maps will get created for Accounts, Contacts, Appointments and 

Customer Address 

4. Only three dashboards will get shipped on configuration 
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Access Maplytics in PowerApps  

User can use the credentials of the environment to log in to PowerApps and select the Maplytics app to 
perform Maplytics features. Use the buttons ‘Details Map’ or the ‘Heat Map’ to open the respective maps.  
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Maplytics Dashboard 
The users can define their Dashboard views for Maplytics and include them as web resources in standard 
Dynamics CRM Dashboards. 

 
Maplytics ships with five pre-defined Dashboards for various Sales and Service Modules for different user 
roles. To set up more dashboards, please refer the ‘Installation Manual’. 
 

Steps to add Maplytics View to Dashboard 

To include the Maplytics component in 
Dashboard, click on the new button and select to 
add Web Resource. Select 
‘ikl_/Maplytics/Maplytics.Dashboard.html’ web 
resource and set the name of the Dashboard 
record in the custom data parameter to be passed 
to the HTML web resource. 
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Create a route dashboard 

To plot route on a CRM dashboard follow the steps mentioned below: 
 

1. User needs to include the Maplytics Detail Map component on the Dashboard. To do this click on 
the ‘New’ button in the section of dashboard and select ‘Add Web Resource’. Select 
‘ikl_/Maplytics/Maplytics.DetailMap.html’ web resource.  
 
Go to Sales > Dashboards > Click on “New” button 

 
 

2. Choose any layout as shown below: 

 
 

3. Provide the dashboard name and click on the web resource button to add the Detail map HTML 
web resource.  
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4. Add web resource :‘ikl_/Maplytics/Maplytics.DetailMap.html’ web resource  
5. Add a parameter in Custom Parameter (data) field as <Dashboard Name>||dashboard||true 

and click on ‘OK’ 

 
6. After saving the dashboard and user can see the route plotted on the dashboard.    
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Note: Only 25 waypoints can be added into the route. 
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Workflows  
Maplytics ship the following workflows: 

1. Geocoding workflows – This geocodes addresses of the records and provides the values for respective 

Latitude and Longitude. 

2. Territory Assignment workflow – This assigns territories to CRM records on the basis of the addresses 

in the respective records.  

3. Driving Instructions workflow – This automatically generates directions (in HTML and Plain text 

format) between two related entity records using their respective addresses.  

4. Get Time zone workflow – This provides the time zone of the respective records in which they lie 

based on their addresses.  

Geocoding workflow is configured for Account, Lead, and Contact entities and Territory workflow for 

Account by default. The user can set up these workflows for custom entities also.  

 

 

Note: To run the workflow, please make sure the Microsoft Dynamics CRM Asynchronous 

Processing service is running as shown in below screenshot.      
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Configure Geocoding workflows for custom entities 
1. Go to Setting > Processes > Click on ‘New’ to design a new Workflow Process. 
2. Write Process name, choose ‘Workflow’ under category section and select desired entity as 

shown below; 

 
 
 
 

3. Select ‘Organization’ under ‘Scope’ dropdown. Select ‘Record is created’ and ‘Record fields 
change’ options as shown below: 
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4. For the Record fields change option, select all of the address fields to ensure the address is 
geocoded when any of the address fields is changed as shown below; 

 
 

5. Select the Inogic.Maplytics.Geocoding workflow assembly from the Add step menu as shown 
below; 

 

Note: Please don’t select Latitude & Longitude field attribute here.  
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6. Click on ‘Set Properties’ and set the address parameter as shown in below screenshot for the 
workflow assembly; 

 
7. Choose ‘Update Record’ from ‘Add Step’ menu after selecting ‘Set Properties’ record and select 

same entity for which workflow is being created. 
8. Click on ‘Set Properties’ of the new record and in the update window set the Latitude, Longitude 

and Rating to the output parameters returned by the workflow assembly as shown in the 
screenshot below; 

 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

Note: For custom workflows, add an 'AND' condition, if the address fields are not blank as shown in the 

above screenshot. This will avoid the trigger of the workflow if the address fields do not have any value.  
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Geocoding Confidence Rating: 
User can also check the geocoding confidence rating provided by Bing Maps. A ‘Rating’ field can be added 
that shows the confidence rating as High, Medium or Low. The ‘Rating’ field is set in the workflow as 
shown in the above screenshot. 

  
 

 
 
 

Note:  

 Latitude and Longitude fields should of data type: ‘Floating Point Number’ with precision set to 
5. Add minimum to maximum range of fields respectively Latitude (-90 to +90), Longitude (-180 
to +180). 

 Geocoding Confidence Rating cannot be checked for Geocoding plugin 
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Configure Territory Assignment workflow for custom entities 

 
1. Follow the Steps 1 – 3 from configuring 

geocoding workflow for custom entities. This 
will help you create a new workflow.  

2. For the Record fields change option, select all 
of the address fields to ensure the territory is 
changed when any of the address fields is 
changed as shown below; 
 

 
 
 
 
 
 
 
 
3. Click on ‘Add Steps’ and add ‘AssignTerritoryWorkflow.AssignTerritory’ assembly as shown below; 
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4. Click on ‘Set Properties’ and set the address parameter as shown below and Save this;  

Configure Get Time Zone workflow 
 
1. Go to Settings > Processes > Click on ‘New’ to design a new Workflow Process. 
2. Write Process name, choose ‘Workflow’ under category section and select desired entity: 
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3. Select ‘Organization’ under ‘Scope’ dropdown. Select ‘Record is created’ and ‘Record fields change’ 

options. 

 
 
4. For the ‘Record fields Change’ option, select all of 

the address fields to ensure the address is 
retrieved when any of the address fields is 
changed. 
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5. Select the Inogic.Maplytics.GetTimezone workflow assembly from the Add step menu. 

 
 
6. Click on ‘Set Properties’ and set the address parameter as shown in below screenshot for the 

workflow assembly. 
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Here, user needs to specify the address fields on the basis of which user wants to get the time zone. After 

this user needs to set the time zone in field (string type). Please follow below steps for the same: 

1. Choose ‘Update Record’ from ‘Add Step’ menu after selecting ‘Set Properties’ record and 
select same entity for which workflow is being created. 

2. Click on ‘Set Properties’ of the new record and in the update window set the TimezoneName, 
TimezoneAbbreviation to the output parameters returned by the workflow assembly. 

 
 

Once user finishes all the above steps and activates the workflow, 

user can run it on any record of the respective entity which has 

address data. This will provide set the time zone set for the record 

as shown below. 
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Configure Driving Instructions workflow 
7. Go to Setting > Processes > Click on ‘New’ to design a new Workflow Process. 
8. Write Process name, choose ‘Workflow’ under category section and select desired entity as shown 

below; 

 
9. Select ‘Organization’ under ‘Scope’ dropdown. Select ‘Record is created’ and ‘Record fields change’ 

options as shown below; 
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10. For the ‘Record fields Change’ option, 
select all of the address fields to ensure the 
address is retrieved when any of the 
address fields is changed as shown below; 
 

 
 
 
 
 
 
 
 
 
 
 
11. Select the Inogic.Maplytics.DrivingInstructions workflow assembly from the Add step menu as shown 

below; 
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12. Click on ‘Set Properties’ and set the address parameter as shown in below screenshot for the 

workflow assembly; 

 

 
In ‘FromAddress’: Select the address fields of the entity that you want the direction ‘From’. Select 
the all address field i.e. Steet1, Street2, and City etc. and ensure sure you keep space between 
two fields. 
{Address 1: Street 1(Account)}   {Address 1: Street 2(Account)}  {Address 1: City(Account)}  {Address 

1: State/Province(Account)}         
 

In ToAddress: Select the address fields of the entity that you want the directions ‘To’. Select the 
all address field i.e. Steet1, Street2, and City etc. and ensure to keep space between two fields. 

 
Travel Mode: Select the Travel mode. For example (Driving, Walking, Transit). If you do not specify 
the Travel mode then it will take Driving mode by default. 

 
Distance Unit: Select the Distance unit. For example (Mile or mi, Kilometer or km). If you do not 

specify the unit then it will take Kilometer as default unit. 

 

13. Click on add step -> Send Email -> Click on set property 
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Click on Email body -> Select Look for -> local value “inogic.Maplytics.DrivingInstructions. 

DrivingInstruction” 

 

Select DrivingInstruction for plan text or DrivingInstructionHTML for html page. Click on save 

and close. 
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14. The driving instructions will be returned both in HTML and Plain Text format as an output parameter 

to this workflow. User can use either of them. For example we have used HTML formatted direction 
instruction in Email here.  
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Maplytics Batch Processing Tool  
The workflows for Geocoding and Territory Assignment designed can be used on a day-to-day basis for 
addresses that are changed or added occasionally. However, for bulk geocoding/territory assignment on 
data, we recommend using the Batch Processing tool. This tool ensures that the bulk geocoding on records 
is handled in single batch. While in the territory assignment, this tool helps to assign the respective 
territories to all the selected records based on their Latitude and Longitude values. 
 

 
 
 
To run the tool, Extract the Batch 
Processing tool .zip file and run the 
BatchProcessingTool application. 
 
 
 
 
 
 

Executing Batch Processing Tool 
 
Connection Details: 
Please enter the CRM details on this screen. The users have to enter the following details: 

Deployment model: The user can select either of the options given in below screenshot 
depending on their deployment. 
CRM Server: Please enter the serverurl of CRM. For example, http://<servername>:<port> or 
https://<orgname>.crm.dynamics.com 
Organization: If the deployment model is ‘OnPremise’ then the user has to specify the 
organization name. For other deployment models leave this blank. 
When the user enters the server URL  in case of On-Premise deployment model, the organization 
list will be auto-populated with the organizations available in CRM. Select the organization for 
which Maplytics is to be or already has been installed. 
Username: Username of a valid CRM user. For example: mollyc@CRM166504.onmicrosoft.com 
In case of On-Premise deployment model, the organization list will be auto-populated with the 
organizations available in CRM. Select the organization for which Maplytics is to be or already has 
been installed. 
Password: Password of CRM user.   

 

Note: To run this tool, the user needs to make sure that machine has Microsoft .net framework 4.0 

and Maplytics installed in Dynamics CRM.  

mailto:mollyc@CRM166504.onmicrosoft.com
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User can also use their Client Id and Client secret key to log in for their respective CRM using Application 
user.  
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Choose Option: Here, the user can make selection whether they would like to run this tool for Geocoding 
(Batch Geocode) or Territory Assignment. In this example, we have chosen Batch Geocode as shown 
below: 

 
Entity Selection and Filtering: 
Please find the details of the same below: 

 Entity: Select the entities on which the user would like to run this tool.  

 Views: Once the user selects the entity, all the views defined for this entity are populated in the 
list of views. Select the required view.  
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Results and Log Settings: 
Since this is executed as a batch process in the background, enter the email address, if the users would 
like the job results to be mailed to them.  

 
Progress : 
In this section, the user can see the progress of the geocoding process. 

 

 

Note: The Batch Processing Tool takes time to process based on the number of records selected. 

Please do not close the window until this process is completed.   
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Record Summary:  
 
Geocoding:  
Bing Status: This shows the number of the records for which the geocoding from Bing maps were 
successful or failed.  
CRM Status: This shows the number of the records for which the updation of geocordinates (Latitude & 
Longitude) to the respective CRM records were successful or failed. 
 
After completing the geocoding process, the user can download the results. The results will be 
downloaded in CSV format. User can check the columns of CRMDescription and BingDescription in the 
result to check the reason for failure of processes on the records.    
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Territory assignment:  
CRM Status: This shows the number of the records for which the updation of Territories  for the respective 
CRM records were successful or failed. 
 

 
 

 
 
 
 
 
 
 

Note:  

1. If a user selects ‘All records’ for an entity, then a view for that entity cannot be selected. 
2. A user cannot select an entity with a same view twice. 
3. If the user adds an entity with a view and then selects ‘All Records’ for the same entity, it will 

remove all the views selected for that entity with the user’s permission.  
4. All of the above instructions apply for running Batch processing tool for Territory 

Assignment. 
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Set colors and pushpins for Categories 
The users now have the ability to define colors and pushpins to visualise the caetgorised pushpins on map. 
This way user will be able to differentiate between the records that belong to different categories. To set 
the pushpins and colors define the color of the category attribute, the users have to follow the below 
steps: 

 Go to Settings > Entity Maps and select the entity map of the entity for which the user needs to 
define the color and pushpins. 

 
 Click on the plus (+) icon of the Category Configuration subgrid to open the new Entity Category form. 

Select the name of the category attribute 
in the Category text box and save the form. 

 The user can select only OptionSet, Two 
options, Numeric, String, Lookup and 
Money attributes to define category 
colors. 

 Colors and shapes will be auto-populated, 
the user can also set their own preference. 

 The user can click on the         ‘AutoSet’ 
button to set random colors as well as 
pushpins for all the values, or the user can 
click on the Discard button to cancel the 
changes. 
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Maplytics – Tablet / Mobile 
For Dynamics 365 v9.x, Maplytics can be accessed from the Entity homepage and entity form using the 
‘Detail Map’ , ‘Heat Map’ and ‘Map’ button respectively.  
 

     
 
 
 

     
 
 
 
 
 
 
 
 

Mobile Tablet 
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Maplytics can also be accessed from the Dynamics 365 App for Phones and Tablets (both on Dynamics 
365 v8.2 and v9.x) using a dashboard for detail map. To open Detail map; Go to Dashboard > Maplytics 
Detail Map as shown below: 
 
 

     
 

Detail Map  

The Detail map consists of the following components. There are five ways to plot the data on Map, similar 

to the Detail Map on browser: 

 By Location 

 By Region 

 By Drawing 

 By Territory 

 By Template 
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Proximity 

Enter the radius for the proximity search. The Proximity can be provided in either Miles or Kilometers.  
 

     
 
 

Concentric Proximity Search 
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Summary Card 

Now users can also get the aggregated information for a particular closed shape on the map with Summary 
Card. 
 

    
 

Search POI  

Ability to search for any Points of Interest (POI) like ATMs, restaurants, hotels, coffee shops, etc. in the 
vicinity. This will be plotted alongside the CRM data. 
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Category Filter 

 
User can categorize the data on the basis of an attribute of the Entity  
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Current Location 

This is used in combination with Proximity to specify the center point for the proximity search. By default, 
this field displays the address stored in the Maplytics Personalized record of the logged in user. 
 

Set GPS Location as the current location 

The user can also locate the GPS location of phone/tablet devices using  button.  
 
 

     
 
GPS location is represented by ‘Blue’ circle on the map. It will automatically update the user’s current 
location, making it easier to perform proximity (Near-Me) searches.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: Please ensure the following points for the GPS functionality to work: 

 Provide ‘Location’ permission to Dynamics 365 App in phone / tablet device 

 GPS location is turned ON of respective devices 

 ‘User Content and Location’ is tuned ON in Dynamics 365 App 
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Tooltip Card 

Every Pushpin will display the record name, address, as well as the contextual data defined in the tooltip 
section of the Maplytics Configuration. The user can open the record, change owner and run workflow 
using the available quick actions button. 
 

      
 

Contextual Menu 

To get a contextual menu on the map, long press anywhere on the map. Pushpin Contextual menu 
provides the following additional options. These option provides commonly used features in Maplytics 
like Set as Current Location, Origin, and Adding to Route, etc. 
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Set As Origin:  
Selecting this option will set the address of the pushpin as the start location of the route. 
 

Set As Destination:  
Selecting this option will set the address of the pushpin as the end location of the route. 
 

Add to Route:  
This option will set the address of the pushpin as a middle waypoint of the selected route. For example, if 
the users already have Point A and Point B selected as their route, and click on the Add To Route option, 
then the Point B will become Point C, and the address of the selected pushpin will become the Point B of 
their route. 
 

Set As Current Location:  
This option is used to set the address of the pushpin as the current location, which can be used for 
proximity search. For example, if the user wants to plot all the leads that are within a radius of 100 miles 
from a particular record then the user can click on the Set As Current Location option to set the address 
as the current location and then the user can plot the records around this location. 
This option also removes the additional step to type the current location manually for the proximity 
search. 
 
Set As POI Location:  
This option helps the user to set the center point for the Point of Interest (POI) searches like ATMs, 
restaurants, Airports, etc. Once this location is set as the POI location, the user can search for different 
POI around this location. 
 

Manage Territory:  
The user can manage the territory, i.e., assign/re-assign territory from the map using this option. 
 

Save Template:  
User can save the plotted search criteria as a template, so as to open the template directly instead of 
searching on  the map again. 
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Routing – Tablet / Mobile  

 
Another essential feature of Maplytics is Routing across multiple waypoints. Using the Contextual Menu 
options explained above, the users can add multiple waypoints to their journey. At given point in time, 
the users can add maximum 25 waypoints in direction.  
 

     
 
Once multiple waypoints have been added, click on Go button to bring up the Routing Screen shown 
below.  
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Merged Route and Plot View 

When the user plots the data and then creates a route, both the plotted data and the route will stay on 
the map. This makes it easy for the user to add more waypoints to the route without switching between 
Plot and Directions card. The route can be cleared using the ‘Clear Route’ button. 
 
 

    
 

Save Route and Plot Saved Routes 

Users can now save the route from the Dynamics 365 App for Phones and Tablets and later use the ‘Open 
Saved Route’ feature to plot the saved routes. 
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Email route - The user can email route to any of the 
Dynamics CRM records using email route option.  

 
 

Along the Route Search 

The user can also search the along the route records the same way as on the Browser. 
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Route Redirect and Copy Navigation Links 

 
Redirect with Google Maps 
 

     
 
 
Redirect with Waze 
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Heat Map – Tablet / Mobile 

 
For Dynamics 365 v9.x, Maplytics can also from the Entity homepage and entity form using ‘Heat Map’. 
When clicked on Heat Map button, it opens the heat map.  

 

     
 
 

Summary card 
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Pie chart in Heat Map 
  

      

 

Column chart in Heat Map 
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Dashboards – Tablet / Mobile 

The users can define their Dashboard views for Maplytics and include them as web resources in standard 
Dynamics CRM Dashboards. 

   
Maplytics ships with 6 pre-defined Dashboards for various Sales and Service Modules for different user 
roles. 
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Contact Us 
M/S. INOGIC TECH (INDIA) PVT. LTD.  
A-301 Everest Nivara InfoTech Park, 
MIDC, Turbhe, 
Navi Mumbai - 400 705 - INDIA. 
 
E-mail: crm@inogic.com  
Twitter: @Maplytics; @Inogic 
Facebook: @Maplytics; @Inogic 
Website: http://www.maplytics.com/ ; http://www.inogic.com/ 
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