CRM WORD MERGE

USER GUIDE

Create Word Merge Templates with deep data
relationships in Dynamics 365
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Introduction

CRM Word Merge provides additional capabilities beyond the out of the box Word Templates feature.
The relationship builder allows for the selection of views that have been created for related entities
(One-to-Many and Many-to-One relationships) and include them as tables in the document template. It
also provides the ability to add “second-level” relationships and views providing much more flexibility
when building templates.

For an example scenario, consider a template based on the account entity. On the account form there
are two sub-grids for contact records. Each sub-grid is based on a different, filtered, custom system view
(e.g. one for “internal” contacts and the other for “customer” contacts). CRM Word Merge will allow the
user to add each of the views in the account template as separate tables, displaying the data as it is
represented on the CRM form. To go even further, it is also possible to drill into the Contact
relationships (e.g. Contact -> Activities) and add any of those views to the template.

The solution provides much more control over the data that can be represented in a template and adds
considerable business value.




Verify the Solution Installation
After downloading the solution from https://appsource.microsoft.com/en-us/ the following

components should be present in Dynamics 365:

1. CRM Word Merge Solution
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2. Custom Actions for Create, Upload, Replace and Merge templates
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4. Create Template/Upload Template buttons on the Document Template entity ribbon.
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5.

"Replace Template” button on uploaded template ribbon:
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"Document Templates” button on the ribbon of any entity that has a Template configured for
it. For example, as the result of creating the first CRM Word Merge template for the Account

entity, the Document Templates option will appear under the ellipse menu from the Account
form Ribbon. This will allow the user to run the template against the Account record.
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Set User permissions

1.
2.
3.

Navigate to Settings -> Security -> Security Roles.

Select the related Security Role of the user.

Click on the “"Customization” tab and provide “Organization” (green) Read permissions for
Publisher and Solution entities.
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4. Click on the "Custom Entities” tab and provide “Organization” level (green) Create, Read and
Write permissions for the “Document Template” entity and click save and close.

m I R saveandCiose [ dmactions-

@ Security Role: Account Manager

Custom Entities

@ telp -

Working on solution: Default Solution

Detolls | CoreRecords  Marketing  Sales | Service | BusinessManagement | Service Management  Customizaion = Missing Entities  Business Process Flows
Booking Timestamp 5] [@) [¥) [¥] [¥] @] U

Booking Update Trigger Q o] (@] (@] (@] o] Q O
Competency Requirament (Deprecated) [*] [*] (] [*] ("] "] 9 @
Contact Price List o @] 8] Q Qo Q Q o
Customer Asset o] o o] (o] (o] @] e] o
Delegatian [

Document Tempiate *® [ ] [ ] @] o (@] 2] O
Estimate [ [] [] [] [] [] [ [
Estimste Line ° °® ® °® ° ° ®
Expense *] "] L ] L]
Expense Category O [ ] (8] (8] @] L ]

Expense Receipt [*]

Fact L [~ [~ ("] @ "] @ @]
Field Computation o} ] o] Q o] Q Q o
Field Service Price List ltem o @] o] 8] 8] @]

Field Servica Setting Q (@] O (@] (o] @] O O
Field Service System Job QO o (@] (8] (6] o]

Filter Qo e}
Find Work Event o o] (o] Q Qe o] @] o
PR i o) e fa fa) o o fal N

Key
’7 O Hore Seiected User

Create template

1. Login to your Dynamics 365 Application

Business Unit

@ Farent: Child Business Units

@ Organization

2. Go to Settings -> Extensions -> Document Templates -> Click 'CREATE TEMPLATE'
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3. Select the entities to be used in the template. As an example, the steps below demonstrate how
to add Contacts associated with the Account (One-to-Many) and the Primary Contact for the

Account (Many-to-One).

Select the primary entity e.g. Account

Select Entity

TAccount = |

One To Many Relationships

Select Related Entity
[  account

O account

[0 account

[ actoncard

[ activityparty
[] acivilypointer

Choose related entities

Existing
Views

account_parent_account

msa_account_managingpartner

Relationship Schema

csm_account_account_MasterAccount

account_actioncard
acoount_activity _parties

Account_ActivityPointers

Under “One-to-Many Relationships” select “Contact” and choose from the list of Contact

Views from the dropdown. This will enable the addition of a table in the template to display

Contacts related to the Account.
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Under "Many-to-One Relationships” select List for Many-to-Many Relationships and

select the views from the dropdown. The example below shows the Primary Contact related to

the Account;




4.

Select Entlt}‘ Acoount L |

One To Many Relationships

Many To One Relationships

Select Related Entity Relationship Schema

[l accoynt account_parent_account

[ account msa_account_managingpartner

] account csm_accounl_account_MasterAccount
] businessunit business_unit_accounts

Wi contact account_primary_contact

If entity selection is complete click on “Download Template” and proceed to step #5
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It is also possible to select 2nd level relationships for One-to-Many Relationships and Many-to-
Many Relationships:
In One-to-Many Relationships, e.g. Account -> Contact, we can select the Contact Entity
Relationships by checking the contact entity relationship checkbox and clicking on the
hyperlink. In the figure below the relationship path is: Account -> Contacts -> Tasks (related
to Contacts)

From the Pop up window choose the related entities and click on Save and Close button.
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Save & Close

iii.  Click 'Download Template'




5. Format the Template: open the Word Template downloaded from last step
I.  Make sure the "DEVELOP” tab is enabled on the Word Ribbon, Go File -> Options ->
Customize Ribbon -> Check Developer
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ii.  Navigate to the DEVELOPER tab -> Click 'XML Mapping Pane’-> Select urn:Microsoft-
crm/document-template/entity from the dropdown

[ TP = < JE Template.docx [Read-Only] - Word - S - - T -
HOME INSERT DESIGM PAGE LAYOUT REFEREMCES MAILINGS REWVIEW VIEW DEVELOPER Feifei Qiu (Pact.. - ﬁ &

D_r 25 Record Macro oF I'E D D

== - Recording =

Visual Macros “  Add-Ins COM XML Mapping Block Restrict Document Document

Basic t. Macro Security Add-Ins - Pane Authors - Editing  Template Panel
Code Add-lns Contrals Mapping Protect Templates -~
XML Mapping T X

Custom XML Part:

| urmimicrosoft-crm/document templaterentity/ bl
< WordMerge
| b ACCOUNT

(
\



6. Add attributes from the XML Mapping into the template

To add a text field: right click the node in XML part -> Insert Content Control->Plain Text e.g.

'name’ attribute for Account

~ Account Name:

B

XML Mapping

Custom XML Part:

| urnimicrosaft-crm/document-template/entity/

¥ mergedname

maodifiedby

maodifiedbyname
medifiedbyyeminame
muadifiedon
maodifiedonbehalfby
maodifiedonbehalfbyname
madifiedenbehalfbyyominame

nam=
i Inzert Content Control

opel May
cpenaeals_oare
opendeals_state
OpENTEVENUE
openrevenue_base
cpenrevenue_date
openrevenue state
originatingleadid
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Rich Text
Plain Text
Picture
LCheckbox
Combo Box
Dropdown List

Date Picker

Note: Please refer to the FAQ section for information on avoiding an unresponsive document

when adding attributes.

i, To add an Image field: follow the same process as above, but choose “Picture” when

inserting Content Control

Account Name: name

Account Logo: |

AIVIL |\"||’J|.J|.JII IU
Custom XML Part;
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isprivate
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To add a Lookup/OptionSet field: same process as above, but it is necessary to choose
the 'ID" attribute instead of the 'name’ attribute, e.g. Ownerid instead of Owneridname for
the Owner lookup field of the Account

N XML Mapping

Custormn XML Part:

urremicrosoft-crmy/document-template/entity/

e e

L~ 4

" openrevenue_date
1 " ppenrevenue_state
Account Name: name originatingleadid

I
I

- I griginatingleadidname
&

E This nage " onginatingleadidyocminame
ot
;ngﬁplzuyr;delnﬁy b overriddencreatedon
b owneridname
P owneridtype

Account Logo: I owneridyominame
I ownershipcode
Owner| I ownershipcodename

Add a One-to-Many relationship, e.g. Account related Cases

a. Insert a 2-row table, the number of columns depends on how many attributes you
want to show and you have in the selected view e.g. add 4 columns to display
Case Number, Title, Owner, Case Requestor

b. Table header is static text, which can be edited to whatever is desired, it is not
necessary to use the system field name

c. Use the same approach as described in section 6 above to add these attributes
from the XML part

Case Murmber Tekle e Caae Regueertor

| Bckyinee bt sty Gttmend

d. To display all the related records select the 2nd row, right click "View-All Cases’
under XMP Mapping -> Insert Content Control -> Repeating
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Add Many to One relationship e.g. attributes for an Account’s Parent Account
i.  Navigate to many to one relationship, in this template, we selected Account-
account_parent_account, expand, add any attribute if needed follow the same

approach as described in last steps.

[d

ParentAccount
Name

|_| parentaccountid |

addressl_telephonel
websiteur]

revenue

ownerid

XML Mappmg
Custom XML Part:

I urn:microsoft-crm/document-template/entity/

-

R o
transactioncurrencyidname

traversedpath

utcconversiontimezonecode

versionnumber

websiteurl

yominame

AMMNOTATION-Account_Annotation
INCIDEMT-incident_customer_accounts
OPPORTUMNITY-opportunity_customer_accounts
ACCOUNT-account_parent_account
accountcategorycode
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accountcategorycodename
accountclassificationcode
accountclassificationcodename
accountid

accountnumber
accountratingcode

v v v A )

accountratingcodename
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b. Add Many to Many relationship, e.g. Marketing lists, the account is added to:
(list-listaccount_association)

i. Inserta2-row table, the number of columns depends on how many attributes
you want to show and you have in the selected view. Table header is static
text, which can be edited to whatever is desired, it is not necessary to use the
system field name

ii. Use the same approach as described in step 6 above to add attributes from
the XML part

ii. Select the 2"~ row, right click 'View-Active Marketing Lists’ under XMP
Mapping -> Insert Content Control -> Repeating.

telephonesd
telephone3
teritorycode

garketing Lisks (N b) ki
| List Name ‘ Type ‘ Purpose ‘ CreatedfromCode | Listid | territoryid
listname. \ type \ purpose \ createdfromcode | listid territoryidname
= tickersymbol
timezoneruleversionnumber

transactioncurrencyid
transactioncurrencyidname
traversedpath
utcconversiontimezenecode
versionnumber
websiteurl
yominame
I annotation-Acceunt_Annotation
I contact-contact_customer_accounts
I incident-incident_customer_accounts
P account-account_parent account
' contact-account_primary_contact
4 [ist-listaccount_association

View-Active Marketina |iste
listn  Repeating Insert Content Control v

lastusedon Map to Selected Content Control




After adding all the desired attributes save the template into a local folder.

**Below is a sample template, which contains all possible types of attributes and relationships

Account Overview

Name name

Address address1_linel
address1_city
address1_country

Revenue revenue

Website websiteurl

Created on createdon

"

# of Employee numberofemployees Parent Account parentaccountid
Tel telephonel MName address1_telephonel
Primary Contact | primarycontactid websiteur]
Owner ownerid revenue

Status statuscode ownerid
Related Cases

Case Number Title Owner Case Requestor
ticketnumber title ownerid customerid
Marketing Lists (N: N)

List Name Type Purpose CreatedfromCode | Listld
listname type purpose createdfromcode | listid
()




Upload template using CRM Word Merge

1. Log in your CRM Application
2. Go to Setting -> Document Templates -> Click 'UPLOAD TEMPLATE’

3. The System pops up the below dialog window:
a. Fillin the Template Name
b. Choose and upload a locally saved template

Upload Template

Template Name

Template File | Choose file | Na file chosen

Submit

4. Click 'Submit’. The template will be listed under the "Active Document Templates” view.

= Dynamics 365 ~ Settings ~ | Document Templates >

=+ NEW [ DELETE | - QUCREATETEMPLATE  DLUPLOADTEMPLATE e EMAILALINK | = [¥} RUN REPORT ~ mEXCEL TEMPLATES ~ a._, EXPORTTOEXCEL | ~ @ IMPORTDATA | - exs.

+ Active Document Templates v

v Name Crested On
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Merge a template using CRM Word Merge
1. Go to Sales -> Account -> Open an Account Record which you'd like to generate template
2. Click ".." -> DOCUMENT TEMPLATES -> Select Template
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] Word Templates
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3. Download and view the merged document:

Account Overview

Mame Adventure Waorks {sample}

Address 4405 Balboa Court

Santa Cruz

U5,

Rewvanus

S60,000.00

Website

http -/ fwremer adwenture-works.com)/

Created on

127222015 1038 PM

# of Emplayes 4,300 Farent Account A, Datum Corporstion
Mame [=ampie)

Tel 5550152

Primary Contact Mancy Anderson {sample) htop: /fvwrenee adstum_comy

Chawner hadhuri Durgam 510,000.00

Status Active hizdhuri Durgam

Related Cases

Case Mumber Title Charner Ca=e Requestor

CAS00026-TZF7CS

M=ad service festure
information (ssmple)

Mzdhuri Durgam

Adwventure Waorks {sampl=}

CAS-DO02Z0-VLCTFFT

Product festura
information required
[szampila)

Mizdhuri Durgam

Adventure Waorks {sample}

Marketing Lists (N: N)

List Mams

Type Purpose

CreatediromCode

Listld

ML

Static

Account

574elebc-64a5-
e511-BDdd-
3B63bb2eSb20:

MLZ

Static

Acoount

51bBS7ed-64a5-
2511-Bidd-
3B63bb2eSb20

Replace template using CRM Word Merge

1. Go to Settings -> Document Template -> Select template
2. By clicking on the "Replace’ button on the ribbon the following pop up will appear:

Replace Template

Template Name

Template File

| Choose file | No file chosen

Replace

~




3. Provide the new Template Name and Template File then click the “Replace” button.
4. Refresh the CRM View and notice that the Template Name and Template File have been updated.

]
18 J

~



FAQ

Q. Why does the template become unresponsive when adding attributes from the XML Mapping?

A. This may occur if multiple relationships and many fields are selected in the "Developer” tab. If the
document does become unresponsive waiting for some time (for resources to free up) usually results
in the document becoming responsive again.

Q. Can repeating control be added to tables in the vertical direction?

A. No. The repeater control will not produce the desired repeating result in a vertical direction. It
should be used to create repeating rows only in the horizontal direction.




